Charging problem, anybody else?

Status
Not open for further replies.
Joined
Feb 14, 2007
Messages
167
Location
Lake County Ohio
Ok so my 396t is having problems, i talked to a service rep from uniden today and he said something about the pin in the scanner that when you hook it up to the charger is bad. He said that it would need repair for the standard $60 bucks. Anybody else have this problem. I would leave it alone, but the scanner wont charge and when i plug it into the charger, it just says no charge on the screen. Damn!

Roughly how long does it take for a scanner to be sent down to fort worth, repaired and sent back? Do they do a good job, and is it really worth the 60 bucks?
 

800crazy1

Member
Joined
Mar 2, 2004
Messages
362
how long have you been using the rechargables that wont charge ? i like n4yek use an external charging unit , like he said , 20 bucks walmart , i use a duracell 6 hour charger and have the energizer 15 min rapid charger. try a different set of rechargables if anything. then if that doesnt work do what ya gotta do.
 

jakegday

Completely Banned for the Greater Good
Banned
Joined
Jun 24, 2006
Messages
145
thanks to rechargeable batteries, i dont even know if my ac adapter works
 

_godawgs_

Member
Joined
Oct 11, 2007
Messages
31
Location
Ga
Batt Switch

I'm sure you already have checked this, but i'll say it just in case..it happened to me once..Make sure the switch in the battery compartment is all the way over to the Ni-Mh side...somehow mine had been pushed to the middle of the switch and would not charge my batts...dont know why it happened but i always check that switch when i put batts back in.
 

kennyloatman

Member
Joined
Jun 25, 2007
Messages
578
Location
Cumberland Co., NJ
_godawgs_ said:
I'm sure you already have checked this, but i'll say it just in case..it happened to me once..Make sure the switch in the battery compartment is all the way over to the Ni-Mh side...somehow mine had been pushed to the middle of the switch and would not charge my batts...dont know why it happened but i always check that switch when i put batts back in.
That is what it sounds like to me too, mainly if the screen says "charge off" when the scanner is off and plugged into the charger.
 

troymail

Silent Key
Joined
Dec 19, 2002
Messages
9,977
Location
Supply (Lockwood Inlet area), NC
I found that the internal chargers in both my 396 and PSR-500 seem to be "burning up" batteries so I stopped using those in favor of external "rapid chargers" (for now)... a little experiment.

I was charging a set of Duracells each night in my PSR-500 -- purchased in November -- they are now worthless... The other set I had in my 396 were on nearly permanent charge - always hooked to the AC adapter - so they should have charged and stopped since the AC power was there - but they still seemed to burn up the batteries because when I took it off charge, the batteries only lasted about 1-2 hours before the radio started beeping.
 
Joined
Feb 14, 2007
Messages
167
Location
Lake County Ohio
ok guys, just took the Ni-Mh batteries out of the scanner, plugged it in and it works fine, gets power and everything with the AC power. Thanks to you, i am now convinced its either my internal charger or the battries are bad. Im gonna do what was suggested and just purchase the rechargeables from wallyword with an external charger and take them out at nights and charge them and run the radio off the AC power. Thanks alot guys... you saved me $60!!! And for those of you who recomended the swtch, thanks the guy from uniden told me about that, but it was on the Ni-Mh side.
 
Status
Not open for further replies.
Top