DSD+ does not decode P25

Status
Not open for further replies.

OldDrunk

Member
Joined
Aug 28, 2008
Messages
22
I can't seem to get DSD+ to work. When I tune to a P25 station, DSD+ starts scrolling text and recognizes the signal as P25, but it does not seem to be able to decode it, and there is no audio coming from the speakers. The scrolling text in DSD+ does not have the word "voice" in it, and there appear to be error messages as well. I tried several different P25 channels with the same results.

I installed VB Cable and I believe that I set all the recording and input and output devices in SDR# and in Windows correctly. Please see the screenshots. Can anyone please help?

1. Why is DSD+ not able to decode the P25 signal?

2. If I am tuned to an analog channel, I also have no audio when the output in SDR# is set to VB Cable and DSD+ is running. Shouldn't I be able to hear analog transmissions, since there is no decoding required?

3. If the playback device in Windows is set to VB Cable, as per instructions, how would the sound get to the speakers?
 

Attachments

SCPD

QRT
Joined
Feb 24, 2001
Messages
0
Location
Virginia
I see three problems.

1. You've set an offset. Correction and offset are two different things. You'll have to calibrate your RTL stick by setting the correction value. The offset should be zero. Click on the RTL-SDR USB button to set the correction.

2. There is no signal under the red line in the waterfall. After calibrating your RTL stick, tune to the voice channel and look for a dashed line that lines up with the vertical red line.

3. The bandwidth is too wide. Drop it down to around 7khz for P25.
 

OldDrunk

Member
Joined
Aug 28, 2008
Messages
22
Thanks for all the replies.

I set the playback device in windows to "speakers", and DSD+ now decodes the digital transmissions sporadically. At times DSD+ seems to be decoding correctly, but there is no audio. Other times the audio is garbled. I am guessing the decoding is sporadic for two reasons. First, the stock antenna does not provide very good reception. Also, the CPU in my laptop may not be powerful enough. The laptop is at least six years old and has a dual core pentium at 1.7 GHz. So my next step is to connect a better antenna.

I will post an update once I got a better antenna hooked up.

For now, I believe these are the correct settings:
1. In SDR# set the "Output" to "MME Cable Input"
2. In Windows set the "recording" to "Cable Output"
3. In Windows set the "playback" to "Speakers"
 

rrbum

Member
Joined
Feb 28, 2012
Messages
165
I don't like all the "no sync" messages you are getting. The program must remain synced up whilst decoding. Is the signal strong enough for decode? Is your dongle corrected to be accurately tuned? Me thinks weak signal.
 

joeuser

The Wretched
Joined
Feb 9, 2014
Messages
1,614
Location
North Central Kansas
I would think your system dual 1.7 would be enough, esp. if you turn down the resolution on the waterfall. SDR# uses a lot of horsepower, it was one reason I just stopped using it and just use Unitrunker & DSD+
 
Status
Not open for further replies.
Top