DSDplus 229 fmp24 issues?

Status
Not open for further replies.

dubs0980

Member
Premium Subscriber
Joined
Apr 4, 2012
Messages
116
I've been having an issue with decoding with the new fastlane release. When using fmp24 to dsdplus via VAC as well as fmp24-cc to dsd-cc, both dmr and p25 (the only two formats I tried) come through with choppy audio and errors in a sort of rhythm. It's almost like every half second dsdplus shows some error and audio cuts out. I set up a fresh copy of 2.29 and same thing happens.

Fastlane 2.18 everything works great

SDR# via VAC to the 229 DSDplus works great.

FMP24 from 2.18 to 2.29 DSDplus works great.

I don't recall but I believe I even tried 2.18 fmp24-cc to 2.29 dsdplus-cc and it worked too.

Anyone else getting a similar issue, or have any suggestions that might help?

Thanks guys, and thanks DSD crew for the great work!
 
Last edited:

thewraith2008

Member
Joined
Nov 22, 2016
Messages
755
Hello,

Have you checked your PPM value?
Check that your Gain is OK.
Check that your audio piping settings are correct.
Any reason why your not using FMP24 and DSD+ via a TCP link. Some features only work through TCP.

You said you have issues "When using fmp24 to dsdplus via VAC as well as fmp24-cc to dsd-cc"
But then say "FMP24 from 2.18 to 2.29 DSDplus works great" and "I don't recall but I believe I even tried 2.18 fmp24-cc to 2.29 dsdplus-cc and it worked too."

Cheers.
 
Last edited:

dubs0980

Member
Premium Subscriber
Joined
Apr 4, 2012
Messages
116
Sorry I wasn't very clear. I was under the impression all the 'cc' and 'vc' versions only use the TCP link? (at least that's how I've been running them.)


ppm is spot on at -1.0

Gain isn't too high. They are strong signals but peak below the top and I turn then down/up accordingly.

Audio paths seems correct.

My older 2.18 folder runs just fine, whether TCP link or VAC.

2.18 FMP24 and FMP24-CC to 2.29 DSDplus or DSDplus-CC runs just fine.

The problem occurs when using fmp24 and fmp24-cc from the new 2.29. That makes me think it's got something to do with the new release of FMP24 or some type of new setting or of course something I've done wrong when updating.

thanks for taking the time.
 

thewraith2008

Member
Joined
Nov 22, 2016
Messages
755
Could very well be a setting as others are using FMP24 v2.14 with no issue.

You should post the command lines from the batch files you are using.
FMP24-CC
CC
FMP24-VC
VC

FYI. To clarify versions
In the DSD+ Public Release v1.101, FMP is v1.4t
In the DSD+ FL v2.18 release, FMP24 is v2.11
In the DSD+ FL v2.29 release, FMP24 is v2.14
 

DSDPlus

Member
Joined
Jul 24, 2014
Messages
377
I've been having an issue with decoding with the new fastlane release. When using fmp24 to dsdplus via VAC as well as fmp24-cc to dsd-cc, both dmr and p25 (the only two formats I tried) come through with choppy audio and errors in a sort of rhythm. It's almost like every half second dsdplus shows some error and audio cuts out. I set up a fresh copy of 2.29 and same thing happens.

Fastlane 2.18 everything works great

SDR# via VAC to the 229 DSDplus works great.

FMP24 from 2.18 to 2.29 DSDplus works great.
This may be related to the changes made to support NEXEDGE AVL.

The problem goes away if you use FMP24 v2.11 with DSD+ v2.29?

What are the computer specs?
 

dubs0980

Member
Premium Subscriber
Joined
Apr 4, 2012
Messages
116
Wraith: Thanks for the clarification. The only self made batch file is an FMP24 with -O2 -P-1.0 to point it to VAC and save me from changing the ppm from the window. Same results. Everything else is bone stock.

DSDPlus: Correct. FMP24 v2.11 works perfectly with DSD+ v2.29. (and DSD+ v2.18)

FMP24 v2.14 exhibits the issue with DSD+ v2.18 and DSD+ v2.29.

I've been running these on a pretty clean Toughbook Cf-30 1.6ghz Core 2 Duo L7500 MK2, windows 7, 4meg ram, ssd. Maybe I'll try my other netbook and see it does the same.

I would certainly expect people to notice this if everyone was having the same issue. DSD+ is basically choking on errors every half second. So I suspect its something on my end.
 

DSDPlus

Member
Joined
Jul 24, 2014
Messages
377
In advanced system settings, disable all visual effects except smoothing edges of screen fonts. Try adjusting processor scheduling for best performance of programs or services. Check Task Manager for loading levels. Minimize FMP24 windows.
 

dubs0980

Member
Premium Subscriber
Joined
Apr 4, 2012
Messages
116
That might have helped a little. Certainly not perfect but I had slightly longer streams of decoding than before, but would still choke up. I kept going back and forth with the visual effect settings and watching the cpu usage and decode. With the best performance (smoothing still checked) setting and everything but the event log minimized I was seeing sub 10% processing and minimal memory usage during decode. However even with full appearance and everything up on the screen it's maxing out at ~50% cpu. With best appearance and fmp minimized it's maxing out at ~20%.

I'm seeing similar cpu usage and memory trends when running FMP24 v2.11 and decode is strong.

Thanks for the help guys, I appreciate it.
 

pmb1010

Member
Joined
Jun 29, 2015
Messages
24
So... I just got signed up for Fastlane. Received 2.29 ZAP file today.
I've been using the 101T version for a while now, and recently got a 2nd SDR radio.

If I wish to try FMP24 V2.11 how do I do so? Or just wait for next release.

(I seem to have choppy audio, and yes minimizing the screens does seem to help)
 

thewraith2008

Member
Joined
Nov 22, 2016
Messages
755
If you are using standard batch files with the exception of FMP24-CC then using -O2 does nothing as the CC batch file only accepts the TCP link.

Did you change "-o20001" to "-o2" or add it to line. If you changed it then FMP24 can't talk to DSD+.

Standand CC batch file (from v1.101 release):
DSDPlus -rc -i20001 -v3 -wsl400.2 -wss100.200 -wel0.1 -wcl0.445 -wes400.520 >>CC.log

Standand FMP-CC batch file (from v2.18 release):
FMP24 -rc -i1 -o20001 -P0.0 -f935.0

I'll assume that what you have shown as options are typos "-O2 -P-1.0" should be "-o2 -P1.0"
In any case I doubt this is your issue.

You said "DSDPlus: Correct. FMP24 v2.11 works perfectly with DSD+ v2.29. (and DSD+ v2.18)"
Is that using that PC your having problems with? If so then one would think your PC specs are OK.

Cheers.
 

dubs0980

Member
Premium Subscriber
Joined
Apr 4, 2012
Messages
116
If you are using standard batch files with the exception of FMP24-CC then using -O2 does nothing as the CC batch file only accepts the TCP link.

Did you change "-o20001" to "-o2" or add it to line. If you changed it then FMP24 can't talk to DSD+.

Standand CC batch file (from v1.101 release):
DSDPlus -rc -i20001 -v3 -wsl400.2 -wss100.200 -wel0.1 -wcl0.445 -wes400.520 >>CC.log

Standand FMP-CC batch file (from v2.18 release):
FMP24 -rc -i1 -o20001 -P0.0 -f935.0

I'll assume that what you have shown as options are typos "-O2 -P-1.0" should be "-o2 -P1.0"
In any case I doubt this is your issue.

You said "DSDPlus: Correct. FMP24 v2.11 works perfectly with DSD+ v2.29. (and DSD+ v2.18)"
Is that using that PC your having problems with? If so then one would think your PC specs are OK.

Cheers.

That -o2 was in reference to a simple new fmp24 batch file I created to run FMP24 via VAC to DSDplus.exe to see if works (because vac is my 2nd audio path on my machine.) All the TCP link CC batch files are un-edited. FMP24-cc v2.14 and CC v2.29 seem to see each other just fine with the TCP link but when it starts decoding the errors show up and audio is choppy. I only have issues when I run the new FMP24 v2.14 in any form. Otherwise everything else seems to play well.

All this is on the same PC.
 

thewraith2008

Member
Joined
Nov 22, 2016
Messages
755
Only other thing I can guess is see if signal polarity in the DSD-CC events window is set to "NOT inverting signal polarity" by pressing "P" with that window in focus.

You may have press by accident and DSD+ may have remembered it via DSDPlus.bin
 
Status
Not open for further replies.
Top