DSDPlus.frequencies File

Status
Not open for further replies.

RonnieUSA

Member
Joined
Aug 8, 2005
Messages
2,149
Location
Rowan County,KY (Morehead)
I have been trying to get this to work, but can't seem to.
All of my frequencies are conventional, no digital trunked.

Here are 3 of a few I'm trying to add:
460.58750
453.72500
151.71500

Thank You for any help on this.
 

RonnieUSA

Member
Joined
Aug 8, 2005
Messages
2,149
Location
Rowan County,KY (Morehead)
Here is a copy of what I'm trying to do:

; DSD+ frequency file
;
; line format:
;
; protocol, network ID, site number, OTA channel number, TX frequency, RX frequency, sort order
;
;
; use site number = 0 for network-wide definition
;
; use 0.0 for unknown frequencies
;
; use sort order = 0 to sort by OTA channel number
;
;
; protocols:
;
; D-Star
; IDAS
; NEXEDGE48
; NEXEDGE96
; dPMR
; DMR
; Cap+
; Con+
; P25
; ProVoice


NEXEDGE48, 0, 0, 460.587500, 1
NEXEDGE48, 0, 0, 453.72500, 2
NEXEDGE48, 0, 0, 151.71500, 3
 

LimaZulu

Member
Joined
Jul 7, 2011
Messages
175
Well, I never had time to edit the file so can't be 100% sure if it's going to work but.... As far as I can see you are missing some parameters. You must set option for each parameter in order as given in the example: protocol, network ID, site number, OTA channel number, TX frequency, RX frequency, sort order. Counting from left to right you set only 5 parameters out of 7. Or in ohter words you set only first 5 parameters.

protocol=NEXEDGE48
network ID=0
site number=0
OTA channel number=460.587500
TX frequency=1

As you can see the last two lines contain wrong values. I'm not sure how to find the unknown values (some of them can be seen in even log window) but if we say that all uknown values can be set to 0 it sould look something like this

protocol=NEXEDGE48
network ID=0
site number=0
OTA channel number=0
TX frequency=460.587500 (if you are sure this is TX and not RX frequency)
RX frequency=460.587500 (just for example)
sort order=1

So your furst line is going to look something like this:

NEXEDGE48, 0, 0, 0, 460.587500, 460.587500, 1

Try it and let us know if this works :)
 
Last edited:

jhampton2000

Member
Joined
Dec 19, 2005
Messages
826
Ronnie - just to add, if you have more than one entry, you'll need to have some parameter that tells DSD+ how to distinguish between entries in the frequency file: I understand it's just a look-up table, nothing more.

So even if you add all 7 entries, you still need to be able to tell DSD+ how to distinguish between frequencies from a unique identifier (such as format, network ID, site, etc). So you need to say if it's site 1 = freq A, site 2 = freq B etc. At the minute it won't know which of the 3 freqs to display to you.
 

RonnieUSA

Member
Joined
Aug 8, 2005
Messages
2,149
Location
Rowan County,KY (Morehead)
Well, I never had time to edit the file so can't be 100% sure if it's going to work but.... As far as I can see you are missing some parameters. You must set option for each parameter in order as given in the example: protocol, network ID, site number, OTA channel number, TX frequency, RX frequency, sort order. Counting from left to right you set only 5 parameters out of 7. Or in ohter words you set only first 5 parameters.

protocol=NEXEDGE48
network ID=0
site number=0
OTA channel number=460.587500
TX frequency=1

As you can see the last two lines contain wrong values. I'm not sure how to find the unknown values (some of them can be seen in even log window) but if we say that all uknown values can be set to 0 it sould look something like this

protocol=NEXEDGE48
network ID=0
site number=0
OTA channel number=0
TX frequency=460.587500 (if you are sure this is TX and not RX frequency)
RX frequency=460.587500 (just for example)
sort order=1

So your furst line is going to look something like this:

NEXEDGE48, 0, 0, 0, 460.587500, 460.587500, 1

Try it and let us know if this works :)
That worked to get them to load, but it's still not showing any thing in the channel window except source, and scrAlas.

I changed it to look like this:

NEXEDGE48, 1, 1, 1, 460.587500, 460.587500, 1
NEXEDGE48, 2, 2, 2, 453.72500, 453.72500, 2
NEXEDGE48, 3, 3, 3, 151.71500, 151.71500, 3
 

jhampton2000

Member
Joined
Dec 19, 2005
Messages
826
I should have clarified....if it's conventional Nexedge, there is no network ID, no site number, no OTA channel number for DSD+ to decode.

The freq file is just a look up table for DSD to match one or more of these parameters to a freq that you specify. DSD+ isn't finding any matches because there is nothing to match in your examples. It'll work on DMR conventional and/or Digital trunked because there are channel numbers, but not on NXDN conventional where there aren't.
 

RonnieUSA

Member
Joined
Aug 8, 2005
Messages
2,149
Location
Rowan County,KY (Morehead)
I should have clarified....if it's conventional Nexedge, there is no network ID, no site number, no OTA channel number for DSD+ to decode.

The freq file is just a look up table for DSD to match one or more of these parameters to a freq that you specify. DSD+ isn't finding any matches because there is nothing to match in your examples. It'll work on DMR conventional and/or Digital trunked because there are channel numbers, but not on NXDN conventional where there aren't.
Thank You, because that is gonna save me time trying to under stand why it's not working.
 
D

DaveNF2G

Guest
That worked to get them to load, but it's still not showing any thing in the channel window except source, and scrAlas.

I changed it to look like this:

NEXEDGE48, 1, 1, 1, 460.587500, 460.587500, 1
NEXEDGE48, 2, 2, 2, 453.72500, 453.72500, 2
NEXEDGE48, 3, 3, 3, 151.71500, 151.71500, 3
If you were monitoring a trunked system where these parameters would actually worked, I don't think the software would understand that the third channel belongs to a different system. Either that or it would interpret what you have as being frequencies belonging to three separate systems.
 

RonnieUSA

Member
Joined
Aug 8, 2005
Messages
2,149
Location
Rowan County,KY (Morehead)
Well, I never had time to edit the file so can't be 100% sure if it's going to work but.... As far as I can see you are missing some parameters. You must set option for each parameter in order as given in the example: protocol, network ID, site number, OTA channel number, TX frequency, RX frequency, sort order. Counting from left to right you set only 5 parameters out of 7. Or in ohter words you set only first 5 parameters.

protocol=NEXEDGE48
network ID=0
site number=0
OTA channel number=460.587500
TX frequency=1

As you can see the last two lines contain wrong values. I'm not sure how to find the unknown values (some of them can be seen in even log window) but if we say that all uknown values can be set to 0 it sould look something like this

protocol=NEXEDGE48
network ID=0
site number=0
OTA channel number=0
TX frequency=460.587500 (if you are sure this is TX and not RX frequency)
RX frequency=460.587500 (just for example)
sort order=1

So your furst line is going to look something like this:

NEXEDGE48, 0, 0, 0, 460.587500, 460.587500, 1

Try it and let us know if this works :)
I got it to work on a Conventional DMR System.

DMR, 0, 0,1, 153.3975, 153.3975, 1
 
Status
Not open for further replies.
Top