Edison Twp System Sounds Like CRAP...!!!!!

Status
Not open for further replies.

firecentral

Member
Joined
Mar 20, 2006
Messages
11
What is going on with edisons system i own the pro 96 and recently upgraded to the dsp. 1.4. Now when listening to FD/EMS i get loud blasts of encryption or other scatter noise thought the talkgroup was unencrypted why is this happening i hear them clear then the scanner recieves CRAP its bad enough they encrypt there PD talkgroup i can see sensitive channels being encrypted but not the main talkgroup. Ive aso heard that edison has one of the first mixed mode analog/digital 3600 systems out there... what is going on anybody in the area have a pro 96 with 1.4 if so monitor the talkgroups for a bit and see what happens this system is horrible to many "BUGS".
 

GM

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
933
The first Pro-96 that I had (when they first hit the street) did a much better job at decoding the digital voice all around than the newer versions and updated firmware currently do. (as per my experience with two units, one at v1.1; another with v1.4). That's the main reason why I kept my BC296D (plus it has other features that I like about it). I don't know what I could suggest to improve listening. Otherwise else, I have no problems with their system, other than the occasional sound quality adjustment.
 

ansky

Member
Joined
Dec 27, 2005
Messages
1,071
Location
NYC Metro
I always have problems listening to the FD 460.525 analog freuqency. I always get that "noise" you refer to.
 

firecentral

Member
Joined
Mar 20, 2006
Messages
11
Here Is The Problem

To monitor the edison system without that horrible noise get rid of the 1.4 dsp update and go back to the 1.3 dsp update dont know why this happens with a brand new update but my scanner is fine now with the 1.3 update i thought 1.4 was better what is going on with rat shack?
 
Status
Not open for further replies.
Top