Feed going offline several times a day

Status
Not open for further replies.

tafische

Member
Feed Provider
Joined
Sep 15, 2003
Messages
24
Location
Germantown, TN
I have a feed I have been running for years without issue, but since late last week it has been going offline multiple times per day.

It is on a dedicated Debian Whezzy box running Darkice. I was on 1.1, but after having issues I upgraded to 1.2 - but the issue persists. I have been running in the foreground with -v 10, but I am still receiving no specific errors on the console when it goes offline.

Anyone else been having similar errors? I am posting the .cfg and output below if anyone has any suggestions.

Thanks!

Code:
# sample DarkIce configuration file, edit for your needs before using
# see the darkice.cfg man page for details

# this section describes general aspects of the live streaming session
[general]
duration        = 0        # duration of encoding, in seconds. 0 means forever
bufferSecs      = 5         # size of internal slip buffer, in seconds
reconnect       = yes       # reconnect to the server(s) if disconnected

# this section describes the audio input that will be streamed
[input]
device          = default  # OSS DSP soundcard device for the audio
sampleRate      = 22050     # sample rate in Hz. try 11025, 22050 or 44100
bitsPerSample   = 16        # bits per sample. try 16
channel         = 1         # channels. 1 = mono, 2 = stereo

# this section describes a streaming connection to an IceCast2 server
# there may be up to 8 of these sections, named [icecast2-0] ... [icecast2-7]
# these can be mixed with [icecast-x] and [shoutcast-x] sections
[icecast2-0]
bitrateMode     = cbr       # average bit rate
format          = mp3    # format of the stream: ogg vorbis
bitrate         = 16        # bitrate of the stream sent to the server
server          = audio1.radioreference.com
                            # host name of the server

port            = 80      # port of the IceCast2 server, usually 8000
password        = xxxx    # source password to the IceCast2 server
mountPoint      = xxxx  # mount point of this stream on the IceCast2 server
name            = xxxx
                            # name of the stream
description     = xxxx
                            # description of the stream
url             = http://www.yourserver.com
                            # URL related to the stream
genre           = my own    # genre of the stream
public          = yes       # advertise this stream?
localDumpFile   = dump.ogg  # local dump file
password        = xxx    # source password to the IceCast2 server
mountPoint      = xxx  # mount point of this stream on the IceCast2 server
name            = xxx
                            # name of the stream
description     = xxx
                            # description of the stream
url             = http://www.yourserver.com
                            # URL related to the stream
genre           = my own    # genre of the stream
public          = yes       # advertise this stream?
localDumpFile   = dump.ogg  # local dump file
DarkIce 1.2 live audio streamer, darkice - DarkIce is a live audio streamer. - Google Project Hosting
Copyright (c) 2000-2007, Tyrell Hungary, Tyrell Hungary Corporation
Copyright (c) 2008-2013, Akos Maroy and Rafael Diniz
This is free software, and you are welcome to redistribute it
under the terms of The GNU General Public License version 3 or
any later version.

Using config file: /etc/darkice.cfg
27-Jul-2015 08:30:13 Using ALSA DSP input device: default
27-Jul-2015 08:30:13 buffer size: 220500
27-Jul-2015 08:30:13 encoding
27-Jul-2015 08:30:13 scheduler high priority 99
27-Jul-2015 08:30:13 Using POSIX real-time scheduling, priority 4
27-Jul-2015 08:30:13 HTTP/1.0 200
27-Jul-2015 08:30:13 set lame mode 3
27-Jul-2015 08:30:13 set lame channels 1
27-Jul-2015 08:30:13 set lame in sample rate 22050
27-Jul-2015 08:30:13 set lame out sample rate 22050
27-Jul-2015 08:30:13 set lame bit rate 16
27-Jul-2015 08:30:13 set lame quality 9
27-Jul-2015 08:30:13 set lame lowpass frequency 0
27-Jul-2015 08:30:13 set lame highpass frequency 0
27-Jul-2015 08:30:13 set lame psycho acoustic model 1
27-Jul-2015 08:30:13 set lame error protection 1
LAME 3.99.5 32bits (LAME MP3 Encoder)
CPU features: MMX (ASM used), SSE (ASM used), SSE2
Using polyphase lowpass filter, transition band: 5424 Hz - 5690 Hz
27-Jul-2015 08:30:13 MultiThreadedConnector :: tranfer, bytes 0
27-Jul-2015 08:30:13 MultiThreadedConnector :: ThreadData :: threadFunction, was (thread, priority, type): 0x9a4e9a0 4 SCHED_FIFO
27-Jul-2015 08:30:13 MultiThreadedConnector :: ThreadData :: threadFunction, now is (thread, priority, type): 0x9a4e9a0 1 SCHED_FIFO
 

an39511

Member
Joined
Feb 10, 2010
Messages
220
Location
Cleveland, Ohio
I don't run your type of equipment but have suffered connections problems similar to what you describe.
Like you, I had feeds running rock solid for years and then had connection problems. What turned out to be the problem was packet loss on my connection to the internet. The packet loss was bad enough to cause the feeds to drop dozens of times in a day but the packet loss was not enough to stop me from using the internet. Eventually it became so bad my entire connection failed. Turns out there was a chew in the line causing signal leaks.
Of course this is only one of many causes but it is an easy check with ping plotter software.
 
Status
Not open for further replies.
Top