FMP24 - The -b option seems to be ignored.

Status
Not open for further replies.

M105

Member
Joined
Sep 13, 2005
Messages
395
I decided to set up a batch file to monitor my local NOAA Weather Station. I used the following command line:
FMP24 -i3 -P40 -o3 -f162.5500 -b12.5 -n2 -_1 -wsl6.6 -g49.6
--------------
Ok, it works fine but with one quirk being the initial bandwidth always gets reset to 7.6 instead of the 12.5 that I have specified.

FMP24 command window reports the BW set to 12.5 when it first runs but the spectrum window shows it clearly at 7.6. I can use the B key to manually adjust the bandwidth after it is running with no problem.

What am I missing or doing wrong? It appears that FMP24 sees the command line switch since it acknowledges it at 12.5 but when the actual monitoring starts the BW is getting reset to 7.6. I am using the latest fastlane version...
 

jonwienke

More Info Coming Soon!
Premium Subscriber
Joined
Jul 18, 2014
Messages
11,270
Location
VA
NWS channels are 25KHz. Why are you specifying them as narrowband when they are not?
 

M105

Member
Joined
Sep 13, 2005
Messages
395
NWS channels are 25KHz. Why are you specifying them as narrowband when they are not?
12.5 works and I think it is the widest allowed number. Regardless, I think it should be set at what was specified, no?
 

jonwienke

More Info Coming Soon!
Premium Subscriber
Joined
Jul 18, 2014
Messages
11,270
Location
VA
Correct bandwidth for NWS channels is 25KHz. Using a narrower setting is probably going to result in overmodulated/clipped audio. Unless the -b parameter refers to deviation, in which case it would be 5KHz for a wideband FM channel.
 

BM82557

Member
Joined
Aug 28, 2006
Messages
2,845
Location
Berkeley Co WV
I decided to set up a batch file to monitor my local NOAA Weather Station. I used the following command line:
FMP24 -i3 -P40 -o3 -f162.5500 -b12.5 -n2 -_1 -wsl6.6 -g49.6
--------------
Ok, it works fine but with one quirk being the initial bandwidth always gets reset to 7.6 instead of the 12.5 that I have specified.

FMP24 command window reports the BW set to 12.5 when it first runs but the spectrum window shows it clearly at 7.6. I can use the B key to manually adjust the bandwidth after it is running with no problem.

What am I missing or doing wrong? It appears that FMP24 sees the command line switch since it acknowledges it at 12.5 but when the actual monitoring starts the BW is getting reset to 7.6. I am using the latest fastlane version...
Somebody else reported this kind of situation last summer, see post http://forums.radioreference.com/voice-control-channel-decoding-software/336750-fmp24-2-8-dsd-fastlane-b-parm-issues.html#post2610380

Don't know if it was ever resolved.
 

M105

Member
Joined
Sep 13, 2005
Messages
395
Correct bandwidth for NWS channels is 25KHz. Using a narrower setting is probably going to result in overmodulated/clipped audio. Unless the -b parameter refers to deviation, in which case it would be 5KHz for a wideband FM channel.
It is wonderful that you know all that but it really does not address my question. Why is FMP24 not setting the bandwidth as specified in the -b command? If you can present a corrected command line that sets the bandwidth at anything other than 7.6 please post it. I have another batch file I use for NXDN that ignores the -b4 parameter and sets that at 7.6 as well. So forget the NWS issue, I just want to know if this is a bug or if I need to change something to get the -b command to work.
 
Last edited:
Joined
Feb 14, 2008
Messages
2,013
I also asked about this a while back but can't find the thread. The -b argument used to work, but then a newer release nixed it and they said DSD+ automatically determines the bandwidth for you. I've never liked that and wish we could adjust it. It looks too narrow on the scope like it's chopping off part of the signal, as shown in the screenshot below.

Another strange thing is how the green wave doesn't align over the frequency you're actually tuned to. In the screenshot, the actual frequency tuned here is over on the left side with a narrow grey vertical line over it. But the green wave is centered right in the middle. Why can't the frequency tuned and the green wave both be aligned and centered exactly over top of each other?

 

slicerwizard

Member
Joined
Sep 19, 2002
Messages
6,222
Location
Toronto, Ontario
Correct bandwidth for NWS channels is 25KHz.
NWS channel spacing is 25 kHz. The signals don't use anywhere near the full 25 kHz.


Using a narrower setting is probably going to result in overmodulated/clipped audio. Unless the -b parameter refers to deviation, in which case it would be 5KHz for a wideband FM channel.
So +/-5 kHz deviation for a total of 10 kHz. So FMP24's 9.5 kHz bandwidth filter would be fine, since its skirts extend a bit beyond 9.5 kHz. The 12.5 kHz filter is also fine. And no doubt the OP verified this, just as I did.
 

M105

Member
Joined
Sep 13, 2005
Messages
395
Another strange thing is how the green wave doesn't align over the frequency you're actually tuned to. In the screenshot, the actual frequency tuned here is over on the left side with a narrow grey vertical line over it. But the green wave is centered right in the middle. Why can't the frequency tuned and the green wave both be aligned and centered exactly over top of each other?
----------------
The green line represents a different scale factor from the white. The green is essentially a centered and zoomed-in view of the region near where the pointer is at on the while scale. The white represents the 2.4MHz of spectrum the SDR covers. Actual tuning is done based on the white scale with the green showing you a close-up of the signal you are tuned to. If they were both aligned in the center you could not see the zoomed-in scale very well at the point where it is most important.
----
I am about ready to conclude that recognizing the -b setting but not actually adjusting the bandwidth is a bug else there would be no need for the parameter. I just wanted to make sure I was not overlooking some conifg setting or missing some other reason for the setting being ignored.
 
Last edited:
Joined
Feb 14, 2008
Messages
2,013
But the way the green is overlaid over the white tricks you into thinking that what you're looking at on the white is the same as the green in the middle. And, if you see some nearby activity on the green wave from a different frequency and you want to click to tune the new frequency and listen, it's confusing.
 

M105

Member
Joined
Sep 13, 2005
Messages
395
But the way the green is overlaid over the white tricks you into thinking that what you're looking at on the white is the same as the green in the middle. And, if you see some nearby activity on the green wave from a different frequency and you want to click to tune the new frequency and listen, it's confusing.
Yeah, well I found it a bit odd until I understood what I was looking at. It is really quite useful once you become accustomed to it. Without doing it that way you would have to manually zoom in and out like SDRSharp or have two windows going at once to display the same information. This puts everything you need in one window.
 

slicerwizard

Member
Joined
Sep 19, 2002
Messages
6,222
Location
Toronto, Ontario
And, if you see some nearby activity on the green wave from a different frequency and you want to click to tune the new frequency and listen, it's confusing.
If you see nearby activity in the green zoomed spectrum, it's only a few channels from whatever you're currently tuned to, so just use the cursor left/right keys to retune. Personally, I find it difficult to click *exactly* on most signals, so I have to use the cursor keys anyway. Might as well just start with them...
 

DSDPlus

Member
Joined
Jul 24, 2014
Messages
377
It is wonderful that you know all that but it really does not address my question. Why is FMP24 not setting the bandwidth as specified in the -b command? If you can present a corrected command line that sets the bandwidth at anything other than 7.6 please post it. I have another batch file I use for NXDN that ignores the -b4 parameter and sets that at 7.6 as well. So forget the NWS issue, I just want to know if this is a bug or if I need to change something to get the -b command to work.
Please contact us for a corrected version.
 

jonwienke

More Info Coming Soon!
Premium Subscriber
Joined
Jul 18, 2014
Messages
11,270
Location
VA
So +/-5 kHz deviation for a total of 10 kHz. So FMP24's 9.5 kHz bandwidth filter would be fine, since its skirts extend a bit beyond 9.5 kHz. The 12.5 kHz filter is also fine. And no doubt the OP verified this, just as I did.
No, because you have to add double the highest audio frequency in addition to the deviation. So +-5KHz (deviation) + 2*5KHz (audio frequency) = ~20KHz of used bandwidth, rounded up to 25KHz to prevent bleedover from one channel to another. (https://en.wikipedia.org/wiki/Carson_bandwidth_rule)

The particular station you're listening to may not be modulating to the max, but you shouldn't assume that all stations are configured that way.
 
Joined
Feb 14, 2008
Messages
2,013
Works great. Thank you.
I also got the corrected version. But I notice that when you use a voice following instance of this corrected version of FMP24, the bandwidth keeps reverting back to 7.6 even though I have -b12.5 in the .bat file.
 
Status
Not open for further replies.
Top