GREPSR500 deaf on scan??

Status
Not open for further replies.

tommyscan

Member
Premium Subscriber
Joined
May 28, 2008
Messages
342
Location
seaford new york
I have had my unit since february, worked great for 4 months and then I noticed a drop in crisp audio and a drop in decoding trunked systems,especially motorola 800 and uhf types.THEN this week it went dead as far as audio?? It would scan,show a conv frequency or trunked id number with no audio?? I entered a trouble ticket to gre support and received a reply that it COULD be the radio?? Whats up with that response?? I think SOOO!!! Has anyone else experienced this? And if so,how did you fix it?? I changed the firmware to an earlier version,reset the global settings to default, and alsio initialized the unit to factory settings with no luck!!! Help!!!!!!!!!!
 

DonS

Member
Premium Subscriber
Joined
Jun 17, 2003
Messages
4,106
Location
Franktown, CO
Try pressing the WX button... do you get a local NOAA frequency (presuming you have one)? If so, it's probably not the scanner itself.
 

tommyscan

Member
Premium Subscriber
Joined
May 28, 2008
Messages
342
Location
seaford new york
no I dont. when pressing weather I get a continual scan until I turn the squelch all the way to the left and the audio is low and VERY scratchy.
 

corbintechboy

Member
Premium Subscriber
Joined
Aug 12, 2005
Messages
435
Location
Corbin, KY
Sounds to me like the front end may have blew. Don't really know but did you maybe let static get to the antenna or something? I don't really know if this could be a problem but sounds like it (but I am no electronic guy).
 

tommyscan

Member
Premium Subscriber
Joined
May 28, 2008
Messages
342
Location
seaford new york
No,I took good care of it.No water or any self modifications. Its really depressing to have that happen over a 6 month period. It makes me so angry to spend that type of money to have such cheap parts being put in. I have a bc245xlt which is 15 years old ,been thrown around and works like a charm. Go figure???
 

Stavro35

Member
Joined
Mar 23, 2003
Messages
1,150
Location
Bainbridge Island, WA
I had an issue with mine. I sent it in for repair. And in a few days I got a brand new unit. I had it for a couple of months,I got it around Christmas time. One day I wasn't hearing much of anything. We tried everything to get it to work,it wouldn't. I sent it back and got a brand new unit,as stated. The new unit has not given me problems.
 

tommyscan

Member
Premium Subscriber
Joined
May 28, 2008
Messages
342
Location
seaford new york
wow!! Why is this happening?? You would think the internal parts of a scanner of this magnitude,meaning all those bells and whistles would have half way decent parts!!! I think GRE has great service and a nice looking line of receivers BUT hope they are reading this!!!! Have to do something when a unit goes deaf in 6 months or less on its own!!!????
 

tommyscan

Member
Premium Subscriber
Joined
May 28, 2008
Messages
342
Location
seaford new york
Yes I have head set and still hear only certain transmissions in vhf and a few trunked ids on the local county system??!! What do you think it is??
 

kikito

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
2,593
Location
North Pole, Alaska
wow!! Why is this happening?? You would think the internal parts of a scanner of this magnitude,meaning all those bells and whistles would have half way decent parts!!! I think GRE has great service and a nice looking line of receivers BUT hope they are reading this!!!! Have to do something when a unit goes deaf in 6 months or less on its own!!!????
Well, stuff happens to stuff! Just because a few units go bad out of thousands doesn't mean we have to go into a drama frenzy like it's a huge widespread problem.....

I've had several dozens of scanners in the past two decades and only ONE so far that I had to send in for repairs. It was a Uniden BC250D if anyone's curious....
 

tommyscan

Member
Premium Subscriber
Joined
May 28, 2008
Messages
342
Location
seaford new york
well maybe its not a big deal to YOU BUT, if you spent the money that I have in this hobby and all you want to do is sit back and enjoy the monitoring and SUDDENLY cant,then I think you will be saying the same thing!! A bc250d is not a good comparison to the gre 500!!?? No offense but its like comparing a cobra to an icom!!!!!!!!!!
 

tommyscan

Member
Premium Subscriber
Joined
May 28, 2008
Messages
342
Location
seaford new york
And bt the way its NOT just a few units if you been reading the posts on this unit!! Several hundred if not more have had problems with loose inside screws,lost audio,choppy audio,loose bnc connections,just to name a few!!!!!!
 

kikito

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
2,593
Location
North Pole, Alaska
A bc250d is not a good comparison to the gre 500!!?? No offense but its like comparing a cobra to an icom!!!!!!!!!!
I mentioned the BC250D because that's the only scanner I've had to send in for repair, that was the point. At the time the BC250D came out it did COST as much or more than the PSR-500 by the way.....
 

kikito

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
2,593
Location
North Pole, Alaska
And bt the way its NOT just a few units if you been reading the posts on this unit!! Several hundred if not more have had problems with loose inside screws,lost audio,choppy audio,loose bnc connections,just to name a few!!!!!!
Even if we're going to go by posts, which is an inaccurate way to come up with those numbers, there's no way it's in the hundreds. A lot of complains are due to operator error and other similar instances. You can't go by the initial post of a complain alone and not read further where the resolution is likely provided.
 

tommyscan

Member
Premium Subscriber
Joined
May 28, 2008
Messages
342
Location
seaford new york
Not to continue the rant,BUT USER ERROR?? I hardly think most users would loosen their bnc connector or open up the unit and mess with the internal screws!!! Lets just leave it like this, out of ALL the scanner receivers I have owned which are about 30 over the years, this seems to have the most construction design flaws!!!!!!
 

kikito

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
2,593
Location
North Pole, Alaska
Not to continue the rant,BUT USER ERROR?? I hardly think most users would loosen their bnc connector or open up the unit and mess with the internal screws!!! Lets just leave it like this, out of ALL the scanner receivers I have owned which are about 30 over the years, this seems to have the most construction design flaws!!!!!!
How about we leave it at: Me and many others disagree and haven't had any of the issues that you claim are so widespread. The PSR-500 and BCD396T are the best scanners I've owned and they work great software and hardware wise.
 
Status
Not open for further replies.
Top