Have any experience with digiCircle?

Status
Not open for further replies.

NWI_Scanner_Guy

Member
Premium Subscriber
Joined
Jan 23, 2008
Messages
2,247
Location
Hammond, IN
Thought I'd share my experience with a digiCircle purchase, and ask if anyone else has purchased from them, and if you had any problems if you did.

Last week I was eying both a PRO-197 and a PRO-106 listed on digiCircle. Still had some tax return money left over, and was looking to buy a digital scanner since I so foolishly sold off my PSR-800 about a month ago (yeah, I have no idea what the heck I was thinking). Anyway, couldn't decide if I wanted base or handheld. The 197 was cheaper by about 40 dollars, but after factoring in shipping, the difference was only about 18 dollars. Well, while trying to decide, the 197 was sold, leaving just the 106. Not knowing how long it would remain in the site, I went ahead and purchased it. Paid about four dollars more for priority versus regular shipping, which turned out to be next day shipping; a happy surprise indeed.

Anyway, when the scanner arrived, I promptly installed batteries and powered it up. Came on okay, and even noticed that the previous owner hadn't cleared out the memory. After watching it go through its scan-lists a few times and not picking up anything, I pressed the "WX" button for the weather, and got nothing. Hmmm, not good, I thought. Decided to search through the various pre-programmed bands. Still nothing. And I noticed that on the CB, Marine and Railroad bands it would scan through a few channels and then stop. Even turning the squelch down all the way failed to produce any sound.

Thinking it may either be a loose antenna connection or a loose speaker connection, I decided to open it up and take a peek around before contacting digiCircle requesting a RMA. Now I have some electronics experience from my days in the Air Force, but just enough to make me dangerous, but from what I could see with the naked eye and through a magnifying glass, all connections concerning the antenna looked solid. I couldn't get to the speaker connections, so I just put it all back together and prepared to e-mail digiCircle. However, before I did that, I decided to turn it on again, just to see what, if anything, might happen. Well, much to my surprise, when it came on, it started receiving. Thinking it might be a fluke, I once again pressed the "WX" button, and was able to toggle through the three weather stations I can pick up here in the Chicago area. As a last test, I reset the scanner to "fresh out of the box" conditions and did the weather thing again. Success again, so I hooked it up to my computer and downloaded a few trunk systems and once again it performed flawlessly.

So, to make a long story short, I have no idea what was wrong with it to begin with and even less of an idea as to how I "fixed" it just by taking it apart and putting it back together. I was "this close" to writing off digiCircle, and vowing never to do business with them again. Now that the 106 works fine, I feel a little more confident about buying from them again in the future.

So, I was just wondering if anyone else has bought anything from them, and if so, did you experience any problems with the product, or was it smooth sailing all the way?
 

silagi

Member
Premium Subscriber
Joined
Apr 24, 2008
Messages
97
Location
Fremont, CA
I have purchased about 10 different electronic items from DigiCircle. Everything was exactly as advertised. I actually live about 5 minutes from their warehouse so I place the order online and pick up at the warehouse a few hours later. I have never had a problem with them. Them seem to be nice honest business people.
 

KC4RAF

Member
Joined
Sep 30, 2006
Messages
1,599
Location
Davenport,Fl.- home to me and the gators and the s
Bought a PRO-107 from them

last year without any hitches. The scanner worked great, no problems with it at all. I recommend the site to people and the few who have bought, said it was flawless transactions. The 107 was under 50 dollars and I thought it might have a problem or two, but that wasn't the case. Just didn't come with the software or cable, and that was remedied through RS and a member of RR (Xeno194 had the software and sent me a copy, and I thank him for sharing).
I think your pretty much safe, but it still comes down to the seller being truthfull about the product he's/she's selling.
Your experience sounds like a loose connection somewhere that may have accored during shipping or was never advertised that the condition existed by the seller.
Glad to hear that it does work for you now and hope you enjoy it.
Roger
 

SCPD

QRT
Joined
Feb 24, 2001
Messages
0
Location
Virginia
Butterfinger

Answering the OP's question, wonder if this radio got dropped at some point in time.
There may be an intermittent connection, possibly on the board trace itself, or where a component is mounted. Possilby the antenna connection. Examine the case for a scuff mark.
It didn't work when you got it, you opened it up and put it together again, that was enough to flex something and now the intermittent is making.
Put the WX back in and shake the radio, wiggle the antenna, or gently twist the case. See if the RX dies.
 

NWI_Scanner_Guy

Member
Premium Subscriber
Joined
Jan 23, 2008
Messages
2,247
Location
Hammond, IN
Answering the OP's question, wonder if this radio got dropped at some point in time.
There may be an intermittent connection, possibly on the board trace itself, or where a component is mounted. Possilby the antenna connection. Examine the case for a scuff mark.
It didn't work when you got it, you opened it up and put it together again, that was enough to flex something and now the intermittent is making.
Put the WX back in and shake the radio, wiggle the antenna, or gently twist the case. See if the RX dies.
Well, knock on wood, the 106 is still going strong. Didn't shake it or wiggle the antenna, but I did accidentally knock it off the edge of my desk yesterday, and thankfully it didn't miss a beat (after putting the batteries back in, that is).

Whatever caused it to not work at first seems to be resolved, so it looks like I'll definitely be doing business with Digicircle again.
 

bkantor

Member
Joined
Jan 22, 2002
Messages
271
Location
Bay Shore, NY
I had a terrible experience with them this month...saw a Pro-197 on there without the antenna or power supply, but for $170 it was a bargain that came with the original box, instructions, mounting bracket. Well, this radio arrived today....the box and instructions were as promised, but the radio inside was a Pro-2055! Not only a much cheaper radio, but this one also had a bad display!! I called immediately and they were kind enough to give me an RMA and said they would refund my $, but I was totally aggravated. I asked them why they don't check the packages before they send them (I think they are buying/selling, so some slimy seller probably pulled a bait and switch) - no good response, just "it happens sometimes". That was my first purchase and will DEFINITELY be my last from them.

Bob
 

silagi

Member
Premium Subscriber
Joined
Apr 24, 2008
Messages
97
Location
Fremont, CA
Well I ended up buying a Pro197 from them a little over a month ago. $210, brand new in the box. Works great and I have not had a problem with it. Dealing with them in person in my home town I can tell you that they seem like nice honest businessmen. Yes they probably got ripped off by whoever they got that radio from.
 

methusaleh

Member
Joined
Feb 18, 2009
Messages
361
Location
New England
I had a terrible experience with them this month...saw a Pro-197 on there without the antenna or power supply, but for $170 it was a bargain that came with the original box, instructions, mounting bracket. Well, this radio arrived today....the box and instructions were as promised, but the radio inside was a Pro-2055! Not only a much cheaper radio, but this one also had a bad display!! I called immediately and they were kind enough to give me an RMA and said they would refund my $, but I was totally aggravated. I asked them why they don't check the packages before they send them (I think they are buying/selling, so some slimy seller probably pulled a bait and switch) - no good response, just "it happens sometimes". That was my first purchase and will DEFINITELY be my last from them.

Bob
No kidding...that must be why it is still on the site, and has been "sale pending" for weeks now!
 

john_p_bowen

Member
Joined
Jul 12, 2009
Messages
49
Location
Thomasville, NC
I had a terrible experience with them this month...saw a Pro-197 on there without the antenna or power supply, but for $170 it was a bargain that came with the original box, instructions, mounting bracket. Well, this radio arrived today....the box and instructions were as promised, but the radio inside was a Pro-2055! Not only a much cheaper radio, but this one also had a bad display!! I called immediately and they were kind enough to give me an RMA and said they would refund my $, but I was totally aggravated. I asked them why they don't check the packages before they send them (I think they are buying/selling, so some slimy seller probably pulled a bait and switch) - no good response, just "it happens sometimes". That was my first purchase and will DEFINITELY be my last from them.

Bob
At least they gave you your money back. They have great customer service from my experiences.
 

Nasby

Member
Joined
Apr 4, 2004
Messages
2,439
Location
Ohio
Anyone have any idea what their shipping charges for a handheld scanner would be?
I've searched all over their site and can't find it anywhere.
 
Status
Not open for further replies.
Top