Help with a Pro 95

Status
Not open for further replies.

xploded

Member
Joined
Oct 4, 2006
Messages
1
Having trouble with my Pro-95. First I have lost the display screen. Scanner is on and picking up channels and no screen.
2. Anytime someone transmits, the scanner gives that static you hear when you adjust the squelch. No matter how you adjust it doesn't go away unless you turn off the unit and back on then soon as someone transmits it starts again.
Does anybody have any suggestions? I am stumped and have no answers. Is it worth investing in a fix or should I shop for a new one?
Any help from anyone that has experienced this is greatly appreciated.
 

Dubbin

Member
Feed Provider
Joined
Dec 19, 2002
Messages
4,479
Location
Findlay Ohio
I would be shopping for a new one. If you don't need digital then check out the BC246T or the BR330T. Both are solid units that will survive the rebanding. If you need digital then the BCD396T is hard to beat.
 

DickH

Member
Joined
Mar 12, 2004
Messages
4,069
xploded said:
Having trouble with my Pro-95. First I have lost the display screen. Scanner is on and picking up channels and no screen.
2. Anytime someone transmits, the scanner gives that static you hear when you adjust the squelch. No matter how you adjust it doesn't go away unless you turn off the unit and back on then soon as someone transmits it starts again.
Does anybody have any suggestions? I am stumped and have no answers. Is it worth investing in a fix or should I shop for a new one?
Any help from anyone that has experienced this is greatly appreciated.
For the first problem, the display contrast has changed (yes, it can happen all by itself). Push FUNC 9, then use the arrow keys to adjust it.

For the other problem, if you have a .p95 file, reset the scanner (page 83), then load the freqs. back in. Actually, that should fix the first problem too.

Dick
 
Status
Not open for further replies.
Top