Help With RadioFeed & Port Forwarding

rkillins

Member
Joined
Dec 15, 2001
Messages
207
I am trying to set up the RadioFeed Web Server. I'm stuck at Step 3 (RadioFeed Setup Instructions - The RadioReference Wiki) "Get the Web Server to work remotely"

When I type my outside IP, colon, and my forwarded port into my browser, it will not connect. When I type the same at canyouseeme.org, it reports success, that it can be seen.

The instructions for setup simply say to troubleshoot using canyouseeme.org, which I have. Can anyone advise where I have gone wrong?
 

N1GAW

Member
Premium Subscriber
Joined
Jul 15, 2014
Messages
3,767
Location
Raleigh, NC
You need to open the port through your routers firewall. Exactly how you do that depends on the router make/model. A quick google search for "How to open port on XXXXXX router" where xxxxxx is your router make model.
 

rkillins

Member
Joined
Dec 15, 2001
Messages
207
Thank you Sir. I assume I did that though ... butmaybe not correctly. If I didn't do this, or I did it wrong, would I be successful with canyouseeme.org?

I have accessing my Hitron router, went to port forwarding and added a rule for RadioFeed.

When creating this rule, the following was requested:
Protocol : TCP
Public Port Range - I entered the server port I specified in the web server setup in Radio feed for both the high and low values
Private Port Range - I entered the same values as above
Local IP address - the local IP address identified by RadioFeed after pressing "Get My IP" in the Web Server dialogue. I get two addresses, a "local", and an "outside".
Remote IP address - selected default "ANY". The other option is specific where I can enter a remote IP range (0.0.0.0 ~ 255.255.255.255)
Rule Status : ON
 

ProScan

Software Provider
Premium Subscriber
Joined
Jul 2, 2006
Messages
4,490
Location
Ontario, Calif.
It sounds like you have the Router Port Forwarding setup correctly since Open Port Check Tool -- Verify Port Forwarding on Your Router sees the open port.

If the browser is on your network, you don't need the Router Port Forwarding. Just enter the Local IP Address followed by colon and port number.
If the browser is outside your network then you need the Router Port Forwarding. Enter the Remote IP Address followed by colon and port number.
 

rkillins

Member
Joined
Dec 15, 2001
Messages
207
Oh I see ... yes, I was trying to connect within the same netowrk.
Working now!! Thanks. But it does take quite a long time for the client to connect. Two parting questions though if I may,

I'm connected via my Android phone's browser. Are you familiar with any other means, another app perhaps, that I could connect to this stream bypassing the need for the web player? The embedded player android's mobile browser (Chrome) on the webpage doesn'e play well (ie the slider for the volume control doesn't work ... trying simply toggles the play/stop. If I select the "Listen Live" link, it opens up a player (I imagine native to the device) but it is either not connecting, or taking a very long time to do so.

Is there any magic to possibly get metadata from DSD+? I think I read it would be DSD+'s developer's responsibility to adapt it to RadioFeed and I'm not sure if that ever happened, but perhaps someone has discovered a workaround.
 
Last edited:
Top