SDRTrunk Icecast Streaming Issue

Status
Not open for further replies.

Mikesuper26

Member
Joined
Oct 31, 2010
Messages
92
Location
Stamford, CT
Hello all,

I am using SDRTrunk on a Windows PC in conjunction with OP25 running on a Raspberry Pi 4 utilizing Liquidsoap. I have Icecast 2.4 installed on my Pi which I use as a streaming server for OP25. I am trying to connect Windows based SDRTrunk (which is running from a different local network) to my Icecast server but every time I try I get a message with "Disconnected." Below is the response I receive in my command line of SDRTrunk:

Code:
12:36:18.407 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [108MB/158MB 68%]
12:36:49.416 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [65MB/158MB 41%]
12:37:19.428 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [73MB/158MB 46%]
12:37:50.408 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [109MB/158MB 69%]
12:38:20.417 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [82MB/158MB 52%]
12:38:51.422 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [79MB/158MB 50%]
12:39:21.453 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [76MB/158MB 48%]
12:39:52.406 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [105MB/158MB 66%]
12:40:22.399 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [105MB/158MB 66%]
12:40:53.411 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [103MB/158MB 65%]
12:41:24.407 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [72MB/158MB 46%]
12:41:54.425 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [89MB/158MB 56%]
12:42:25.405 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [125MB/158MB 79%]
12:42:55.412 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [105MB/158MB 67%]
12:43:26.406 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [128MB/158MB 81%]
12:43:56.399 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [92MB/158MB 58%]
12:44:27.524 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [134MB/158MB 84%]
12:44:58.440 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [115MB/158MB 73%]
12:45:28.434 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [59MB/158MB 37%]
12:45:59.421 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [127MB/158MB 80%]
12:46:30.406 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [90MB/158MB 57%]
12:47:01.407 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [63MB/158MB 40%]
12:47:31.420 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [116MB/158MB 73%]
12:48:02.409 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [62MB/158MB 39%]
12:48:32.404 INFO  i.g.d.a.b.AudioBroadcaster - [OP25] status: Disconnected  [78MB/158MB 49%]
These messages continue indefenitely. With this limited information I have no idea what is causing this issue. I have made sure that the server, port, username and password are correct. Anyone have any ideas on what could be wrong? I wonder if it is in issue with Icecast itself on my Pi.

Thanks

Mike
 

DSheirer

Member
Premium Subscriber
Joined
Feb 15, 2010
Messages
525
Location
Fulton, NY
Mike, are you able to ping the pi from the computer running sdrtrunk? Is there a separate mount point/password for each (OP25 & sdrtrunk)?
 

Mikesuper26

Member
Joined
Oct 31, 2010
Messages
92
Location
Stamford, CT
I can ping the Pi from the PC running SDRTrunk. There are separate mountpoints for each instance of OP25 (I have two) and I specified a new mountpoint in SDRTrunk called "Greenwich P25." I wasn't sure if there was anything else that needed to be done in addition to that. I am using the source username and password listed in my icecast.xml file on my Pi (which hosts my Icecast server as well as the two instances of OP25.)

Thanks
 

thewraith2008

Member
Joined
Nov 22, 2016
Messages
1,503

Mikesuper26

Member
Joined
Oct 31, 2010
Messages
92
Location
Stamford, CT
I fixed the mountpoint spacing issue, still having an error but at least I am getting information now. See below:

Code:
17:55:40.244 INFO  i.g.d.a.b.AudioBroadcaster - [op25] status: Disconnected  [251MB/395MB 63%]
17:56:10.277 ERROR i.g.d.a.b.i.IcecastHTTPAudioBroadcaster - HTTP protocol decoder error  [332MB/395MB 84%]
org.apache.mina.filter.codec.ProtocolDecoderException: java.lang.ArrayIndexOutOfBoundsException: Index 1 out of bounds for length 1 (Hexdump: 48 54 54 50 2F 31 2E 30 20 34 30 33 20 46 6F 72 62 69 64 64 65 6E 0D 0A 53 65 72 76 65 72 3A 20 49 63 65 63 61 73 74 20 32 2E 34 2E 34 0D 0A 43 6F 6E 6E 65 63 74 69 6F 6E 3A 20 43 6C 6F 73 65 0D 0A 44 61 74 65 3A 20 4D 6F 6E 2C 20 30 34 20 4D 61 79 20 32 30 32 30 20 32 31 3A 35 36 3A 31 30 20 47 4D 54 0D 0A 43 6F 6E 74 65 6E 74 2D 54 79 70 65 3A 20 74 65 78 74 2F 70 6C 61 69 6E 3B 20 63 68 61 72 73 65 74 3D 75 74 66 2D 38 0D 0A 43 61 63 68 65 2D 43 6F 6E 74 72 6F 6C 3A 20 6E 6F 2D 63 61 63 68 65 2C 20 6E 6F 2D 73 74 6F 72 65 0D 0A 45 78 70 69 72 65 73 3A 20 4D 6F 6E 2C 20 32 36 20 4A 75 6C 20 31 39 39 37 20 30 35 3A 30 30 3A 30 30 20 47 4D 54 0D 0A 50 72 61 67 6D 61 3A 20 6E 6F 2D 63 61 63 68 65 0D 0A 41 63 63 65 73 73 2D 43 6F 6E 74 72 6F 6C 2D 41 6C 6C 6F 77 2D 4F 72 69 67 69 6E 3A 20 2A 0D 0A 0D 0A 74 6F 6F 20 6D 61 6E 79 20 73 6F 75 72 63 65 73 20 63 6F 6E 6E 65 63 74 65 64)
        at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecFilter.java:262)
        at org.apache.mina.core.filterchain.DefaultIoFilterChain.callNextMessageReceived(DefaultIoFilterChain.java:641)
        at org.apache.mina.core.filterchain.DefaultIoFilterChain.access$1300(DefaultIoFilterChain.java:48)
        at org.apache.mina.core.filterchain.DefaultIoFilterChain$EntryImpl$1.messageReceived(DefaultIoFilterChain.java:1114)
        at org.apache.mina.core.filterchain.IoFilterAdapter.messageReceived(IoFilterAdapter.java:121)
        at org.apache.mina.core.filterchain.DefaultIoFilterChain.callNextMessageReceived(DefaultIoFilterChain.java:641)
        at org.apache.mina.core.filterchain.DefaultIoFilterChain.fireMessageReceived(DefaultIoFilterChain.java:634)
        at org.apache.mina.core.polling.AbstractPollingIoProcessor.read(AbstractPollingIoProcessor.java:539)
        at org.apache.mina.core.polling.AbstractPollingIoProcessor.access$1200(AbstractPollingIoProcessor.java:68)
        at org.apache.mina.core.polling.AbstractPollingIoProcessor$Processor.process(AbstractPollingIoProcessor.java:1242)
        at org.apache.mina.core.polling.AbstractPollingIoProcessor$Processor.process(AbstractPollingIoProcessor.java:1231)
        at org.apache.mina.core.polling.AbstractPollingIoProcessor$Processor.run(AbstractPollingIoProcessor.java:683)
        at org.apache.mina.util.NamePreservingRunnable.run(NamePreservingRunnable.java:64)
        at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.base/java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ArrayIndexOutOfBoundsException: Index 1 out of bounds for length 1
        at org.apache.mina.http.HttpClientDecoder.parseHttpReponseHead(HttpClientDecoder.java:221)
        at org.apache.mina.http.HttpClientDecoder.decode(HttpClientDecoder.java:108)
        at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecFilter.java:253)
        ... 15 common frames omitted
Not sure what any of this means. Is there somewhere in my icecast.xml that I should be specifying mountpoints? I did not have to do this with the two OP25 local mountpoints that are streamed from the Pi. The hostname of my stream is "op25."
 

thewraith2008

Member
Joined
Nov 22, 2016
Messages
1,503
No idea about the error. (other than an array with one element is trying to be accessed at the 2nd element, which it doesn't have.)

Is there somewhere in my icecast.xml that I should be specifying mountpoints? I did not have to do this with the two OP25 local mountpoints that are streamed from the Pi. The hostname of my stream is "op25."
No you should not need to do that.
Only when you need advanced options would you need to do that.

Your new stream should be defined exactly as the first two streams (IP, port, password) with only the mountpoint been different.
 

Mikesuper26

Member
Joined
Oct 31, 2010
Messages
92
Location
Stamford, CT
No idea about the error. (other than an array with one element is trying to be accessed at the 2nd element, which it doesn't have.)


No you should not need to do that.
Only when you need advanced options would you need to do that.

Your new stream should be defined exactly as the first two streams (IP, port, password) with only the mountpoint been different.
I see, thank you. I am positive that the stream is defined exactly the same except for the mountpoint.

The only thing I can imagine is that something isn't configured correctly. If anyone has any insight as to what this error means, please let me know.

Thanks
 
Status
Not open for further replies.
Top