Icom IC-2720 separation cable repair question, with schematic

Status
Not open for further replies.

KC9LQV

Member
Premium Subscriber
Joined
Nov 12, 2009
Messages
133
Location
SW Indiana
I have an Icom IC-2720 with an OPC-1155 separation cable that got flakey. The plug at the chassis end would cause the radio to power off if disturbed. Swapping out the cable eliminated the problem, so I know it's not the plug on the chassis.

I have the 6P6C plugs and crimping tool, and have cut the bad plug off and taken a peek at the conductors.

I have one question, though. The red (pin 5) and white (pin 4) wires are shielded by strands. What I can't tell for sure is what to do with those shields at the plug. Are they being twisted together and used as the conductor at pin 3?

I've tried to scrutinize the original plug carefully, but my crappy eyesight doesn't help. There appears to be a conductor in pin 3, but that's one more wire than used in the cable unless you count the shield.

I'm attaching the schematic for the cable. Please take a look at it, as I'm not sure how to interpret the pinout. It shows pin 3 "connecting" to both pin 4 and 5. If someone could clarify it would be great.

Hope the schematic helps anyone else who wants to repair or fabricate a separation cable.
 

Attachments

SCPD

QRT
Joined
Feb 24, 2001
Messages
0
Location
Virginia
I have an Icom IC-2720 with an OPC-1155 separation cable that got flakey. The plug at the chassis end would cause the radio to power off if disturbed. Swapping out the cable eliminated the problem, so I know it's not the plug on the chassis.

I have the 6P6C plugs and crimping tool, and have cut the bad plug off and taken a peek at the conductors.

I have one question, though. The red (pin 5) and white (pin 4) wires are shielded by strands. What I can't tell for sure is what to do with those shields at the plug. Are they being twisted together and used as the conductor at pin 3?

I've tried to scrutinize the original plug carefully, but my crappy eyesight doesn't help. There appears to be a conductor in pin 3, but that's one more wire than used in the cable unless you count the shield.

I'm attaching the schematic for the cable. Please take a look at it, as I'm not sure how to interpret the pinout. It shows pin 3 "connecting" to both pin 4 and 5. If someone could clarify it would be great.

Hope the schematic helps anyone else who wants to repair or fabricate a separation cable.
I'm wondering if 3 is a shield around 4 and 5, not actually connected to it. I have one of these radios. Although I've never had the need to replace my cable, I do believe I have heard a few times that a pin to pin cable with RJ-45's on each end works just fine as a replacement cable.
 
Last edited:

KC9LQV

Member
Premium Subscriber
Joined
Nov 12, 2009
Messages
133
Location
SW Indiana
FWIW, the repair was successful.

As a test, I took a flat 6 conductor phone-type cable and wired it straight through with a 6P6C connector on each end. That worked properly. I would have considered simply using the flat cable as a permanent replacement for the Icom cable, but the absence of the shields on conductors 4 and 5 concerned me.

Then I went to replace the faulty connector on the Icom cable. The trick was getting all the conductors in a round cable to lay flat in the proper order. What I ended up doing was sliding a piece of heat-shrink tubing onto the cable, then splitting the outer casing and rolling it back far enough to give me the slack I needed to get the wires into position. After removing the paper wrap and the string strain relief, I teased out the stranded shields and twisted them together.

Once I had all the conductors in order and laying flat, I trimmed them even, rolled the casing back up, and slid the heat-shrink tubing flush with the end of the casing. Then I crimped it and heated the shrink tubing. The heat-shrink tubing gives the plug a much more solid feel.

I tested it, found it to be working fine, and replaced the ferrite core. Back in business.

This may all seem rather mundane, but I wanted to post a definitive answer for people who may be replacing or repairing these cables in the future. Once area of confusion is the plugs. Forget "RJ" numbers ... they're inexact and people are constantly mixing them up. Stick with the position/conductor nomenclature. This particular Icom controller cable uses 6P6C plugs. Order them by that term and you can't go wrong.

Hope this helps.
 
Status
Not open for further replies.
Top