Library Update 368

Status
Not open for further replies.

SCPD

QRT
Joined
Feb 24, 2001
Messages
0
Location
Virginia
Anybody know what's going on? They've been pretty consistent with updating the library on Saturdays. Or did they stop doing updates?
 

DonS

Member
Premium Subscriber
Joined
Jun 17, 2003
Messages
4,106
Location
Franktown, CO
The update process (DB retrieval from RR) has been failing after about 4.5 hours. I'm investigating it.
 

fourthhorseman

Member
Premium Subscriber
Joined
Feb 3, 2009
Messages
2,081
Location
So Far Away....
I updated my 800 last night,Was good to go.Full update onto a new install of EZScan.
It took about 45 seconds..

library 367 and location 10..dated last week
 

DonS

Member
Premium Subscriber
Joined
Jun 17, 2003
Messages
4,106
Location
Franktown, CO
I updated my 800 last night,Was good to go.Full update onto a new install of EZScan.
It took about 45 seconds..

library 367 and location 10..dated last week
Yes - 367 works. The posts above were referring to the expected library 368, which should have appeared on Saturday 21 June.
 

DonS

Member
Premium Subscriber
Joined
Jun 17, 2003
Messages
4,106
Location
Franktown, CO
The update process (DB retrieval from RR) has been failing after about 4.5 hours. I'm investigating it.
Problem found. Recent changes to Minnesota's ARMER system (erasing contents of site names, instead of filling with "EMPTY" as had been done before) caused null pointers in .NET. Unhandled exception being thrown.

New library build will start shortly. Will be done late tonight.
 

DonS

Member
Premium Subscriber
Joined
Jun 17, 2003
Messages
4,106
Location
Franktown, CO
This DB editing error (or, perhaps, change of convention) also screws up the web interface.

Go here:
Allied Radio Matrix for Emergency Response (ARMER) Trunking System, Various, Minnesota - Scanner Frequencies

In the list of sites, scroll down to RFSS=3, Site=013. That's one of the sites that were changed on 20 June. Note that just above it (Site = 008), the "Name" field contains "EMPTY" - but is still clickable. Site 013 (and 016), though, have completely blank names, and do not contain a clickable link (except for the "UNKNOWN" county).
 

Jay911

.
Feed Provider
Joined
Feb 15, 2002
Messages
9,307
Location
Bragg Creek, Alberta
Is somebody going after the db admin to get it reverted? At the very least, just put "Site 3-013" (etc) in there.
 
Last edited:

jaspence

Member
Premium Subscriber
Joined
Mar 21, 2008
Messages
2,359
Location
Michigan
There was a separate post in another thread about the delay being caused by turning over the database responsibility to Whistler as the reason. Does anyone know the real reason?
 

Jay911

.
Feed Provider
Joined
Feb 15, 2002
Messages
9,307
Location
Bragg Creek, Alberta
There was a separate post in another thread about the delay being caused by turning over the database responsibility to Whistler as the reason. Does anyone know the real reason?
Well, since DonS is the guy who runs the database download, I'd say his is the real reason.
 

SCPD

QRT
Joined
Feb 24, 2001
Messages
0
Location
Virginia
Problem found. Recent changes to Minnesota's ARMER system (erasing contents of site names, instead of filling with "EMPTY" as had been done before) caused null pointers in .NET. Unhandled exception being thrown.

New library build will start shortly. Will be done late tonight.
Sounds Good, thanks man
 

DonS

Member
Premium Subscriber
Joined
Jun 17, 2003
Messages
4,106
Location
Franktown, CO
As the above posts confirm, update 368 worked and is now available.

(I also notice that the ARMER system was edited early this morning, and the site names are no longer empty (well, they now say "EMPTY" instead of actually being <empty>)).
 
Status
Not open for further replies.
Top