liquidsoap clobbered in routine upgrade

Not open for further replies.


Premium Subscriber
Feb 13, 2008
A few months ago I installed liquidsoap on my Ubuntu server at home by downloading the package liquidsoap_0.9.1~savonet-2_i386.deb directly from the savonet web site at:

then using

dpkg -i liquidsoap_0.9.1~savonet-2_i386.deb

to install and configure it from the command line.

Unfortunately today I ran an apt-get upgrade on my machine as I tend to do every week or so and that version got removed and replaced by liquidsoap 0.9.1-1 from the Ubuntu repositories. Unfortunately the version they offer doesn't have MP3 support so everything except my OGG streams died.

After some quick Google research I found this page which provides the lines to add to /etc/apt/sources.list in order to make sure that the MP3 capable version with the latest fixes from Savonet is always the priority. I only had to go so far as the first two lines. YMMV.

DebianStableBackports – Savonet

For those curious, my /etc/liquidsoap/radioref.liq file looks something like this:

#!/usr/bin/liquidsoap -v
radio = amplify(2.0,input.alsa())
output.icecast.mp3( host="", port = 80, password = "xxxxxxxxx", genre="Scanner", description="Scanner audio", mount="/xxxxxxxx", name="Baltimore Maryland Police/Fire/EMS", user="source", url="", bitrate=32, stereo=false, radio)

Once "radio" is defined and processed I can use that variable over and over again to serve multiple streams, or pull back input.alsa() to run different effects. I used the amplify after some friends complained about the low volume and it made it a comfortable volume at most people's defaults, with the BCD-396T feeding my sound card line-in at volume level 3.

In another file I have links for OGG/MP3 feeds on ScanBaltimore and one that points to a local icecast2 server on my LAN (no need to waste bandwidth on the feeds I'm going to listen to while sitting at my desk) which look basically identical except for the ogg line, which looks like this:

output.icecast.vorbis( host="", port = 8000, password = "xxxxxxxx", genre="Scanner", description="Scanner audio", mount="/xxxxxxx", name="Baltimore Maryland Police/Fire/EMS", user="source", url="", stereo=false, quality=5.0, radio)

The OGG stream uses quality instead of bitrate as an option.

I can't even remember how I managed to set up my ALSA since it's "just worked" since I did many years ago and liquidsoap reads it like a champ.
Last edited:
Not open for further replies.