Low to no signal in PDW

Er1kz

Member
Joined
Sep 13, 2020
Messages
25
Hey peeps!

I've recently bought a RTLSDR dongle, RTL2832U.

I've followed the set-up of both this, VBAudiocable and PDW. I've put my settings to the following, (see file attached). Also included is PDW signal and what's coming out.

I can't seem to get over 20% which is very sad since I need about at least 95. I bought the RTLSDR dipole antenna kit; Using our new Dipole Antenna Kit

I don't know if I am doing something wrong or what might be the problem. My RTLSDR dongle is conntected to a hub at top, followed byt a short antenna cable to my two large portable antennas attached to the side of my PC. Right next to the window.

I have tried going outside, to another room.. and still only 20% no matter what I do. I even pulled the antennas out of the dongle and still receiving the same. Everything is brand new so I must be doing something wrong...

Does anyone have any idea?

Thank you,
Erik
 

Attachments

wgbecks

Member
Joined
Jan 17, 2005
Messages
252
Location
Porterfield, Wisconsin
From the attachments it appears you're running SDR#. That being the case then open the "Settings" panel
and check the setting of the RF Gain control. The AGC modes work so, so but my preference is to set the
RG Gain manually to obtain gain to receive the signal of interest without causing the SDR to overload and
create a tone of IM products.

Once you have adequate RF Gain then open the Audio Panel to see that you are directing audio output
to your Virtual Audio Cable device and use the level slider control near the top left corner of SDR#'s display
to obtain satisfactory audio drive downstream.


Settings (2).png
 
Last edited:

Er1kz

Member
Joined
Sep 13, 2020
Messages
25
From the attachments it appears you're running SDR#. That being the case then open the "Settings" panel
and check the setting of the RF Gain control. The AGC modes work so, so but my preference is to set the
RG Gain manually to obtain gain to receive the signal of interest without causing the SDR to overload and
create a tone of IM products.

Once you have adequate RF Gain then open the Audio Panel to see that you are directing audio output
to your Virtual Audio Cable device and use the level slider control near the top left corner of SDR#'s display
to obtain satisfactory audio drive downstream.


View attachment 91320
Hey!

I just played around with RF gain and can't seem to make any difference. When I put my audio down the meter stops. And when I put it to full it's still to the left, with the message "RX-Q", no percentage

Kind regards,
Erik
 

Er1kz

Member
Joined
Sep 13, 2020
Messages
25
From the attachments it appears you're running SDR#. That being the case then open the "Settings" panel
and check the setting of the RF Gain control. The AGC modes work so, so but my preference is to set the
RG Gain manually to obtain gain to receive the signal of interest without causing the SDR to overload and
create a tone of IM products.

Once you have adequate RF Gain then open the Audio Panel to see that you are directing audio output
to your Virtual Audio Cable device and use the level slider control near the top left corner of SDR#'s display
to obtain satisfactory audio drive downstream.


View attachment 91320
I somehow managed to get 87.1%..
 

thewraith2008

Member
Joined
Nov 22, 2016
Messages
1,170
As already noted, it looks like your RF Gain is way to high.
For RTL dongles, an RF Gain of 28 db should be the starting point. Avoid the temptation to crank it right up, this rarely helps.
Normally you set RF Gain to 0, then start adjusting the RF gain up until the noise floor begins to rise then leave it there.

When using SDR# and outputting the audio via a virtual cable, the volume control of SDR# needs to be adjusted so a 'good level' is supplied for PDW to use.

In PDW, the virtual cable also needs to be selected in Menu>Interface>Setup... > Soundcard (enabled).
In PDW, the 'signal meter' is not a true indicator of the supplied audio level.

PDW docs said:
The signal indicator is located on the far right of the toolbar. Unfortunately, it’s
impossible to show the real signal strength, it just starts moving when random noise
is detected and fully moves to the right when the current selected mode is decoded.
Below the signal indicator the RX-Quality is shown. In fact, this is the “decoding quality”,
but this value is highly dependant on signal quality.
In the end, you will still need to have a good signal so what ever you are decoding will decode with a good success rate.
 

Er1kz

Member
Joined
Sep 13, 2020
Messages
25
As already noted, it looks like your RF Gain is way to high.
For RTL dongles, an RF Gain of 28 db should be the starting point. Avoid the temptation to crank it right up, this rarely helps.
Normally you set RF Gain to 0, then start adjusting the RF gain up until the noise floor begins to rise then leave it there.

When using SDR# and outputting the audio via a virtual cable, the volume control of SDR# needs to be adjusted so a 'good level' is supplied for PDW to use.

In PDW, the virtual cable also needs to be selected in Menu>Interface>Setup... > Soundcard (enabled).
In PDW, the 'signal meter' is not a true indicator of the supplied audio level.



In the end, you will still need to have a good signal so what ever you are decoding will decode with a good success rate.
Gotcha, I'm gonna play around more with RF Gain. Currently at 52%...
 

Er1kz

Member
Joined
Sep 13, 2020
Messages
25
I've now made progress, I get to 94.5 and then after 10 minutes of slowly going down it's at 85.9%.... How do I stop it from going down?
 

BM82557

Member
Joined
Aug 28, 2006
Messages
3,162
Location
Berkeley Co WV
I've now made progress, I get to 94.5 and then after 10 minutes of slowly going down it's at 85.9%.... How do I stop it from going down?
Sounds like the dongle is drifting off freq after it warms up. Carefully adjust the PPM after running the dongle 15-20 minutes.
 

Er1kz

Member
Joined
Sep 13, 2020
Messages
25
Sounds like the dongle is drifting off freq after it warms up. Carefully adjust the PPM after running the dongle 15-20 minutes.
So basically adjust Frequency Correction up until it stays at a good %? I put it at 1 now and will conitnue to move it up.
 

ausscan

Member
Joined
Mar 6, 2009
Messages
204
Honestly the best thing I did with an SDR and PDW was move it to linux and use Multimon-ng and Pagermon. Forever trying to set the levels in PDW got the better of me. Also the antenna you use can make a big difference, some people I know can get away with one of those dipoles but I need a tuned antenna in the roof for any decent decode rate.
 

thewraith2008

Member
Joined
Nov 22, 2016
Messages
1,170
Decoding via SDR# and PDW will require a few things to be right before good decodes can be seen.

RTL Dongle PPM must be calibrated. You must tune to a known accurate signal then adjust the PPM value (if needed) until the signal is centered.
- If dongle is 0.5-1ppm type you can adjust and use.
- If dongle is unknown ppm type then you have to warm up (5 mins) dongle before setting the PPM value.
- This warm up period needs to be observed each time the dongle is first started.
- Once PPM value is known and set then you should not have to change again.
A good signal must be seen in SDR#.
No audio filtering should be used in SDR#.
SDR# must be tuned to center of target signal. Sometimes this means the signal could be off frequency to the expected frequency.
A suitable bandwidth value must be set in SDR#. Try 15 KHz and work down. (10 KHz maybe to narrow at first)
The audio level supplied to PDW must be in the sweet spot zone. This requires trail and error.

Here are some questions that will be useful for us to know the answers too.
  • What type of RTL dongle you are using? (e.g. RTL-SDR.com)
  • What is the stability of said dongle (e.g. 0.5ppm)
  • What are you decoding with PDW (e.g. POCSAG, MOBITEX)
  • What is the target signal level like (e.g signal to noise ratio as shown in SDR#)
 

thewraith2008

Member
Joined
Nov 22, 2016
Messages
1,170
Okay, I'll try my best.

1: This is the dongle that I am using: Köp RTL-SDR receiver dongle (v3) till rätt pris @ Electrokit

2: No idea what you mean with stability of dongle...
The specs shown in the link for #1 answers question #2.
The dongle has a 1 ppm stability, this is good (the stability is how much a dongle can drift from a frequency. Less is better)
In SDR# I set my RTL-SDR.com dongle to -1 ppm but you will still need to set this yourself to be sure.

3: I am decoding POCSAG.

4: Attached an image of my SDR#

I usually use 7.5khz and that seems to be the best.
7.5Khz is to narrow for the bandwidth. I see your screenshot says 12.5Khz away. 12.5 Kz should be OK for starters.
Your screenshot does not show a strong signal. If the signal was present when you got the screenshot then the signal is not strong enough.
 

morfis

Member
Joined
Jan 24, 2004
Messages
1,095
This is a screenshot of my settings if they help at all. Gain is set at 17.
Not sure that any individual's gain setting is of much use to other people but your screenshot conveniently shows a couple of strong pager channels, one flex and one POCSAG
Gain setting that is probably a bit higher than required with your set-up and bandwidth is too wide for the POCSAG you have tuned

Back to Erik - re-read the posts from thewraith about 'tuning' your set-up and compare your screenshot of noise with that from Doombar which shows the signals you are looking for. Is your 'dipole' horzontal? It should be vertical and as it seems to have telescopic elements you could try adjusting the lengths to around 45cm each to tune them for your freq of interest.
 

Er1kz

Member
Joined
Sep 13, 2020
Messages
25
Hey!

Put it vertically. And adjusted length to 45cm.

I also played around with settings and it does reach 100% but then goes up and down and then goes bad..... I don't know what to do..
 

morfis

Member
Joined
Jan 24, 2004
Messages
1,095
...... it does reach 100% but then goes up and down and then goes bad..... I don't know what to do..
What reaches 100%?
If you mean the small 'signal meter' in PDW - it doesn't need to and is not a calibrated display anyway. If you mean the %decode underneath that I wouldn't worry until you are feeding PDW with a good clean pager signal

How about another screenshot of your apparently improved signal? The earlier one showed what was essentially 'noise; and not good pager signals
 

Er1kz

Member
Joined
Sep 13, 2020
Messages
25

There it is, I reverted the length of antenna and put it a an upside down V since doingwhat you said made it loose signal completely... Now it goes up and down and is currently at 87%.. but does give me clear messages.
 
Top