• To anyone looking to acquire commercial radio programming software:

    Please do not make requests for copies of radio programming software which is sold (or was sold) by the manufacturer for any monetary value. All requests will be deleted and a forum infraction issued. Making a request such as this is attempting to engage in software piracy and this forum cannot be involved or associated with this activity. The same goes for any private transaction via Private Message. Even if you attempt to engage in this activity in PM's we will still enforce the forum rules. Your PM's are not private and the administration has the right to read them if there's a hint to criminal activity.

    If you are having trouble legally obtaining software please state so. We do not want any hurt feelings when your vague post is mistaken for a free request. It is YOUR responsibility to properly word your request.

    To obtain Motorola software see the Sticky in the Motorola forum.

    The various other vendors often permit their dealers to sell the software online (i.e., Kenwood). Please use Google or some other search engine to find a dealer that sells the software. Typically each series or individual radio requires its own software package. Often the Kenwood software is less than $100 so don't be a cheapskate; just purchase it.

    For M/A Com/Harris/GE, etc: there are two software packages that program all current and past radios. One package is for conventional programming and the other for trunked programming. The trunked package is in upwards of $2,500. The conventional package is more reasonable though is still several hundred dollars. The benefit is you do not need multiple versions for each radio (unlike Motorola).

    This is a large and very visible forum. We cannot jeopardize the ability to provide the RadioReference services by allowing this activity to occur. Please respect this.

M7300 Firmware Update

Status
Not open for further replies.

cameron2645

Newbie
Joined
May 11, 2014
Messages
2
I am having issues installing new firmware on the M7300 radio, if anyone could help out in a step by step of how to do it. The best thing I have tried is:

-Load compression code
-select bootapp
-wait for the radio to show Ready MBAPP R11.0
-Scroll through the radio and select load ECP
-Confirm Y
-wait for computer to show Loading Code
-Computer shows Waiting on responce for Burn App (Kernel)

From there any option I try it fails

Any Advice or Ideas?
 

Radioman96p71

Member
Feed Provider
Joined
Jan 11, 2008
Messages
1,062
Location
Polk County, IA
Not sure if your instructions are quite correct there.

First off, you'll want to read the SRN for the version of ECP/XGP you are using to make sure your radio meets the requirements or if you need to update BurnApp/BootApp.

Either way, you'll want to go into RPM > Radio > Load Compressed Code

Select the button to read Versions and see what all you have going on. Check those against the SRN to make sure they are good to go.

Code should always be loaded in the following order. Skip over a step if you don't need to load that particular firmware. (e.g if BurnApp is the correct version, jump to BootApp, etc)
1. BurnApp
2. BootApp
3. OTP or ECP/XGP
4. Encryption Modules

So if you are upgrading a radio that has everything outdated you'd check BurnApp, point to the new BurnApp code file and hit the Load button. Once you get the all clear go to BootApp and do the same. After that do the ECP/XGP and then the personality.

BurnApp/BootApp/ECP are all different things and CANNOT be interchanged. Loading ECP with BurnApp selected would most likely cause paperweight mode to load. The OMAP radios are some of the most finicky hardware I've seen in a long time. A sideways glance will scare them into a brick.

Good luck, let me know if you get an error and what it is.
 

Muxlow

Super Secret
Joined
Aug 16, 2005
Messages
1,400
Location
Middlesex County
Have you been able to read/write the pers file to the radio? Maybe you dont have the correct com port selected?
 

cameron2645

Newbie
Joined
May 11, 2014
Messages
2
To: Radioman96p71
I am only trying to Load an ECP the weird thing is my XG-75's can take the ECP no problems what so ever the things I see and note is that my RPM askes for BootApp 12A00 and on the XG-75 is MBAPP 11.04. Then the M7300 it comes up as MBAPP 11.00. from there the steps i have taken is

1. Connect radio COM port 1
2. RPM > Radio > Load Compressed Code Select ECP
3. Wait for the radio to Come up with READY MBAPP 11.00
4. Scroll through the radio and select LOAD ECP
5 Confirm Y/N (Ofcourse yes)
6. Radio Reboots
7. Wait for the computer to say Loading code... file = (target ECP)
8. Radio once again Comes up READY MBAPP 11.00
9. Try Selecting ECP Again then on the computer "Failed to Recive Proper Response"

To Muxlow:
Yes I can read and write personalitys into the radio with no issues
 

Radioman96p71

Member
Feed Provider
Joined
Jan 11, 2008
Messages
1,062
Location
Polk County, IA
Sounds like you need to update the BootApp to a newer version.

What is the output from the Show Versions button on that Load Compressed Code screen?
 
Status
Not open for further replies.
Top