mfj-259 troubleshooting help

Status
Not open for further replies.

VE3JSO

Member
Joined
Mar 3, 2007
Messages
985
Location
sarnia ont
hi i was wondering if you guys can help when i switch to vhf 113-170 on mfj-259 the frequency counter will sometimes read 0.00000 and the swr will read 1:1 and resistance and 0ohms but when i move the knob a little then it will read the right freq any ideas what that could be
 

k6cpo

Member
Joined
Dec 30, 2013
Messages
870
Location
San Diego, CA
I have the same issue on my MFJ-259 and I suspect it's from corrosion on the band selector switch. I just haven't gotten into it to try to clean the switch.
 

VE3JSO

Member
Joined
Mar 3, 2007
Messages
985
Location
sarnia ont
ok thanks for the info if you get a chance to clean it before i do could you tell me how you did?
 

k6cpo

Member
Joined
Dec 30, 2013
Messages
870
Location
San Diego, CA
ok thanks for the info if you get a chance to clean it before i do could you tell me how you did?
Now I remember why I didn't clean it before. I opened it up again and the switch is underneath the circuit board and appears to be sealed. I could not see any way to get any contact cleaner into the switch, so I'll just live with it. This analyzer was given to me so when it quits, I'll just go buy one, either a Comet or RigExpert.
 

VE3JSO

Member
Joined
Mar 3, 2007
Messages
985
Location
sarnia ont
Now I remember why I didn't clean it before. I opened it up again and the switch is underneath the circuit board and appears to be sealed. I could not see any way to get any contact cleaner into the switch, so I'll just live with it. This analyzer was given to me so when it quits, I'll just go buy one, either a Comet or RigExpert.
ah ok thanks after looking into the problem on google i found this site that might help fix the problem http://www.w8ji.com/mfj-259b_calibration.htm but i am going to contact mfj and talk to them before i do anything
 
Last edited:
Status
Not open for further replies.
Top