mmdvm hat problem -- strange

KE4LH

Newbie
Joined
Jul 31, 2020
Messages
2
I have a mmdvm_hs board on a Pi Zero W. It's a cheap chinese knockoff but I can get it online via wifi. And it does answer back to my dstar radio. It even shows green connection to Dstar network and will even link to a reflector if I do it in the admin page. However, it will not link via radio commands, and the pi-star dashboard never shows any rf activity even though it broadcasts time and link info. It will only link if I go into the admin page and tell it to link to a reflector, and then it anounces the link. But I cannot talk, or hear any traffic on any reflector I choose. I have manually set an IP address on my router and the mmdvm, and opened all ports directed to that IP. I believe the hat radio has a problem since it doesn't report rf traffic but perhaps its just off frequency. I put in the recommended offset -475RX, and tried all kinds of settings with the same results. It does improve the anouncement voice a little but that's it. Not tried any TX offsets... I've even tried wifi to my phone with the same results. Ive even direct tied it via an ethernet/usb adaptor with same results.... Anyone have any ideas...? It does send my call letter back to the radio after a key up but that's all it does.
 

RadShackFan

Member
Joined
Jun 2, 2010
Messages
191
What radio are you using?

What is the TX & RX frequency on the hotspot?

What is the TX & RX frequency on the radio?
 

RadShackFan

Member
Joined
Jun 2, 2010
Messages
191
If you're using an Icom HT, watch this video and follow his suggestions. I did and my ID-51A works with my Chinese hotspot just fine.

 

dmaria

Member
Premium Subscriber
Joined
May 24, 2010
Messages
270
One of the biggest problems that is encountered while setting up a hotspot with D-Star is that the radio must be set for duplex. It seems like it should be a simplex setup but it is not. The radio needs to be setup for duplex just like for repeater use. Just program the radio with a zero offset (plus or minus, it doesn't matter).
 

KE4LH

Newbie
Joined
Jul 31, 2020
Messages
2
I'm using an IC7100 but I also have a 5100. I just got finished re-programming the thing and also setting my radio Callsign module to the correct 8th position. That fixed it and it's now working quite well. To be honest, I was thinking there wasn't going to be an answer and I want to say thank you all for helping. I had already known about the repeater offset to zero issue but the final piece was the module number being in the number 8th callsign position as noted in the video above. Thanks everyone. I'm going to document all of my findings and hopefully help others get thru this problem of configuration. Took me 4 days, on and off..
 
Top