• To anyone looking to acquire commercial radio programming software:

    Please do not make requests for copies of radio programming software which is sold (or was sold) by the manufacturer for any monetary value. All requests will be deleted and a forum infraction issued. Making a request such as this is attempting to engage in software piracy and this forum cannot be involved or associated with this activity. The same goes for any private transaction via Private Message. Even if you attempt to engage in this activity in PM's we will still enforce the forum rules. Your PM's are not private and the administration has the right to read them if there's a hint to criminal activity.

    If you are having trouble legally obtaining software please state so. We do not want any hurt feelings when your vague post is mistaken for a free request. It is YOUR responsibility to properly word your request.

    To obtain Motorola software see the Sticky in the Motorola forum.

    The various other vendors often permit their dealers to sell the software online (i.e., Kenwood). Please use Google or some other search engine to find a dealer that sells the software. Typically each series or individual radio requires its own software package. Often the Kenwood software is less than $100 so don't be a cheapskate; just purchase it.

    For M/A Com/Harris/GE, etc: there are two software packages that program all current and past radios. One package is for conventional programming and the other for trunked programming. The trunked package is in upwards of $2,500. The conventional package is more reasonable though is still several hundred dollars. The benefit is you do not need multiple versions for each radio (unlike Motorola).

    This is a large and very visible forum. We cannot jeopardize the ability to provide the RadioReference services by allowing this activity to occur. Please respect this.

Motorola TETRA MTH800 & MTP850 - can't get into programming mode manually

swaggerro

Newbie
Joined
May 19, 2023
Messages
1
Hello all,

I need a hand getting my TETRA radios to programming mode.

I've searched the whole Google for a workaround for these 2 masterpieces, but I don't have any patience with them...

I've just bought the Motorola PMKN4025A RS232 Serial cable, and connected to my Windows 7 machine, which I especially installed yesterday, for the Motorola CPS Plus 7.3 (R 07.30.09.30).

My MTH800 it's running under R07.000.8661 firmware meanwhile the MTP850 is running under R13.000.8462 firmware.

Tried all the found methods to get them into the programming mode, so I can connect with the CPS software to program them.

I think the MTH800's firmware it's a little to old for this CPS version, but I'll solve this later. I can fire up a Windows XP VM and install a legacy CPS which will allow me to upgrade to a newer firmware.

Tried 1+9+Power -> nothing happens. The radio will not turn on at all. On both of them, tried with the cable connected to the radio and to the computer.

Tried all USB ports on the computer, so there's no reason to question the functionability of the USB ports.

I've opened PuTTY and connected via Serial - when the radio boots up, sends a bunch of datas, so there's also confirm that the serial cable works.

What can I do so I get these radios into the programming mode? Also, the *# Self Menu does not work on neither of the radios.

Both of the radios are fully working, non TEA encrypted, due to Romanian Ham TETRA & Local Regulations prohibiting the encryption.

They are not faulty at all, inspite, the MTP850 was programmed before, because it has all the HAM Radio frequencies saved into different folders.

I'm running out of any ideas of what I could do, and I think I should be able to get them into the programming mode, since with the serial cable you can even restore a bricked radio, and this is not the case in my sittuation.

When I go to Tetra CPS -> Tools - Detect Radio on RS232 Port, input the COM port from the Device Manager - COM | I will get the error that no radio was detected.

Any ideas/suggestions are highly and greately appreciated!!

Thanks
 

AM909

Radio/computer geek
Premium Subscriber
Joined
Dec 10, 2015
Messages
1,154
Location
SoCal
I don't know if it's related, and can't remember for which radio it came up, but if it matters, I had a DE-9S to DB-25P adapter cable hanging off a programming computer, which turned out to not have one important conductor in it – RI (ring indicator) on DB-25 pin 22 to DE-9 pin 9. It was apparently needed by something I was programming.
 
Top