• To anyone looking to acquire commercial radio programming software:

    Please do not make requests for copies of radio programming software which is sold (or was sold) by the manufacturer for any monetary value. All requests will be deleted and a forum infraction issued. Making a request such as this is attempting to engage in software piracy and this forum cannot be involved or associated with this activity. The same goes for any private transaction via Private Message. Even if you attempt to engage in this activity in PM's we will still enforce the forum rules. Your PM's are not private and the administration has the right to read them if there's a hint to criminal activity.

    If you are having trouble legally obtaining software please state so. We do not want any hurt feelings when your vague post is mistaken for a free request. It is YOUR responsibility to properly word your request.

    To obtain Motorola software see the Sticky in the Motorola forum.

    The various other vendors often permit their dealers to sell the software online (i.e., Kenwood). Please use Google or some other search engine to find a dealer that sells the software. Typically each series or individual radio requires its own software package. Often the Kenwood software is less than $100 so don't be a cheapskate; just purchase it.

    For M/A Com/Harris/GE, etc: there are two software packages that program all current and past radios. One package is for conventional programming and the other for trunked programming. The trunked package is in upwards of $2,500. The conventional package is more reasonable though is still several hundred dollars. The benefit is you do not need multiple versions for each radio (unlike Motorola).

    This is a large and very visible forum. We cannot jeopardize the ability to provide the RadioReference services by allowing this activity to occur. Please respect this.

Motorola XTS3000 CPS

Status
Not open for further replies.

tgrahmann

Member
Premium Subscriber
Joined
Oct 26, 2016
Messages
19
Hi, I'm sure this has been asked before but I haven't had any luck finding an answer. Does anybody know where one would find the XTS3000 Astro 25 CPS? I've found an older version but when I try to "Read Device" from within the software I get a "Failed to Read Device" error. I researched that and it said I needed a newer version (which I was unable to find anywhere). if anybody has any insight on this that would be great!
Thanks
 

Tech792

Member
Joined
Mar 25, 2003
Messages
1,617
Location
Central NJ
XTS3000 doesn't use Astro 25 CPS. It uses the 20 year old Astro Saber CPS. I don't have the part number in front of me though.
 

tgrahmann

Member
Premium Subscriber
Joined
Oct 26, 2016
Messages
19
The Astro Saber 25 XTS3000 Software is actually what I had found, sorry for misnaming it. However, I have a version that is not "up to date" and It won't read my radio.
 

tgrahmann

Member
Premium Subscriber
Joined
Oct 26, 2016
Messages
19
Let me also follow up with the fact that I AM running this version (5.03.00) of the Astro Saber CPS on a Windows Virtual Machine with a RIB-less cable AND a Serial to USB adapter. Could any of that cause this issue?
 

tgrahmann

Member
Premium Subscriber
Joined
Oct 26, 2016
Messages
19
I'm Running XP Pro in Parallels with a USB-to-Serial cable attached to a RIBless cable. I don't feel like any of that would affect this issue, but could it?
 

tgrahmann

Member
Premium Subscriber
Joined
Oct 26, 2016
Messages
19
I'm using a RIBless radio-to-serial cable from Valley Enterprises. Checked the ports and they're correct. Do you think its the 5.03.00 version I'm using?
 

SCPD

QRT
Joined
Feb 24, 2001
Messages
65,126
Location
Virginia
I suppose its possible you using latest firmware on that radio witch actually the last one i think was firmware 7.71.07 dsp N08.03.05

Sent from my LG-D321 using Tapatalk
 

Anderegg

Enter text in this field
Premium Subscriber
Joined
Mar 7, 2010
Messages
1,827
Location
San Diego
tg, I similarly run XTS3000 CPS from Parellels 12 on a Mac. My older Cables2Go USB serial adaptor stopped working some time ago (6-8 months), due to a change in an update to Parallels, simply did not work, got the same error as you did. I replaced my blue C2G USB to serial adaptors with one from IOgear, and everything is working fine now. Old blue has been replaced by new grey.

About $13 from B&H photo video https://www.iogear.com/product/GUC232A/

Also, does XTS3000 CPS read/write on 64bit Windows 7? I was under the impression it only works properly under 32bit, but maybe that is for serial port RIB use?

Paul
 
Status
Not open for further replies.
Top