My Radio Shack Pro 96

Status
Not open for further replies.

bencox3731

Member
Joined
Feb 23, 2011
Messages
7
My Radio Shack Pro 96 keeps rebooting itself or shutting off. Any ideas as to why this would be happening? Please help.
 

Keith_W7KEW

Member
Joined
Feb 7, 2011
Messages
156
Location
California
I have you tried to initialize the radio? Is it possible that the batteries are bad or the DC power connection is? Another possibility is that the a PCB connection has come loose.
 

RadioDaze

Member
Joined
Oct 5, 2006
Messages
2,036
Location
Orange County, California, USA
Is this on battery power? Sometimes the contacts inside the battery compartment lose a bit of their "springy-ness". You might try GENTLY pulling them outward slightly so that they give more pressure. Another thing that happens sometimes is that the battery holders develop cracks, causing the batteries to lose some contact with holder's, well, contacts.

Further analysis will soon follow from the good folks on this forum.
 

joetnymedic

Member
Feed Provider
Joined
May 30, 2003
Messages
761
Location
West Haven, CT
i'd go with radiodaze's idea first as its simple and very common. i had the same thing happen with one of my rs scanners good luck,
joe
 

bencox3731

Member
Joined
Feb 23, 2011
Messages
7
It appears that there is a crack in the battery holder. Today I was not getting it to turn on at all. I put some electrical tape to try and see if that would hold it together enough. Now it makes a humming noise whereas I was not getting anything earlier. Should I try a new holder? I also tried a universal 9v car adapter and did not get anything. I also slightly pulled out the contacts as suggested but still nothing. Is it toast?????
 

fmon

Silent Key Jan. 14, 2012
Joined
May 11, 2002
Messages
7,741
Location
Eclipse, Virginia
It appears that there is a crack in the battery holder. Today I was not getting it to turn on at all. I put some electrical tape to try and see if that would hold it together enough. Now it makes a humming noise whereas I was not getting anything earlier. Should I try a new holder? I also tried a universal 9v car adapter and did not get anything. I also slightly pulled out the contacts as suggested but still nothing. Is it toast?????
Remove the batts and holder then try the 9v car adapter.
 

hoser147

Member
Joined
Dec 17, 2005
Messages
4,452
Location
Grand Lake St. Marys Ohio
Does anyone know of a repair shop in Oregon that can work on these?
Send it in thru your local Radio Shack, I had a problem with mine not working, sent it in and had it back in a couple of weeks cost about 45 bucks, they also sent a coupon worth 20 bucks on next purchase back with it. Good Luck.
 
Status
Not open for further replies.
Top