New Kiwa filter shorts my icom r75

Joined
Feb 6, 2011
Messages
68
Location
Cameron County, Tx
Hi guys I need some help I was just installing my new kiwa filter making a YouTube before and after video and as soon as I installed the filter my icom went out the light won't show and it only shows this on the screen I thought Craig was a reputable and trustworthy service tech I can't seem to factory reset my icom any advice
 

wb4sqi

Member
Premium Subscriber
Joined
Mar 7, 2003
Messages
208
Location
Cincinnati, OH
Hi guys I need some help I was just installing my new kiwa filter making a YouTube before and after video and as soon as I installed the filter my icom went out the light won't show and it only shows this on the screen I thought Craig was a reputable and trustworthy service tech I can't seem to factory reset my icom any advice
I wouldn't be blaming Craig as this point, his filters and mods reside in a great many radios and work perfectly.

Try reversing your install, return your radio to stock condition. If it still doesn't work then your installation may have caused your problems. If it does work when you return it to stock it's possible the filter is defective but I can't imagine an IF filter causing the issues you are reporting.

Let us know your results please.
 
Joined
Feb 6, 2011
Messages
68
Location
Cameron County, Tx
Yes talked with him and found out I actually did it!!!! The ribbon that is white right to the 455 filter spot I accidentally popped out when I was putting it in but she's up and running now and boy that filter he made is kicking butt!!
 

wb4sqi

Member
Premium Subscriber
Joined
Mar 7, 2003
Messages
208
Location
Cincinnati, OH
Yes talked with him and found out I actually did it!!!! The ribbon that is white right to the 455 filter spot I accidentally popped out when I was putting it in but she's up and running now and boy that filter he made is kicking butt!!
Good to hear that. Mine is loaded with Kiwa filters and sync mod, makes a good radio great.
 

wb4sqi

Member
Premium Subscriber
Joined
Mar 7, 2003
Messages
208
Location
Cincinnati, OH
How well does that sync mod work? Does it make a difference what exactly does it do with the s am
To me like it locks to the carrier quicker and responds to fading signals much better than the original Icom software. Just seems more responsive like one would expect SD to work. Depends on what your ears tell you, everyone hears things differently.
 
Top