TRX-2: New TRX-2 Extremely Frustrated

Status
Not open for further replies.

KE4NYV

Member
Joined
Apr 18, 2003
Messages
1,017
Location
Williamsburg, VA.
Well, I finally did it. I bought a TRX-2. I am already frustrated with it and I haven't even had the first chance to scan anything yet.

I started off with downloading a fresh version of EZ Scan, Updater and the driver .inf file.

Install of EZ Scan went fine. I powered up the unit and I immediately did a CPU update. It was a bit cumbersome, but the update completed. Updating the DSP is another story. No matter how many times I tried, it would get as far as downloading the file, the radio would power down and then it would go into a USB charging mode. If I manually turned the radio on, the software would eventually error out and crash. Now I am constantly getting the dreaded "Waiting for main unit" error. I have now done about ten cycles of pulling the power and head, waiting about a minute and then powering it back up. It keeps happening and I'm hoping these CPU and DSP updates will fix that.

With the Updater utility, I am attempting the hold Menu button and plug in USB. I eventually get an indication that the scanner is seen by Windows and I can verify a com port of COM5 assigned. If I select it and test, I get an error. I can't get past this point. I have spent more time resetting it than working the issues.

I can tell you that when I did the CPU upgrade, the firmware prior to update was in the 1.x range. I think it was updated to 4.4.

Any suggestions? I was hoping to take this on a trip this weekend, but now I'm considering boxing it back up and exercising my Amazon return policy. It's really disappointing, because I was excited to finally get one of these. I didn't think it would be this trying of my patience and I have been working with GRE scanner for over 15 years.
 

nacsr

Member
Premium Subscriber
Joined
Jan 18, 2003
Messages
194
Location
Rome,NY
You do have the scanner off,right?I have the TRX-1 and it has to be off while updating .
 

SCPD

QRT
Joined
Feb 24, 2001
Messages
0
Location
Virginia
i would disable your Virus protection on your computer and in my case I had hit the test button about six times before it found it and did its thing
I wish Whistler would remove CPU update from EZscsn it causing nothing but problems



Well, I finally did it. I bought a TRX-2. I am already frustrated with it and I haven't even had the first chance to scan anything yet.

I started off with downloading a fresh version of EZ Scan, Updater and the driver .inf file.

Install of EZ Scan went fine. I powered up the unit and I immediately did a CPU update. It was a bit cumbersome, but the update completed. Updating the DSP is another story. No matter how many times I tried, it would get as far as downloading the file, the radio would power down and then it would go into a USB charging mode. If I manually turned the radio on, the software would eventually error out and crash. Now I am constantly getting the dreaded "Waiting for main unit" error. I have now done about ten cycles of pulling the power and head, waiting about a minute and then powering it back up. It keeps happening and I'm hoping these CPU and DSP updates will fix that.

With the Updater utility, I am attempting the hold Menu button and plug in USB. I eventually get an indication that the scanner is seen by Windows and I can verify a com port of COM5 assigned. If I select it and test, I get an error. I can't get past this point. I have spent more time resetting it than working the issues.

I can tell you that when I did the CPU upgrade, the firmware prior to update was in the 1.x range. I think it was updated to 4.4.

Any suggestions? I was hoping to take this on a trip this weekend, but now I'm considering boxing it back up and exercising my Amazon return policy. It's really disappointing, because I was excited to finally get one of these. I didn't think it would be this trying of my patience and I have been working with GRE scanner for over 15 years.
 

KE4NYV

Member
Joined
Apr 18, 2003
Messages
1,017
Location
Williamsburg, VA.
You do have the scanner off,right?I have the TRX-1 and it has to be off while updating .
Yes, I got that figured out after a couple of tries. They don't specify in the steps to have it off. However, I never could get past the step where you test the connection.

Since posting this, I finally got the scanner to start up and tried from a different computer running Windows 7. I was able to verify that at some point, the DSP updated to the latest. Not sure which time. However, I still cannot read/write the SD card through the scanner, so I am resorting to using a card reader. After I pulled the card to start again, it went back to the Waiting for main unit error. I'm in another reset/waiting time. Beyond frustrating.

I guess the CPU and DSP firmware updates didn't fix this problem.
 

Ed6698

Active Member
Premium Subscriber
Joined
Feb 19, 2011
Messages
1,220
Location
Evansville, Indiana
Need to read the owners manual, says right in there to have scanner off, and it is the 1st step listed. What is not listed though, make sure to have the latest version of EZScan before doing cpu/dsp updates, with PC Application Update
 
Last edited:

jdolina

Member
Premium Subscriber
Joined
Jul 4, 2006
Messages
448
Location
Lorain Ohio
To speed up the reset process just do an unplug and hold the power button and count to 30 (I believe 20 works). It is a bit finicky with the usb and I just had to learn to be patient. I tried installing the non-secure whistler drivers for windows 10 and it did not make a difference. When it comes time to update I get the best results following these steps

Make sure Ez-scan is not running
Power off the scanner
Wait for the drive to show up in windows
Run EZ-Scan
Before a cpu/dsp update I usually do the set time to make sure communication is working then proceed
To update the library or vscan folders I start the process and wait....it does seem to 'hang' at least twice during this time and the usb drive is not accessible from windows. It does return and the write continues this is where you have to be patient.

I remember the first time I hooked mine up and had a similar experience. I stuck with it and like the unit well except the usb interface from EZ-scan which really needs to be fixed.
 

Ubbe

Member
Joined
Sep 8, 2006
Messages
4,908
Location
Stockholm, Sweden
DSP upgrades are always strange. It cuts my USB connection when trying to update. Thankfully there hasn't been any new DSP versions since december.

I would suggest getting a card reader and reformat the SD card using SDFormatter and prepare SD card for use from EZScan and program it while in the card reader. If you ever get errors on the TRX display when programming/update then move the SD card to the card reader and do a normal windows check disk, but it usually does that automaticly.

/Ubbe
 

03msc

RF is RF
Premium Subscriber
Joined
Jun 3, 2011
Messages
2,997
Location
Arkansas
DSP upgrades are always strange. It cuts my USB connection when trying to update. Thankfully there hasn't been any new DSP versions since december.


/Ubbe
It has to because it is changing the scanner mode from USB drive (for programming) into DSP update (or firmware, when doing firmware) mode...just let it do its thing.
 

KE4NYV

Member
Joined
Apr 18, 2003
Messages
1,017
Location
Williamsburg, VA.
I was finally able to get it up and going, but still suffered two more episodes of Waiting for main unit before I quit for the night. I did resort to doing all of the reading/writing through my SD card reader, instead of through the radio. I prefer this anyways, because at some point this will be installed in my Jeep and I would much rather just pull the card, take it inside and update it, opposed to taking the radio inside or bringing my laptop out to the car. On the other hand, I do that all of the time to update my Motorola DMR radio in the car, but you get the idea ;)

Thanks for the tips and advice, everyone!
 

goodmore

Member
Joined
Dec 11, 2016
Messages
143
Location
Lancaster County PA
Library updates are much faster using the SD card reader. No doubt about that. I usually do a library update every other week. One thing I found out is to make sure you make a backup of your scan lists. Reformatting the card and loading it from a file is quick and easy. It allows you play with the settings without worry of erasing hours of work.
 

AKJohnny

Scanner Addict
Premium Subscriber
Joined
Jan 18, 2007
Messages
140
Location
Kendall County, IL
I was finally able to get it up and going, but still suffered two more episodes of Waiting for main unit
I've had that same message on two different TRX-2's. You're not alone. Ive also had powering on stick at "Initializing USB interface" on both as well. This Scanner seems really flaky with powering on. I wish it worked more reliably. I'll bet Whistler probably gets many returns because of these issues.
 

Ed6698

Active Member
Premium Subscriber
Joined
Feb 19, 2011
Messages
1,220
Location
Evansville, Indiana
Like I have said in the past with these radios, most all errors and problems are user created. I have owned 2 Whistler scanners for 3 years now, I don't have any issues. When the user manual is not read, then blame the problems on the radio. Most problems are created by the user, connecting scanner to computer via USB while scanner is on or not properly ejecting/removing media. Not properly powering on or off radio by pressing and holding down the power button for a couple seconds. Plugging in and unplugging the radio while the radio is on with external power. All this stuff is in the manual that most users evidently don't read, then blame Whistler.

This by no means is directed at original poster, it is just a general overall observation with issues posted in these forums, both Whistler and Uniden.
 
Last edited:

BrianLoch

Member
Premium Subscriber
Joined
Jul 10, 2010
Messages
20
Location
PA-US
Like I have said in the past with these radios, most all errors and problems are user created. I have owned 2 Whistler scanners for 3 years now, I don't have any issues. When the user manual is not read, then blame the problems on the radio. Most problems are created by the user, connecting scanner to computer via USB while scanner is on or not properly ejecting/removing media. Not properly powering on or off radio by pressing and holding down the power button for a couple seconds. Plugging in and unplugging the radio while the radio is on with external power. All this stuff is in the manual that most users evidently don't read, then blame Whistler.



This by no means is directed at original poster, it is just a general overall observation with issues posted in these forums, both Whistler and Uniden.


I completely understand your point. However, not all here are ignorant due to laziness. i.e. I have 20+ years experience in public safety communications. I have had great whistler and uniden units. My PSR-400 HANDS DOWN is the best conventional trunking scanner I've ever owned. My handheld bearcat four-six back in the day had been my favorite HH. My Relm MS200 in the late 90's was the most sensitive straight up conventional that could go head to head with my Icom IC-R5. The point is, there will always be the last one made on Friday before the holiday weekend unit. I wholeheartedly agree the reference to not reading they manual ect. I have had a major issue with my WS1095 in the 150-160 Mhz range both conventional and digital. I have sent files and zips to whistler and my config is fine. To those who don't read and learn the proper method, you reap what you sow. To those of you / us who genuinely have an issue, we sympathize. Icom, Whistler, Uniden ect. YMMV. I sincerely hope we can all help, and point each other in the right direction - in order to have the best experience possible. This is by no means a direct attack on the previous poster- just a reiteration with my 2¢.


Sent from my iPhone using Tapatalk
 

SCPD

QRT
Joined
Feb 24, 2001
Messages
0
Location
Virginia
I will not go as far as saying that most issues are caused by user error.

However ... some problems are. I expect what we are seeing here is the learning curve at work. The Whistler scanners are VERY different than the Uniden scanners. Just cause you own a Uniden does not mean that you could not have issues with a Whistler. It works both ways btw .. and why I overall hate most Uniden scanners, even though I own some.

Me .. I am running down to pull my 1095 from my car. I long for the day that the manufacturers make a scanner that just works (mostly from a performance point of view).

But when cellular sites have an erp of around 300 watts *my biggest issue right now .. the poor little scanner has little chance of working.
 
Last edited:

Ubbe

Member
Joined
Sep 8, 2006
Messages
4,908
Location
Stockholm, Sweden
It has to because it is changing the scanner mode from USB drive (for programming) into DSP update (or firmware, when doing firmware) mode...just let it do its thing.
Firmware upgrades works fine but the DSP upgrade are always problematic. I have to try with different computers and I think it is a very slow laptop that finally could do DSP upgrades without cutting off the USB in the middle of the upgrade.

It never recovers from that USB failure regardless of waiting time with a powerful computer. All computers running win7 home.

/Ubbe
 

SCPD

QRT
Joined
Feb 24, 2001
Messages
0
Location
Virginia
why not get

After reading these posts I might get the uniden 436 instead. Would save a lot of hassle.
Get a TRX1 ,theres no issues with that ...I have had no problems.I am using a duo core PC.
I had a 436HP and the TRX1 at the same time,the uniden lost and I sold it.
 

kc2kth

Member
Premium Subscriber
Joined
Mar 27, 2004
Messages
425
Location
Toms River NJ
Get a TRX1 ,theres no issues with that ...I have had no problems.I am using a duo core PC.
I had a 436HP and the TRX1 at the same time,the uniden lost and I sold it.
I have both, had the 436 for a couple of years now and the TRX1 I've had for a couple of months. I use both with similar programming. They hear about the same for me - the TRX1 picks up a channel or two better than the 436 does. What kills is startup time on the TRX1. With a 32GB card in it startup is too slow. With the 436 and the same 32GB card I can hear my local fire horn, turn on the 436 and not miss the call. Not even close with the TRX1.
 
Status
Not open for further replies.
Top