TwoToneDetect New TwoToneDetect in the works - Python based

tn_medic_533

Member
Joined
Oct 8, 2008
Messages
26
Location
White County, Tennessee
Andy,
Got it to identify the two tone sets I have been testing with, but now it is throwing up the error that Police Chaser has posted. The only difference is mine has two sets of 00:00 instead of having the 4 sets like his and one has the 13:25.

Justin
Disregard that last post please. I was not thinking about what you said. Everything is up and going like it should be now, sending pages. Thanks again for the great program and all the help you have provided.

Justin
 

tn_medic_533

Member
Joined
Oct 8, 2008
Messages
26
Location
White County, Tennessee
Is there anyway to put two of these programs on the computer and have them switch back and forth on certain days with two different sets of email addresses? What I am trying to do is set this program up for our EMS station. We have two work weeks and when one work week is off, is there some way I can have this program be able to switch to the week that is on shift, and then when they go off shift it will switch to the on coming week?
 

aaknitt

Member
Feed Provider
Joined
Aug 27, 2005
Messages
1,240
I imagine you could do this using Windows Task Scheduler and some batch files. You could create a batch file that would kill the program, change the tone/config files by copying a renamed version, and then restart the program. You could then set up Task Scheduler to run the batch file(s) whenever you wanted. Just a thought, I haven't tried it.

Andy
 

tn_medic_533

Member
Joined
Oct 8, 2008
Messages
26
Location
White County, Tennessee
I imagine you could do this using Windows Task Scheduler and some batch files. You could create a batch file that would kill the program, change the tone/config files by copying a renamed version, and then restart the program. You could then set up Task Scheduler to run the batch file(s) whenever you wanted. Just a thought, I haven't tried it.

Andy
Andy,
Thanks for the advise. Not very computer knowledgable so I'll have to try to figure out how to do what you mentioned and see if it works. Thanks again.

Justin
 

chad3405

Member
Joined
Nov 18, 2009
Messages
30
Location
Texas
Just wondering if any one knows where I could find a more step by step setup page for the new TwoToneDetect. I was using the lab view vers and it had a nice little how to page every thing from installing the mp3 encoder to two tone and lab view its self. I mainly need help with the 3rd party programs that need to run so that two tone can do its job & when and where to stick files to make it work properly. once I get it going I will be able to manage the setup.
I am not much on PC programs but I can sure follow instructions. Also I may be making this harder than it needs to be Im not really even sure if you need lots of 3rd party programs on this vers like you did in the lab view.
Thanks for any help!
Chad
 
Last edited:

aaknitt

Member
Feed Provider
Joined
Aug 27, 2005
Messages
1,240
Just wondering if any one knows where I could find a more step by step setup page for the new TwoToneDetect. I was using the lab view vers and it had a nice little how to page every thing from installing the mp3 encoder to two tone and lab view its self. I mainly need help with the 3rd party programs that need to run so that two tone can do its job & when and where to stick files to make it work properly. once I get it going I will be able to manage the setup.
I am not much on PC programs but I can sure follow instructions. Also I may be making this harder than it needs to be Im not really even sure if you need lots of 3rd party programs on this vers like you did in the lab view.
Thanks for any help!
Chad
Chad,

I don't have a detailed guide put together yet. Check the README.TXT file that comes with the program. The only extra program you need is ffmpeg.exe, and the README file has instructions for where to get it and where to put it.

Andy
 

tjacks34

Member
Joined
Aug 1, 2009
Messages
63
Location
south rockwood mi
any ideas on how to fix this?
On our long tones here they dispatch twice, long tone message, long tone message, when it is complete it will send anywhere from 2 to 4 emails out the first two are identical and the last 1 to 2 are identical.
Any ideas?
thanks and wonderful program again
 

tn_medic_533

Member
Joined
Oct 8, 2008
Messages
26
Location
White County, Tennessee
Just wondering if any one knows where I could find a more step by step setup page for the new TwoToneDetect. I was using the lab view vers and it had a nice little how to page every thing from installing the mp3 encoder to two tone and lab view its self. I mainly need help with the 3rd party programs that need to run so that two tone can do its job & when and where to stick files to make it work properly. once I get it going I will be able to manage the setup.
I am not much on PC programs but I can sure follow instructions. Also I may be making this harder than it needs to be Im not really even sure if you need lots of 3rd party programs on this vers like you did in the lab view.
Thanks for any help!
Chad
Chad,
I was in the same boat you are, but got it figured out and love it. First, download the v49 and the ffmpeg.exe from the two locations Andy has posted. Go to page 7, post #138 on this thread and you'll see where he has v49 for download. Download this link: http://ffmpeg.zeranoe.com/builds/win...in32-static.7z
Once you have that downloaded, open it and click the folder that is marked bin. In that folder, you will see a file marked ffmpeg.exe. Copy or move that into the TwoToneDetect49 folder. Then open the config.cfg file in the TTD49 folder. Enter the gmail (or which ever accout you are using) username. From there, you need to get on a search engine and type in Base64 Encryption. Put your password in to one of those converters and get the password in Base64 encrypted. Copy and paste that in to the section of the config.cfg file with password. SAVE THOSE SETTINGS!!!! Then go to the tones.cfg file in TTD49. Put your tone codes in how it is shown from there as [Tone1], [Tone2], etc. **If you are not using the part where you put in not to send messages to these addresses durring these times under [Tone2], DELETE IT!!** Put the tone codes and addresses you want them sent to in that file, click save. From there, you should be up and running.

Justin
 

chad3405

Member
Joined
Nov 18, 2009
Messages
30
Location
Texas
Thanks!

Thanks man!

Chad,
I was in the same boat you are, but got it figured out and love it. First, download the v49 and the ffmpeg.exe from the two locations Andy has posted. Go to page 7, post #138 on this thread and you'll see where he has v49 for download. Download this link: http://ffmpeg.zeranoe.com/builds/win...in32-static.7z
Once you have that downloaded, open it and click the folder that is marked bin. In that folder, you will see a file marked ffmpeg.exe. Copy or move that into the TwoToneDetect49 folder. Then open the config.cfg file in the TTD49 folder. Enter the gmail (or which ever accout you are using) username. From there, you need to get on a search engine and type in Base64 Encryption. Put your password in to one of those converters and get the password in Base64 encrypted. Copy and paste that in to the section of the config.cfg file with password. SAVE THOSE SETTINGS!!!! Then go to the tones.cfg file in TTD49. Put your tone codes in how it is shown from there as [Tone1], [Tone2], etc. **If you are not using the part where you put in not to send messages to these addresses durring these times under [Tone2], DELETE IT!!** Put the tone codes and addresses you want them sent to in that file, click save. From there, you should be up and running.

Justin
 

Forts

Mentor
Database Admin
Joined
Dec 19, 2002
Messages
6,142
Location
Ontario, Canada
any ideas on how to fix this?
On our long tones here they dispatch twice, long tone message, long tone message, when it is complete it will send anywhere from 2 to 4 emails out the first two are identical and the last 1 to 2 are identical.
Any ideas?
thanks and wonderful program again
I'm in the same boat with our county dispatches. Tones will go off, then the message, then tones again. I've switched back to the LabView version for the time being but am keeping a close eye on the development of this version.
 

tn_medic_533

Member
Joined
Oct 8, 2008
Messages
26
Location
White County, Tennessee
I imagine you could do this using Windows Task Scheduler and some batch files. You could create a batch file that would kill the program, change the tone/config files by copying a renamed version, and then restart the program. You could then set up Task Scheduler to run the batch file(s) whenever you wanted. Just a thought, I haven't tried it.

Andy
Andy,
I have looked all over and really don't understand what you mean by doing this. Is there any way you might be able to break it down a little bit simpler or maybe give me a point in the right direction of where to look to understand this. I have got two folders of TTD v49 on the desktop and have got the two different tone sets in each file. I have then tried to get them to start and switch automatically with the task scheduler but have had no success. Any help would be great.

Thanks,
Justin
 

wgriffin81

Newbie
Joined
Oct 15, 2011
Messages
3
Location
NJ
Awesome Job

Andy,

This is a great program, thanks for putting it out there for everyone. I'm so glad I stumbled across your program and these threads (this & lab view version)


Only one question for you or another member, as I did not see anyone else post this error yet. Our squad has two sets of tones only, the first set work terrific with no problems. The second set does not, I have tried to toy with it with no luck.

Here is the error message:

Unhandled exception in thread started by <function alert at 0x014F48B0>
Traceback (most recent call last):
File "<string>", line 305, in alert
File "E:\Python\build\pyi.win32\TwoToneDetect49\outPYZ1.pyz/wave", line 500, i
n open
File "E:\Python\build\pyi.win32\TwoToneDetect49\outPYZ1.pyz/wave", line 303, i
n __init__
IOError: [Errno 2] No such file or directory: './audio/Extra_Member_/_Full_Scram
ble_2011-10-1915_06_52_828000.wav'
Exception AttributeError: "Wave_write instance has no attribute '_file'" in <bou
nd method Wave_write.__del__ of <wave.Wave_write instance at 0x01587288>> ignore
d


Thanks again,
Bill
 

aaknitt

Member
Feed Provider
Joined
Aug 27, 2005
Messages
1,240
Andy,

This is a great program, thanks for putting it out there for everyone. I'm so glad I stumbled across your program and these threads (this & lab view version)


Only one question for you or another member, as I did not see anyone else post this error yet. Our squad has two sets of tones only, the first set work terrific with no problems. The second set does not, I have tried to toy with it with no luck.

Here is the error message:

Unhandled exception in thread started by <function alert at 0x014F48B0>
Traceback (most recent call last):
File "<string>", line 305, in alert
File "E:\Python\build\pyi.win32\TwoToneDetect49\outPYZ1.pyz/wave", line 500, i
n open
File "E:\Python\build\pyi.win32\TwoToneDetect49\outPYZ1.pyz/wave", line 303, i
n __init__
IOError: [Errno 2] No such file or directory: './audio/Extra_Member_/_Full_Scram
ble_2011-10-1915_06_52_828000.wav'
Exception AttributeError: "Wave_write instance has no attribute '_file'" in <bou
nd method Wave_write.__del__ of <wave.Wave_write instance at 0x01587288>> ignore
d


Thanks again,
Bill
Bill,

What are you using for the tone description for the tone that's giving you problems? The error you're seeing indicates that it can't open the .wav file to record the audio, and I'm wondering if it has to do with the name of the file, which is created from the tone description.

Andy
 

chad3405

Member
Joined
Nov 18, 2009
Messages
30
Location
Texas
human Error = Computers + me

Here is my error. Did some searching but didnt find any fixes that I understood.
Any ideas?


tone1
tone2
tone3
longtone1
A Tone Found!
Checking for B Tone
Checking for B Tone
553.0
1
Checking for B Tone
553.0
2
Checking for B Tone
553.0
3
Checking for B Tone
553.0
4
Tone Set Found!
Fire Department 1
EMAILS HERE

1
delay timer
waiting for audio
recording audio
0
done writing WAV
['00:00', '13:25', '00:00', '00:00']
['00:00', '13:35', '00:00', '00:00']
Unhandled exception in thread started by <function alert at 0x02C199F0>
Traceback (most recent call last):
File "<string>", line 332, in alert
File "E:\Python\build\pyi.win32\TwoToneDetect49\outPYZ1.pyz/subprocess", line
679, in __init__
File "E:\Python\build\pyi.win32\TwoToneDetect49\outPYZ1.pyz/subprocess", line
893, in _execute_child
WindowsError: [Error 2] The system cannot find the file specified
 

aaknitt

Member
Feed Provider
Joined
Aug 27, 2005
Messages
1,240
Here is my error. Did some searching but didnt find any fixes that I understood.
Any ideas?

Unhandled exception in thread started by <function alert at 0x02C199F0>
Traceback (most recent call last):
File "<string>", line 332, in alert
File "E:\Python\build\pyi.win32\TwoToneDetect49\outPYZ1.pyz/subprocess", line
679, in __init__
File "E:\Python\build\pyi.win32\TwoToneDetect49\outPYZ1.pyz/subprocess", line
893, in _execute_child
WindowsError: [Error 2] The system cannot find the file specified
It's not able to run ffmpeg to convert the WAV file to MP3 or AMR format. Make sure that ffmpeg.exe is in the same folder as the program. It could also be a problem with the naming of the WAV file, which is based on your tone description. Make sure you're not using any strange characters in the tone description that might cause file name issues.

Andy
 

wgriffin81

Newbie
Joined
Oct 15, 2011
Messages
3
Location
NJ
Bill,

What are you using for the tone description for the tone that's giving you problems? The error you're seeing indicates that it can't open the .wav file to record the audio, and I'm wondering if it has to do with the name of the file, which is created from the tone description.

Andy
Andy,

Toyed with the name of my tone2, originally had it as "Extra Member / Full Scramble;" Changed it to "Extra Member Full Scramble," all the test calls worked flawlessly. Looks like the special character was what was throwing it off, as I had no other changes.

Thanks for the quick suggestion,

Bill
 

chad3405

Member
Joined
Nov 18, 2009
Messages
30
Location
Texas
Ok I re did ffmpeg in stead of the latest version I went with the one in the link. Now I get a totally new error.
("note that the latest version and the linked version are not the same. the read me says get the latest or the link and they are not the same. dont know if it matters but it confused me.")

Just to make sure I am not missing anything, In my twotonedetect folder I have:
ffmpeg-git-a254452-win32-static.7z
audio
config.cfg
GNU3.txt
README
sampleconfig
sampletones
tones
twoToneDetect49.exe
twoToneDetect49.py

ERROR I get now.

recording audio
0
done writing WAV
['00:00', '13:25', '00:00', '00:00']
['00:00', '13:35', '00:00', '00:00']
Unhandled exception in thread started by <function alert at 0x02C799F0>
Traceback (most recent call last):
File "<string>", line 332, in alert
File "E:\Python\build\pyi.win32\TwoToneDetect49\outPYZ1.pyz/subprocess", line
679, in __init__
File "E:\Python\build\pyi.win32\TwoToneDetect49\outPYZ1.pyz/subprocess", line
893, in _execute_child
WindowsError: [Error 2] The system cannot find the file specified



Sorry if I am being a pain but this is all way over my head.
-Chad
 

sideman8

Newbie
Joined
Oct 26, 2011
Messages
2
Cant open twotonedetect.exe, downloaded 49 and unzip, when double clickin it all im getting is a black command prompt. any idea what im doing wrong? tried it on two of my xp pro machines.
 
Top