TwoToneDetect New TwoToneDetect in the works - Python based

Joined
Sep 27, 2011
Messages
2
Trying to run TwoToneDetect73L on a linux box with RTL_Airband. I have TwoToneDetect70 running with RTL_Airband on a raspberry pi without issue, for over 3 years. Just replaced a couple desktops, so I figured I would boot up a backup TwoToneDetect to stream calls to Zello, as I didn't want to strain the raspberry pi with anything further, and don't want to touch something that is not broke.

My Problem is that when I try to run LevelMeter or TwoToneDetect73L, it gives me the following error:

File "LevelMeter", line 1
SyntaxError: Non-UTF-8 code starting with '\x99' in file LevelMeter on line 2, but no encoding declared; see http://python.org/dev/peps/pep-0263/ for details

Tried starting from scratch, reinstalling packages, everything and keep running this issue. Also tried running Python2 and Python3. Obviously do not have access to the source code, so anyone else able to solve this problem?
 

aaknitt

Member
Feed Provider
Joined
Aug 27, 2005
Messages
1,254
What kind of Linux box are you trying to run on? The 73L binaries are for Windows and ARM architecture (Pi) and won't run on a normal desktop running Ubuntu.
 
Joined
Sep 27, 2011
Messages
2
Well that would explain it, I assumed a python app could run on anything with python. Was trying to run it on Ubuntu 20.04.
 

xawen

Member
Joined
Feb 20, 2020
Messages
19
Has anyone seen this error running on Raspberry Pi? I get this same error when running the TTD or LevelMeter executables.
Code:
./TwoToneDetect73l: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory
Running on Rasbian Buster and followed the Raspberry Pi guide on the twotonedetect.net site for install.
 
Last edited:

bmarchand

Newbie
Joined
Oct 20, 2014
Messages
6
Good afternoon,

I'm running into a problem with the latest version (73l) of TwoToneDetect recording the MP3 files. The audio playback is extremely slow, to the point that you can't even understand it. I have attached a sample from a recording this morning. I have tried this on 3 different PCs all with the same results. Even started with a clean config file and populated with my mail server settings, etc.

Any help would be greatly appreciated.
Brett
 

Attachments

aaknitt

Member
Feed Provider
Joined
Aug 27, 2005
Messages
1,254
Good afternoon,

I'm running into a problem with the latest version (73l) of TwoToneDetect recording the MP3 files. The audio playback is extremely slow, to the point that you can't even understand it. I have attached a sample from a recording this morning. I have tried this on 3 different PCs all with the same results. Even started with a clean config file and populated with my mail server settings, etc.

Any help would be greatly appreciated.
Brett
@bmarchand It sounds like this may be an issue with ffmpeg. Are you using the version of ffmpeg that came packaged with v73l? Is there any chance you had/have another version already installed on your system that it may be using instead?
 

bmarchand

Newbie
Joined
Oct 20, 2014
Messages
6
@bmarchand It sounds like this may be an issue with ffmpeg. Are you using the version of ffmpeg that came packaged with v73l? Is there any chance you had/have another version already installed on your system that it may be using instead?
Thank you, I'll take a look at that. This occurred on a machine that I had started from a clean install of Windows 10 and new folder taken directly from the TTD download (including recreating the config file from the one in the new folder). I'm wondering if something else running on the machine could be causing issues with the audio recording then.
 

aaknitt

Member
Feed Provider
Joined
Aug 27, 2005
Messages
1,254
Another thing you can do is manually edit the config.cfg file and add this line:

keep_wav = 1

That will prevent the WAV file from being deleted after conversion and will allow you to compare the WAV and MP3 files. I'm guessing the WAV will sound ok, which again points to an issue with FFMPEG.

Andy
 

bmarchand

Newbie
Joined
Oct 20, 2014
Messages
6
Another thing you can do is manually edit the config.cfg file and add this line:

keep_wav = 1

That will prevent the WAV file from being deleted after conversion and will allow you to compare the WAV and MP3 files. I'm guessing the WAV will sound ok, which again points to an issue with FFMPEG.

Andy
I have added that into the config and will monitor. Thank you again!
 

bmarchand

Newbie
Joined
Oct 20, 2014
Messages
6
I have added that into the config and will monitor. Thank you again!
Good morning,
I added the keep_wav = 1 setting and now have three wav files from over night. I checked them and they are also playing back with the distortion as well.

Additionally I disabled the Windows virus scanning too.

Brett
 
Top