No Audio when RDP into RPI 3b+

jmurray1919

Member
Premium Subscriber
Joined
Aug 5, 2020
Messages
7
I'm experimenting with trying to RDP into a RPI 3B+ running GQRX. I can remote into the RPI and launch GQRX but I have no audio. There is no display attached to the RPI...Its in my garage, stand alone. I have it connected via eathernet to a tp-link powerline range extender.
The audio output in GQRX is set to default.
Is there a setting somewhere in setup to allow the RPI to communicate audio out?
I also ran a you tube video via RDP with no audio present.
 

lwvmobile

Member
Joined
Apr 26, 2020
Messages
165
Location
Lafayette County, FL
I'm pretty sure VNC services don't typically include any sort of audio connection to the clients connecting to it. If you are just going to stream audio out of GQRX, you can use the UDP audio stream option in GQRX to push the audio out onto your network and use something like VLC on your client to listen.


Code:
$ vlc --demux=rawaud --rawaud-channels=1 --rawaud-samplerate=48000 udp://@:7355
You probably have to replace the @ sign with the IP address of your 3B+. You may also have to put the IP address of the 3B+ in the UDP settings in GQRX instead of using 'localhost' so it will know to listen to that address binding for incoming request. Hope that helps.
 

boatbod

Member
Joined
Mar 3, 2007
Messages
2,574
Location
Talbot Co, MD
I'm experimenting with trying to RDP into a RPI 3B+ running GQRX. I can remote into the RPI and launch GQRX but I have no audio. There is no display attached to the RPI...Its in my garage, stand alone. I have it connected via eathernet to a tp-link powerline range extender.
The audio output in GQRX is set to default.
Is there a setting somewhere in setup to allow the RPI to communicate audio out?
I also ran a you tube video via RDP with no audio present.
GQRX requires PulseAudio for sound output and PA has the capability to play across a network, assuming you have a compatible client somewhere. How to carry audio over SSH?

RDP also supports network audio but there may be things you have to do to get it to behave.
 

jmurray1919

Member
Premium Subscriber
Joined
Aug 5, 2020
Messages
7
Is there a simple(ish) way to Remote control a RTL_SDR V3 on a RPI 3b+? Maybe not using remote desktop or GQRX & the needed workarounds listed above? I just want to use it to scan anything & everything but P25 systems... my pc is running DSD+ and another RTL-SDR to do that.
I'm a bit lost with the above command lines, where they are located, what programs to use. So if I can accomplish listening to & tuning the remote SDR from my PC, that would be outstanding.
I'm super new and need detailed instructions when giving tips, until I've grasped a bit more.
Thanks
 
Last edited:

lwvmobile

Member
Joined
Apr 26, 2020
Messages
165
Location
Lafayette County, FL
Well, I did a little thinking and considered how you had things set up. Simple is pretty subjective so it varies widely from person to person, but to be honest I wouldn't consider anything SDR related to be 'simple' by any means as it usually requires some level of configuration, research, trial and error, etc. But all considered, the way you are currently set up and already have GQRX going, I think my solution might be the easiest, but just for GQRX.

On your Pi, open GQRX, on the bottom right corner, you'll find some buttons, one is UDP, and on the far right you'll see ... three dots. Click that one.

gqrx-settings.png

Then, you'll see settings for target UDP host and port. Set the Host to the IP address of the TARGET receiver, the IP address of the computer you want to listen with. Not the IP address of the Raspberry Pi. (I was mistaken in my earlier post) So, change it from 'localhost' to the IP address of the receiving computer. Sadly, I tried to set it to 192.168.7.0 and 192.168.7.255 to see if it would broadcast to all, but it just crashes GQRX, so don't do that :ROFLMAO:

gqrx-settings-2.png

Finally, on your computer in the house, just run the command

Code:
vlc --demux=rawaud --rawaud-channels=1 --rawaud-samplerate=48000 udp://@:7355
Then you should hear the audio you're listening to on GQRX play through VLC on your computer if all is set up correctly. I tested this in my home with two linux computers and it works well. Hopefully it should work the same on Windows but you'll need to install VLC if you don't have it, and hope Windows firewall doesn't block the GQRX UDP stream or something. Hope that helps.
 
Last edited:

dan-dekalb

Newbie
Feed Provider
Joined
Mar 22, 2010
Messages
18
Location
DeKalb, IL
I have successfully gotten audio over RDP working. You have to build the pulseaudio modules and then change the library file location. I’ll try to dig out the steps I went through when I get back to my desktop.
 

dan-dekalb

Newbie
Feed Provider
Joined
Mar 22, 2010
Messages
18
Location
DeKalb, IL
Looking at my command history,
sudo nano /etc/apt/sources.list
Uncomment the deb-source line
sudo apt-get update
sudo apt install xrdp-pulseaudio-installer
sudo apt install build-essential dpkg-dev libpulse-dev
sudo apt build-dep pulseaudio
sudo apt-get install pulseaudio
apt source pulseaudio
cd pulseaudio-12.2/
./configure
cd ~
git clone h t t p s ://github.com/neutrinolabs/pulseaudio-module-xrdp
Take the spaces out of h t t p s. Comment system kept making it into a hyper-link.
cd pulseaudio-module-xrdp/
./bootstrap && ./configure PULSE_DIR=/home/pi/pulseaudio-12.2/
make
sudo make install
sudo nano /etc/xrdp/pule/default.pa
You need to change the references to xrdp to point to the new library files just installed from the make install. It should look something like this:

.ifexists /usr/lib/pulse-12.2/modules/module-xrdp-sink.so
load-module /usr/lib/pulse-12.2/modules/module-xrdp-sink.so
.endif
.ifexists /usr/lib/pulse-12.2/modules/module-xrdp-source.so
load-module /usr/lib/pulse-12.2/modules/module-xrdp-source.so
.endif


Reboot and you should have audio over RDP. Let me know if you have errors, this was just reconstructed from my bash history, so I may have missed something.

Dan
 

a417

!#
Joined
Mar 14, 2004
Messages
1,938
sudo nano /etc/apt/sources.list
Uncomment the deb-source line
Inline code (under insert (the dots to the right of the smiley in the editor bar) does this)

and

Code (as in code block, under insert does this)
Code:
sudo apt-get update
sudo apt install xrdp-pulseaudio-installer
sudo apt install build-essential dpkg-dev libpulse-dev
sudo apt build-dep pulseaudio
sudo apt-get install pulseaudio
apt source pulseaudio
cd pulseaudio-12.2/
./configure
cd ~
git clone https://github.com/neutrinolabs/pulseaudio-module-xrdp
    Take the spaces out of h t t p s.  Comment system kept making it into a hyper-link.
cd pulseaudio-module-xrdp/
./bootstrap && ./configure PULSE_DIR=/home/pi/pulseaudio-12.2/
<snip>
.endif
this should help you not lose your mind when you're helping people and it involves command line entries or blocks of code.
 
Joined
Jan 13, 2021
Messages
3
Hi,
I managed to get this to work, thank you so much.
But I still have a problem:
A Youtube video in Firefox plays audio just fine.
But I also have JDownloader installed using OpenJRE-11 and this bad guy does not play the notification sounds. It works fine over HDMI when I connect a monitor, but not via xRDP.
BTW: It's a Pi4-8GB and the system is default RaspiOS.
Any help is much appreciated, many thanks in advance.
 

DC31

Member
Feed Provider
Joined
Feb 19, 2011
Messages
1,294
Location
Massachusetts
You could also try PiScan. ezratl/PiScan

much simpler than gqrx

from its github page: To listen to PiScan's audio feed remotely, use a stream client that supports RTSP, such as VLC, and enter the MRL rtsp://<host_address>:8554/audio. Setting a low network caching time is advised to reduce audio latency.

search this sdr forum for another thread regarding piscan for some tweaks needed to get it running.
 

lwvmobile

Member
Joined
Apr 26, 2020
Messages
165
Location
Lafayette County, FL
The only thing is it seems not to redirect ALL audio. Or is some setting or anything wrong for Java or am I using the wrong JRE?
If you haven't already, you can install pavucontrol, the Pulse Audio Volume Control panel, which can let you select which hardware device an individual audio stream comes out of. Not sure if it will work in conjunction with xRDP, but its worth a look at.

Code:
sudo apt install pavucontrol
pav.png
 
Joined
Jan 13, 2021
Messages
3
I have already tried pavucontrol, but in an xrdp session the System sounds are not present. JDownloader or Java are never visible there.
 

lwvmobile

Member
Joined
Apr 26, 2020
Messages
165
Location
Lafayette County, FL
I have already tried pavucontrol, but in an xrdp session the System sounds are not present. JDownloader or Java are never visible there.
I have a feeling it might be one of those things where the audio stream only shows up there the moment its actually playing audio, and then quickly drops off when the audio is finished playing. I downloaded and installed JDownloader2 and looked through all the settings, sadly I didn't see anything where you can specify an audio device or even change the notification sound or test notifications. Perhaps you can make a feature request or seek help on their board, perhaps there is a method to get audio from it over xRDP via command line or something.

 
Top