No decoded audio with DSD+

Status
Not open for further replies.

w4rtt

Member
Joined
May 7, 2010
Messages
174
Location
Independence, KY
I have DSD+ setup and running with all the data flowing down the screen, but there is no decoded audio. Yes, I have the correct sound card selected. All I get is the digi sound from the speaker.
 

mmisk

Member
Joined
Jul 4, 2003
Messages
673
Location
Ottawa Canada
Hi there,

What are you decoding? P25, DMR, NXDN? etc

Try this: adjust the audio level to DSD is a low as possible.

Mike
 

w4rtt

Member
Joined
May 7, 2010
Messages
174
Location
Independence, KY
Trying to decode TRBO and P25.
All I get is the constant hiss from the discriminator and digi noise when present.
 
Joined
Apr 20, 2014
Messages
33
Location
Laguna Beach, CA
hey I don't know about in linux, but in windows you have to have the audio piped out from SDRSharp into your Virtual Audio Cable or VB Audio Cable input. you can go into the windows sound Recording control panel and select "listen to this audio" and point it to your headphones output from there. But the audio signal still gets piped out to the virtual audio cable device.

Then, when you run DSD+, you have to use the command switches to tell it to listen in on the Virtual Audio Cable input device. If you just run DSD.exe once, it should list the devices. So, to input on device #2 you would command "dsd -i2" and to then output to headphones etc on device #3 you would say, "dsd -i2 -o3" now add the P25 decode command and it becomes "dsd -i2 -o3 -f1"

now tune to your P25 freq in SDRSharp or use the Unitrunker setup to get tuned.
make sure your channel width is set to 12,500 or spread the width using the GUI to encompass the whole 'signal width' displayed in the GUI
 
Joined
Apr 20, 2014
Messages
33
Location
Laguna Beach, CA
Ok, so that pyshically outputs to a wire that you have going to your sound card's input, right?

now install Virtual Audio Cable or VBcable, and configure that audio from your soundcard input to pipe into the Virtual Audio cable input device

then set DSD to listen on the Virtual Audio cable input device
 

mm

Member
Joined
Dec 19, 2002
Messages
656
check and try switching the channel balance in your sound card/audio mixer input to either the right or left channel. If you are feeding into a stereo input, and you most likely are, and if the balanced is set to center then the digital noise will be predominant on your audio output.

I had the same problem with my discriminator setup on a bc895 and this was my fix.
 
Joined
Apr 20, 2014
Messages
33
Location
Laguna Beach, CA
do you have any shots of your tuner? or is it all hardware?
Ive never decoded DMR, but by the looks you are very close. it looks like it is recognizing the DMR packets they just have a bad signal or error rate.

i would make sure :
-you are tuned correctly, with 12,500 width spacing
-your windows playback and recording devices are set to 2 channel, 16 bit, 48000

as far as the P25 decoding, you are clearly not getting a good signal to DSD. This could be because of tuning, or Audio piping, or if those are correct then you are not piping at 48000 thru and thru
make sure you are using the correct dsd switch, type "DSD -f1" to decode P25 only, or type "DSD -fa" to decode all codecs P25 DRM etc

-and, have you tried installing VB-audio cable, the virtual audio device? its easy, works and might be just what you need (proper audio in/out piping from tuner to DSD)
 
Last edited:
Joined
Apr 20, 2014
Messages
33
Location
Laguna Beach, CA
If you open the Control Panel -> Sound -> recording devices does the UA-1EX should sound output in the little green equalizer? you mentioned you heard digital transmissions so I assume this is getting and showing input....
 

w4rtt

Member
Joined
May 7, 2010
Messages
174
Location
Independence, KY
All hardware set up. R8500 disc out to sound card.

I can turn "monitor input on/off" on the device.
I have it set to off now.

Set to 48000
 

w4rtt

Member
Joined
May 7, 2010
Messages
174
Location
Independence, KY
If you open the Control Panel -> Sound -> recording devices does the UA-1EX should sound output in the little green equalizer? you mentioned you heard digital transmissions so I assume this is getting and showing input....
I don't see this in the control panel settings.
 
Status
Not open for further replies.
Top