• To anyone looking to acquire commercial radio programming software:

    Please do not make requests for copies of radio programming software which is sold (or was sold) by the manufacturer for any monetary value. All requests will be deleted and a forum infraction issued. Making a request such as this is attempting to engage in software piracy and this forum cannot be involved or associated with this activity. The same goes for any private transaction via Private Message. Even if you attempt to engage in this activity in PM's we will still enforce the forum rules. Your PM's are not private and the administration has the right to read them if there's a hint to criminal activity.

    If you are having trouble legally obtaining software please state so. We do not want any hurt feelings when your vague post is mistaken for a free request. It is YOUR responsibility to properly word your request.

    To obtain Motorola software see the Sticky in the Motorola forum.

    The various other vendors often permit their dealers to sell the software online (i.e., Kenwood). Please use Google or some other search engine to find a dealer that sells the software. Typically each series or individual radio requires its own software package. Often the Kenwood software is less than $100 so don't be a cheapskate; just purchase it.

    For M/A Com/Harris/GE, etc: there are two software packages that program all current and past radios. One package is for conventional programming and the other for trunked programming. The trunked package is in upwards of $2,500. The conventional package is more reasonable though is still several hundred dollars. The benefit is you do not need multiple versions for each radio (unlike Motorola).

    This is a large and very visible forum. We cannot jeopardize the ability to provide the RadioReference services by allowing this activity to occur. Please respect this.

Not another UV5R thread...

Status
Not open for further replies.

ORpac

Member
Joined
Jul 25, 2017
Messages
6
So I've had a couple of these radios for the past few years. Programming them with CHIRP 0.4.1. I purchased them separately a year or so apart but they both have firmware BFB297. Recently noticed a programming issue that I'm not sure if it's new or I'm just now noticing it.

I'm trying to use the TDR function on menu #34 to Tx on channel A only. This works flawlessly on one radio but when this function is set the other radio I can switch between A/B and Tx on both. The same happens if I try to set to Tx on B only. Also noticed that on the problem radio the menu number is always blinking whereas on the properly functioning radio is not.

I tried a full reset with re-program of the exact file that I used on the functioning radio and didn't work.

Is this a faulty radio or am I programming something wrong?

Thanks in advance.
 

jonwienke

More Info Coming Soon!
Premium Subscriber
Joined
Jul 18, 2014
Messages
12,992
Location
VA
Different firmware versions handle dual-watch differently. There are 2 numbers in the firmware version. If either one is different the firmware version is not the same.
 

nd5y

Member
Joined
Dec 19, 2002
Messages
9,312
Location
Wichita Falls, TX
BFB297 is probably not the real firmware version. You need Chirp to view the real firmware version. See UV5R F8HP UV82 FAQ - Miklor

0.4.1 is an old version of Chirp. Newer versions usually won't allow you to load an image into a radio with different firmware. I would suggest using the latest version. Download - CHIRP

Mixing image files between radios with different firmware versions can cause problems. See UV5R F8HP Recovery Baofeng Pofung UV5R
 

ORpac

Member
Joined
Jul 25, 2017
Messages
6
I do realize I'm using an older version. Shows how long I've had these. There are constantly new versions but I haven't needed to re-program the radios since the initial. All other functions work fine.

And I know the issue with image loading, learned it the hard way when I had no Rx. Correct me but I always 'download from radio' and save that file. Then copy and past the channel program into the new radio. I do not just upload the image directly from one radio to the other. If this is wrong please correct me. Maybe based on the firmware versions below is still managed to botch this...


From chirp firmware versions:

Properly functioning radio-
FM 1: BFS311
FM 2: BFB297

Malfunctioning radio-
FM 1: N5R247
FM 2: BFB297

Thanks again for the help
 

ORpac

Member
Joined
Jul 25, 2017
Messages
6
Has anyone else run into this issue, is it a firmware flaw?

Anyone else notice their menu number blinks instead of staying solid? Again not sure if this is a firmware change...
 

nd5y

Member
Joined
Dec 19, 2002
Messages
9,312
Location
Wichita Falls, TX
I have a UV-5R and UV-82 and the only thing that blinks is the arrow icon next to the recive channel when the squelch is open. In the menu mode nothing blinks except during tone/DCS search mode.

Did this radio always behave this way or did it suddenly start blinking after being programmed with an image file from the other radio?
 

ORpac

Member
Joined
Jul 25, 2017
Messages
6
I have a UV-5R and UV-82 and the only thing that blinks is the arrow icon next to the recive channel when the squelch is open. In the menu mode nothing blinks except during tone/DCS search mode.

Did this radio always behave this way or did it suddenly start blinking after being programmed with an image file from the other radio?
Honestly I'm not sure. I never paid much attention because all other functions of the radio work fine. None of the typical firmware Image issues as I've run into in the past (programming radios for friends/family).
 

CCRS53

Member
Joined
Jan 13, 2016
Messages
15
Location
Lineville, AL
So three questions: 1. Have you downloaded the latest build of chirp and tried reprogramming? 2. Have you tried redownloading an image file from your radio and editing it directly, then re-uploading it to your radio? 3. Have you tried changing this setting in the settings menu in chirp instead of on your radio? Hopefully one of these three will solve your problem, Interested to hear back. Also just noticed where you posted the firmware message readouts, and you have two different firmwares flashed to your radios. -Makale
 
Last edited:

ORpac

Member
Joined
Jul 25, 2017
Messages
6
So three questions: 1. Have you downloaded the latest build of chirp and tried reprogramming? 2. Have you tried redownloading an image file from your radio and editing it directly, then re-uploading it to your radio? 3. Have you tried changing this setting in the settings menu in chirp instead of on your radio? Hopefully one of these three will solve your problem, Interested to hear back. Also just noticed where you posted the firmware message readouts, and you have two different firmwares flashed to your radios. -Makale
1: yes I did, no dice
2: Are you talking a new image file or the original?
3: I did try changing in the advanced settings placing dual watch on and Tx priority to channel A and I can still broadcast on B.

I also reprogrammed from my original image file which interestingly had N5R-20 as the firmware message 1 and BFB297 in firmware message 2. Afterwards when I pulled the program back off the radio FM 1 was changed back to N5R2407, FM 2 remained BFB297.
 

CCRS53

Member
Joined
Jan 13, 2016
Messages
15
Location
Lineville, AL
I was meaning a new image file from the radio, in case something went screwy with the original you have. I've never heard of one messing up, but with computers, anything's possible... and also very strange, I've never heard of a radio changing the firmware numbers before. I've programmed dozens of these for work and different agencies and never had that happen before.
 

ORpac

Member
Joined
Jul 25, 2017
Messages
6
Quick update for this. Just bought 2 more UV5Rs off Amazon. Straight out of the box I tested the TDR function before any programming was done (hadn't even plugged them into the computer yet) and it did not work on either. Regardless of the preference I chose in the menu the radio will Tx on A and B. When I return to the menu it keeps the preference set but doesn't effect the radios Tx.

Also, once again the menu #'s are blinking. Of the 4 UV5Rs I have the only one which the TDR function works properly the menu # is solid and does not blink.
 
Status
Not open for further replies.
Top