OP25 on RTL-SDR: LNA Gain Setting Issues

Status
Not open for further replies.

jslezak

Member
Premium Subscriber
Joined
Dec 13, 2019
Messages
5
Hey,

Thanks to boatbod's setup, OP25 is running nicely on an old laptop I had running Ubuntu 18.04. The only weird issue is that it seems like the SDR's noise floor's do not change significantly when messing with the -N 'LNA:xx' setting in OP25. The noise floor from what I have seen in GNU radio and SDR# should be much higher given that gain setting.

I can't seem to find the signal I am looking for in OP25, which I can find in other SDR software using the same hardware/config, since it appears the gain settings aren't changing on the SDR?

Attached are two examples of LNA set to 27 and 47.

Thanks for any insight,
Joe
 

Attachments

wgbecks

Member
Joined
Jan 17, 2005
Messages
280
Location
Porterfield, Wisconsin
Can you post your rx.py command line? My first impression is that the SDR is way off frequency from where you are expecting to see the
desired signal in the FFT plot screen. Did you try running rx.py with the (-X) option? This might help if significantly off frequency. Also
remove any (-o xxxx) offset parameters before trying the (-X) option.
 

jslezak

Member
Premium Subscriber
Joined
Dec 13, 2019
Messages
5
Can you post your rx.py command line? My first impression is that the SDR is way off frequency from where you are expecting to see the
desired signal in the FFT plot screen. Did you try running rx.py with the (-X) option? This might help if significantly off frequency. Also
remove any (-o xxxx) offset parameters before trying the (-X) option.
Unfortunately not at that computer at the moment, the command is in the attached images at the top. I dont have an offset since its spot on when I test a simple rtl_fm command on the same frequency.

I'll give the -X argument when I get back to it. What does that do?
 

boatbod

Member
Joined
Mar 3, 2007
Messages
2,582
Location
Talbot Co, MD
I ran gqrx against one of my rtl dongles and played with the gain, but the noise floor stayed pretty much constant at approx -84db the whole time. The signal peak varied as expected, so it's quite probable that you are simply tuned to the wrong frequency.
 

wgbecks

Member
Joined
Jan 17, 2005
Messages
280
Location
Porterfield, Wisconsin
The (-X) option in @boatbod (s) version will upon startup try to automatically adjust tuning in an effort to obtain sync with the control channel and can make the task of getting op25 up and running the first time much easier. However, it doesn't have limitless capabilities to wonder all over the band looking for a signal. So your mileage may vary.
 

wgbecks

Member
Joined
Jan 17, 2005
Messages
280
Location
Porterfield, Wisconsin
You have to keep in mind that each software application like op25, gqrx, or sdr# have their own implementation as to how you adjust or compensate the SDR to get it set on frequency. Incorrect (-q x), (-d xxx) or (-o xxxx) can prevent the SDR from syncing up on the system or to entirely miss a signal of interest if the error is large enough its not visible in the available FFT (spectrum).
 

boatbod

Member
Joined
Mar 3, 2007
Messages
2,582
Location
Talbot Co, MD
The (-X) option in @boatbod (s) version will upon startup try to automatically adjust tuning in an effort to obtain sync with the control channel and can make the task of getting op25 up and running the first time much easier. However, it doesn't have limitless capabilities to wonder all over the band looking for a signal. So your mileage may vary.
Correct. There has to be *some* signal within the mixer filter bandwidth in order for -X to be able to pick it up. In the OP's case I didn't see any evidence of a signal at all.
 

jslezak

Member
Premium Subscriber
Joined
Dec 13, 2019
Messages
5
Thanks for all the helpful info and quick replies. Glad to know the LNA setting doesn't change the noise floor much, as I figured my issues were simply the gain wasn't being applied.

I'm going to try to increase the signal as well as trying other phase I control channels that are in my area and will post back with how that goes.
 

jslezak

Member
Premium Subscriber
Joined
Dec 13, 2019
Messages
5
Alright, so it appears my tuner is in fact tuning to the right frequency. I used NOAA weather radio that is dead on 162.400mhz and it is spot on. See screenshot attached. Command was $ ./rx.py --args 'rtl' -N 'LNA:47' -S 240000 -f 162.400e6



Guess the next step is to find a better antenna for higher frequencies 700 - 900mhz and move it to a better location?
 

Attachments

Status
Not open for further replies.
Top