OP25 Robotic Audio (an observation)

WX4JCW

Member
Premium Subscriber
Joined
Jun 26, 2006
Messages
2,591
Location
All Over USA
Most of the threads are closed so I apologize in advance but I needed to chime in

I set up a PI 4 with OP25 and hooked it up to the TV in my hotel room and had perfect audio decode, when I decided to install GQRX that's when the problems began, I got really slow robotic audio, so I formatted the card again and reinstalled, the audio came back fine, is there anyway to install GQRX without having this issue?
 

boatbod

Member
Joined
Mar 3, 2007
Messages
2,401
Location
Talbot Co, MD
Most of the threads are closed so I apologize in advance but I needed to chime in

I set up a PI 4 with OP25 and hooked it up to the TV in my hotel room and had perfect audio decode, when I decided to install GQRX that's when the problems began, I got really slow robotic audio, so I formatted the card again and reinstalled, the audio came back fine, is there anyway to install GQRX without having this issue?
When you install gqrx it forces you to have Pulse Audio. Try changing op25 so that it natively uses the "pulse" interface rather than alsa.
If you're running rx.py use "-O pulse" on the command line and see what happens.

If you're running multi_rx.py, try setting the audio device_name to "pulse" as follows:
Code:
    "audio": {
        "module": "sockaudio.py",
        "instances": [
            {
                "instance_name": "audio0",
                "device_name": "pulse",
                "udp_port": 23456,
                "audio_gain": 1.0,
                "number_channels": 1
            }
        ]
    },
 
Top