P25RX-II Firmware Updates / Testing

pcman67

Radio and electronics enthusiast since the ‘70’s
Premium Subscriber
Joined
Feb 28, 2021
Messages
89
Location
Chicagoland
@btt 2021-11-21_1328 sometimes suddently shows P25P1 CC BLKS_PER_SEC of 0 after showing it in the low to mid 50's and then after a short while will go back to the low to mid 50's. It seems like I'm still able to receive audio when the blocks per second is showing 0. Wanted to bring up this bug in this version.
 
  • Like
Reactions: btt

btt

Active Member
Premium Subscriber
Joined
Mar 11, 2020
Messages
1,260
Location
Wa State
@btt 2021-11-21_1328 sometimes suddently shows P25P1 CC BLKS_PER_SEC of 0 after showing it in the low to mid 50's and then after a short while will go back to the low to mid 50's. It seems like I'm still able to receive audio when the blocks per second is showing 0. Wanted to bring up this bug in this version.
I haven't seen it do that yet, but I will look into what might be causing it. Thanks for letting me know that it probably is a display issue only. Does the status led on the receiver stay green during this period when it is showing 0 BLKS/SEC?
 

pcman67

Radio and electronics enthusiast since the ‘70’s
Premium Subscriber
Joined
Feb 28, 2021
Messages
89
Location
Chicagoland
I haven't seen it do that yet, but I will look into what might be causing it. Thanks for letting me know that it probably is a display issue only. Does the status led on the receiver stay green during this period when it is showing 0 BLKS/SEC?
Yes, the status LED remains green when this happens. The RF Sig Level will be reading good when this happens (I average around -90dBm).
It just seems to happen randomly -- it might take 5 minutes for it to happen and then it'll do it again 30 seconds later and then not do it again for another 10 minutes. It will only remain showing 0 BLKS/SEC for usually only a few seconds -- maybe 5 seconds at most before going back to normal (52-54 BLKS/SEC)
 

btt

Active Member
Premium Subscriber
Joined
Mar 11, 2020
Messages
1,260
Location
Wa State
Yes, the status LED remains green when this happens. The RF Sig Level will be reading good when this happens (I average around -90dBm).
It just seems to happen randomly -- it might take 5 minutes for it to happen and then it'll do it again 30 seconds later and then not do it again for another 10 minutes. It will only remain showing 0 BLKS/SEC for usually only a few seconds -- maybe 5 seconds at most before going back to normal (52-54 BLKS/SEC)
I can't reproduce this here, but I think this could be fixed in the latest version 11-22_1651.
 

shirsch101

Member
Premium Subscriber
Joined
Jan 29, 2012
Messages
195
Location
West Chester, PA
Todd,
Version 11-23 17:58 is performing "Great" for me, actually the best that either of my P25-RX or P25RX-II units have ever performed. Great audio and great reception without any adjustments and the display is awesome!!!
Keep up your hard work I really appreciate it. Have a Happy Thanksgiving, you have earned it

Steve
 
  • Like
Reactions: btt

btt

Active Member
Premium Subscriber
Joined
Mar 11, 2020
Messages
1,260
Location
Wa State
Todd,
Version 11-23 17:58 is performing "Great" for me, actually the best that either of my P25-RX or P25RX-II units have ever performed. Great audio and great reception without any adjustments and the display is awesome!!!
Keep up your hard work I really appreciate it. Have a Happy Thanksgiving, you have earned it

Steve
Thank you for the feedback Steve. I really appreciate it. I'm still trying to dial in performance that works for everyone. You are the first to give feedback on this version. Maybe this version will be the one that works for those with issues? I hope so. You have a great Thanksgiving holiday as well my friend!
 

freqseeker

Member
Premium Subscriber
Joined
Jun 18, 2003
Messages
258
Location
Puget Sound WA.
Todd,
I observed another improvement in your recent rewrite of the decoding software. This is on the WSP 700 P2 system. Before the rewrite it would take up to ten minutes to collect all the system info from a cold start (though not always). The NAC was always last, thus audio would not be decoded. Now not only did the BLKS double, the system info loads almost instantly.
Happy Thanksgiving all.
 
  • Like
Reactions: btt

dcr_inc

Feed Provider *York Pa.*
Premium Subscriber
Joined
Feb 28, 2005
Messages
728
Location
Delta, Pa
Todd.. The 20211124 firmware just woke my Model II up.. DON'T make any changes to the receive or decode !!.. This is the first day I have had 100% copy for hours on end.. I was about to sell the model II and go back to the model I.. I actually have stars in all 4 quadrants now on Phase I and II..
KUDOS
 
  • Like
Reactions: btt

btt

Active Member
Premium Subscriber
Joined
Mar 11, 2020
Messages
1,260
Location
Wa State
Todd.. The 20211124 firmware just woke my Model II up.. DON'T make any changes to the receive or decode !!.. This is the first day I have had 100% copy for hours on end.. I was about to sell the model II and go back to the model I.. I actually have stars in all 4 quadrants now on Phase I and II..
KUDOS
11-24_2226 version correct? Thanks for the update!
 

dcr_inc

Feed Provider *York Pa.*
Premium Subscriber
Joined
Feb 28, 2005
Messages
728
Location
Delta, Pa
Todd,
With this Firmware version(11-24_2226), I can decode Phase I down to -120.. Thats just above the noise floor.. KUDOS
 
  • Like
Reactions: btt

pcman67

Radio and electronics enthusiast since the ‘70’s
Premium Subscriber
Joined
Feb 28, 2021
Messages
89
Location
Chicagoland
@btt, Sorry, been out of town and unable to test the last couple of days worth of test versions for the P25RX-II.

I have been evaluating 2021-11-24_2226 and everything IS AWESOME!!!! I know I say that most of your releases are good, but this one is NEXT LEVEL goodness to my ears! I am not sure what all you have done over the past 3 days or so since I last was testing the ALT TESTING version, but whatever you did, you hit a grand slam!

By the way, HAPPY THANKSGIVING!
 
  • Like
Reactions: btt

btt

Active Member
Premium Subscriber
Joined
Mar 11, 2020
Messages
1,260
Location
Wa State
Thank you for the feedback. I'm really glad to hear that it is working well for everyone so far. Happy Thanksgiving!
 

r60

Member
Premium Subscriber
Joined
Dec 22, 2005
Messages
1,109
Location
Location 1
@btt I have about 24 hours on 2021-11-24_2226. I like it too! Thanks Todd.

Anyone care to opine why signal meter bounces around (all green) though -80db. On external antenna with short run low loss cable. Surprised it is not pegged.

I am only 3 miles line of site from 700MHZ site
 

station09

Member
Feed Provider
Joined
Aug 9, 2008
Messages
75
Question , is version 2021-11-16-2326 the most recent for the P25RX ? Most recent for the P25RX-2 is the 2021-11-24-2226 ? Thank You
 

Vermonster

Member
Joined
Oct 5, 2010
Messages
98
Location
Second College Grant, NH
Hat tip to @btt. I've been running 2226 for the last 12 hours on a Boston area Con+ system that I have used for testing this fall. This is clearly the best firmware yet for voice decodes; it matches or exceeds the performance I get from my RTL dongle DSD+FL setup. Huge thanks.
Two notes:
-In order to optimize reception, I still need to manually set LNA gain (22-24 dB); auto with defaults gets about 80% of the calls (note: fringe reception area; typically -108 dBm and EVM% 7%-10%)
-I thought previous firmware versions showed sync state as "synced" (green) on the Signal Insights tab, but this version shows continual no-sync/red (despite console log showing DATA_SYNC and excellent reception as noted above.

When buses and transportation companies fire up on Monday morning I'll test a second Con+ system with a more convoluted band plan.
 
  • Like
Reactions: btt
Top