Possible bug in new HP-1 update

Status
Not open for further replies.

W4KRR

Member
Premium Subscriber
Joined
Apr 1, 2001
Messages
3,266
Location
Coconut Creek, FL
Noticed a possible bug after doing the latest HP-1 firmware update:

When holding on a system (top most display line), HP won't stop on any active talkgroup while in hold mode. After removing the hold (yellow off), it works normally.

Also, the previously mentioned bug that the User ID mode 2 returns to "OFF" after power is cycled.
 

SDavis90

Member
Joined
Jul 21, 2006
Messages
213
Location
Middle Tennessee
Noticed a possible bug after doing the latest HP-1 firmware update:

When holding on a system (top most display line), HP won't stop on any active talkgroup while in hold mode. After removing the hold (yellow off), it works normally.

Also, the previously mentioned bug that the User ID mode 2 returns to "OFF" after power is cycled.
Mine is working fine while holding on a system. However, I do have the ID issue.
 

OCO

Member
Joined
Jul 17, 2011
Messages
929
Location
Central Michigan
Noticed a possible bug after doing the latest HP-1 firmware update:

When holding on a system (top most display line), HP won't stop on any active talkgroup while in hold mode. After removing the hold (yellow off), it works normally.

Also, the previously mentioned bug that the User ID mode 2 returns to "OFF" after power is cycled.
Ken:
I just checked three TRS's in my area, placing the HP1 in System (top line) hold. In all three cases, the HP1 continued to scan and stop properly on Channel (TG) activity. This is with current 2.02 (Extreme) firmware .
I agree on the User ID Mode 2 issue as reported.
 

W4KRR

Member
Premium Subscriber
Joined
Apr 1, 2001
Messages
3,266
Location
Coconut Creek, FL
Ken:
I just checked three TRS's in my area, placing the HP1 in System (top line) hold. In all three cases, the HP1 continued to scan and stop properly on Channel (TG) activity. This is with current 2.02 (Extreme) firmware .
I agree on the User ID Mode 2 issue as reported.
I may have jumped the gun on that. The System Hold seems to be working fine now.

However the User ID Mode 2 issue is still there; using Mode 1 seems to work normally, as reported by others.
 

KWs

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
638
Location
Kent , Ohio
A " Write to HP-1 " function from Sentinel will also cause the UID Mode 2 to revert to off.
 

OCO

Member
Joined
Jul 17, 2011
Messages
929
Location
Central Michigan
A " Write to HP-1 " function from Sentinel will also cause the UID Mode 2 to revert to off.
A "write to HP1" will leave the UID mode set to whatever is in the Profile (check Profile editor, Miscellaneous tab), Default is "off", but if set to mode 1 or mode 2, that's what it will be after the write process. But, power cycle of the HP1 will still revert it to "off" as reported.
 

SDavis90

Member
Joined
Jul 21, 2006
Messages
213
Location
Middle Tennessee
Same issue...

Noticed a possible bug after doing the latest HP-1 firmware update:

When holding on a system (top most display line), HP won't stop on any active talkgroup while in hold mode. After removing the hold (yellow off), it works normally.

Also, the previously mentioned bug that the User ID mode 2 returns to "OFF" after power is cycled.
Mine actually did this last night. Was holding and listening, on a system, (Mot Type II, analog) for about 4 hrs or so....some time along the way it got quiet. Thinking it was just a slow night, I didn't think much of it, until I was swapping out the batteries on my 396XT, and turned it on to check the fresh batteries. While doing this, I was hearing traffic on the same system through my 396XT, but the HP-1 was silent. I actually stared in disbelief for a second, looking back and forth between radios....I'm sure it looked comical.

I tapped the top line at this point...releasing the hold and as it scanned through my list and hit the system (as it returned in the scan) then it started working fine.

I will point out too, that I heard the morse code identifier beeping for the radio system sometime during the quiet phase...I thought that was odd but shrugged it off.

In my limited knowledge on how this thing operates...it almost sounds as if it missed the control channel moving to the other frequency. This particular system control channel changes in the evenings routinely.

I have posted this possible bug to the Uniden website also.
 

adamr368

Member
Joined
Sep 15, 2003
Messages
161
Location
Medford Lakes, NJ
Perhaps another bug identified...

There may be another bug with the new firmware. Create a favorites list and add 2 systems (at least 1 of them a trunked system), then add a group on one of the systems with all but 1 of the talkgroups avoided. While scanning, avoid the 1 unavoided talkgroup and watch the system completely disappear unless you reload the favorites list. This doesn't happen if it's the only system in the favorites list so there has to be at least 2 systems in the list to replicate this issue. Correct me if I'm wrong, but shouldn't the HP-1 throw a warning message up about no channels being in range - or at least sit there with the system accessible to unavoid another talkgroup so it's scannable again? This was actually brought to my attention by another HP-1 owner and I was able to replicate but not resolve. Looking forward to your comments/observations on this one!
 

OCO

Member
Joined
Jul 17, 2011
Messages
929
Location
Central Michigan
There may be another bug with the new firmware. Create a favorites list and add 2 systems (at least 1 of them a trunked system), then add a group on one of the systems with all but 1 of the talkgroups avoided. While scanning, avoid the 1 unavoided talkgroup and watch the system completely disappear unless you reload the favorites list. This doesn't happen if it's the only system in the favorites list so there has to be at least 2 systems in the list to replicate this issue. Correct me if I'm wrong, but shouldn't the HP-1 throw a warning message up about no channels being in range - or at least sit there with the system accessible to unavoid another talkgroup so it's scannable again? This was actually brought to my attention by another HP-1 owner and I was able to replicate but not resolve. Looking forward to your comments/observations on this one!
I created a new Favorite, with 2 systems. I avoided all but one TG (channel) on one of the systems (trunked). Loaded the Favorite, set it up as the only one to use. Avoided the last TG (channel) and sure enough the scanning just showed the other system. I went into Menu-->Advanced Menu-->Avoid Options and unavoided one of the listed TGs and the system showed up in the scanning again.. Not sure if I was supposed to do something to the other system??
 

SDavis90

Member
Joined
Jul 21, 2006
Messages
213
Location
Middle Tennessee
Problem verified

Follow up -

I tried to create the same problem again tonight. With success!

Holding on Mot. Type II Analog system. Listening for 2-3 hours....Goes quiet. I verified and wrote down the CC earlier. So figuring it probably switched to other CC on a certain hour at night....I check the time.

9 minutes past 11pm.

Turn on my 396XT....verified the CC had indeed changed to the other CC frequency...able to receive comms on the 396XT just fine.

Next - Release the hold (on HP)...and when it hits the said system again after release, and during scan, it goes back to working fine.

This is post V2.02 update.

So far no other problems, other than the UID issue.
 

OCO

Member
Joined
Jul 17, 2011
Messages
929
Location
Central Michigan
Paul:
Just updated firmware with Sentinel, went OK, but still shows version 2.02 and if the "UID" problem was the mode set returning to "Off" through power off, it's still doing it....

Latest Sentinel, latest Extreme.....

EDIT: Looks like, from the Uniden forum, that the bug Paul is referring to is an editing entry problem in putting UID's in, not the UID Display Mode issue..
 
Last edited:

W4KRR

Member
Premium Subscriber
Joined
Apr 1, 2001
Messages
3,266
Location
Coconut Creek, FL
System hold bug?

I may have jumped the gun on that. The System Hold seems to be working fine now.
I don't think I jumped the gun. I've been holding on a very busy Motorola trunked system for a few minutes. Not a peep out of the HP-1. As soon as I take the system hold off, I begin to hear traffic.

This seems to occur if I hold on the system while it's scanning through it with no active talkgroups. If I hold the system while a talkgroup is active, it seems to work as it should. Maybe someone else can duplicate this behavior.

(I am referring to System hold, not Department or Channel).
 

SDavis90

Member
Joined
Jul 21, 2006
Messages
213
Location
Middle Tennessee
I don't think I jumped the gun. I've been holding on a very busy Motorola trunked system for a few minutes. Not a peep out of the HP-1. As soon as I take the system hold off, I begin to hear traffic.

This seems to occur if I hold on the system while it's scanning through it with no active talkgroups. If I hold the system while a talkgroup is active, it seems to work as it should. Maybe someone else can duplicate this behavior.

(I am referring to System hold, not Department or Channel).
Mine will work as it should also, if I do a "system hold", while a talkgroup is active.

In fact, that is usually what I do if I want to just listen to that specific system. I system hold on it, and it works fine. What happens with mine is when the Control Channel on the system changes, it goes quiet on the HP.

If I release the hold it scans just fine, and will do so all day long....when I hold it on the system....until the control channel changes again. The control channel for this system changes every night at 11pm.

I plan on holding on a specific talk group tomorrow night to see if it stays locked in during the CC switch over.

I certainly believe we are on to something here.
 

t_shuffle

Member
Joined
Jan 1, 2006
Messages
90
Location
Fair Oaks, CA
You are on to something here. Holding on the top bar kills scanning. I don't trust the second one entirely, either, but I could be wrong.
 
Last edited:
Status
Not open for further replies.
Top