Private Streaming of DSD+ Via Zello - Help?

Status
Not open for further replies.

rkillins

Member
Joined
Dec 15, 2001
Messages
309
I am trying to stream my PC's DSD+ voice to my Android devices via WiFi or cellular. I've chosen Zello.
I have my source account set up on my Windows 10 platform, and a password protected channel. On my Android device, I have my second account set up. I am able to communicate between the two devices as a "walkie-talkie" as this application is intended.

But I am struggling to get the DSD+ audio to transmit via Zello. I'm assuming I am failing in adjusting the settings in both Zello and DSD+ to accomplish this.

In DSD+, with Outpout set to my speakers, I can hear any voice transmissions. I assume I need to change the output to "Cable Input (VB-Aubio Virtual Cable)"
In Zello, Audio options, the playback and recording devices are both set to CABLE INPUT (VB-Audio Virtual Cable)

Am I missing something (clearly I am) as nothing is being transmitted to my Android device (when there is a transmission evident on DSD+)
 

dlnorth

Member
Joined
Apr 24, 2004
Messages
96
I am trying to stream my PC's DSD+ voice to my Android devices via WiFi or cellular. I've chosen Zello.
I have my source account set up on my Windows 10 platform, and a password protected channel. On my Android device, I have my second account set up. I am able to communicate between the two devices as a "walkie-talkie" as this application is intended.

But I am struggling to get the DSD+ audio to transmit via Zello. I'm assuming I am failing in adjusting the settings in both Zello and DSD+ to accomplish this.

In DSD+, with Outpout set to my speakers, I can hear any voice transmissions. I assume I need to change the output to "Cable Input (VB-Aubio Virtual Cable)"
In Zello, Audio options, the playback and recording devices are both set to CABLE INPUT (VB-Audio Virtual Cable)

Am I missing something (clearly I am) as nothing is being transmitted to my Android device (when there is a transmission evident on DSD+)
Did you enable VOX in Zello and set the correct thresholds?
 

Remington12G

GØT AES?
Joined
Dec 20, 2018
Messages
949
The VOX needs to be set and the small locked PTT needs to be red for it to activate
 

rkillins

Member
Joined
Dec 15, 2001
Messages
309
Hi dlnorth ... VOX had been checked to enable VOX for handsfree, and the lock set (red bar to the right of it).
"Set to correct thresholds?" No idea. I'm really not sure how to approach adjusting thresholds.

When I tune into a weather carrier in SDR sharp and pipe out audio using VB-Audio virtual cable, Zello will broadcast to my Android.
 

cmjonesinc

Member
Premium Subscriber
Joined
Apr 25, 2011
Messages
1,303
Here's how i have mine setup. I use unitrunker outputting the raw p25 data in to dsd+ with one virtual audio cable. I then have dsd+ outputting on another virtual audio cable with the decoded voice traffic. I set zellos input channel as the second virtual audio cable (the output from dsd) and zellos output as my computer speakers. I use the second virtual audio cable instead of speaker out from dsd so i can mute the radio when I'm not wanting to hear it. Go to recording properties and check/uncheck 'listen to this device' as needed. That way you can adjust the speaker volume on the computer without interrupting the level that the zello vox is using. Have my thresholds set around -40. Reading back over that, it sounds confusing. I can get some screenshots if you'd like.
 

rkillins

Member
Joined
Dec 15, 2001
Messages
309
Appears a reboot of the PC did the trick. I ddidn't need to adjust any thresholds.
 

rkillins

Member
Joined
Dec 15, 2001
Messages
309
Hi folks, I still struggle with trying to get this concept to work. Clearly I am missing something here ...

For testing, before I try to use it on the sporadic transmissions of a radio system through DSD+, I am using SDR# to tune into the constant transmission of the local weather broadcast.

SDR# Audio Output: [MME] Cable Input (VB-Audio Virtual Cable)

Zello (Windows Platform) Settings:
Audio
  • Playback device: Speakers (Realtek High Definition Audio)
  • Slider: 40
  • Recording Device: CABLE Output (VB_Audio Virtual Cable) only option
  • Slider: 40
  • Playback Amplifier: 0
  • Recording Amplifier: 0
  • Noise Suppression: checked
  • Force HQ voice recording: unchecked
  • Use compatible voice recording format: unchecked
VOX
  • Turn on VOX for handsfree: checked
  • Activation threshold: 48
  • De-activation threshold: 48
  • Trigger time: 50
  • Relaxation time: 50
  • Save VOX contact between sessions: unchecked
The Windows 10 Zello interface, on the bottom, there is a green bar next to the microphone, and a green bar next to the lock.

I am still not getting tyhe audio out to my android application. I can send alerts to my Android from Windows, and I can connect to Windows through my Android, but the SDR# connection isn't being broadcast.

Thoughts? Suggestions?
 

cmjonesinc

Member
Premium Subscriber
Joined
Apr 25, 2011
Messages
1,303
The smaller green bar to the right should be clicked to make it red. Then as audio comes in the bar on the left should turn red on its own to transmit. Make sure you have the channel clicked then click the small green button. If you're multicasting to multiple zello channels hold down ctrl and click all of them then click the small green button.
 

rkillins

Member
Joined
Dec 15, 2001
Messages
309
Thank you cmjonesinc for clearing things up. Your PM image was helpful. I managed to get the weather transmnission to broadcast from SDR# to my android device via Zello, however, no love for for DSD+.

DDS+ (1R)'s output is CABLE Input (VB_Audio Virtual Cable).
When there are transmissions noticed in the event log and channel activity windows, there is no audio going to my Android.
 

cmjonesinc

Member
Premium Subscriber
Joined
Apr 25, 2011
Messages
1,303
If you have dsd output to your speakers are you getting a good decode from it? I'll shoot you another pm when i get home. I'll write up a diagram of the order of operations and that may help troubleshooting.
 

cmjonesinc

Member
Premium Subscriber
Joined
Apr 25, 2011
Messages
1,303
It just hit me what your issue might be. Are you using 1 or 2 virtual audio cables? If you have a computer with external speakers (with external volume control), this is one way to make it work.

Sdr# (out to vb cable in) ---------- DSD+ (input vb cable) (output speaker) ---------- Zello (input speaker) (output speakers). The problem with this setup is if you adjust the volume to mute in windows it will also mute the zello input therefore you won't have an audio feed. If you have external speakers you can turn the audio down on the speaker and leave windows turned up. But all your computer audio will come through zello as well.

The better method is to use 2 virtual audio cables. To keep it free I use 'vb cable' for one and 'virtual audio cable (free)' for the other. The operation for that would be

Sdr# (out vb cable) ------ DSD+ (in vb cable) (out virtual audio cable) -------- Zello (in virtual audio cable) (out speaker). Then you can right click and go in to windows recording properties. Select virtual audio cable and go to the advanced tab (i think off the top of my head) and check 'listen to this device'. That will allow you to adjust your pc speaker volume where ever you want it. And if you don't want to hear your stream over the computer you can leave 'listen to this device' unchecked. Then just use your pc as normal and all the streaming stuff will be in the background.

I know that's a bit confusing so if you'd like a diagram I don't mind doing it. Hope that hasn't confused you and gets you going.
 

rkillins

Member
Joined
Dec 15, 2001
Messages
309
Thanks cmjonesinc ... I'm only using one virtual cable. I am not using SDR# with DSD+. Just DSD+. (I only used SDR# for testing to tune into a constant carrier.)
Yeah, a bit confusing ... I'll plug away at it.
 

cmjonesinc

Member
Premium Subscriber
Joined
Apr 25, 2011
Messages
1,303
Even better... I have nine instances running via gateway mode and three of them do not transmit, but gateway mode works much smoother.
Finally had a second to get that set up........ man that is nice. Thanks for posting those instructions. I never even knew that mode existed.
 
Status
Not open for further replies.
Top