• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

Pro-2002 Problem and RS Support Site

Status
Not open for further replies.

seocom

Member
Joined
Aug 28, 2006
Messages
2
Hi All,

New member and first post.

Dragged out an old scanner that hasn't been used in many years, my old Pro-2002. Plugged it in and without turning it on, the display lights up with all apostrophe eights ('8) right across the board. Turning the power switch on and/or hitting keys does not do anything.

Is there any kind of a reset on these, or does this sound familiar to anyone and how did they fix it? I am handy with repairs so I would like to tackle it myself.

At one time, Radio Shack (Tandy) had a website that gave repair info, but I have not been able to find any working now. I have found some references to them, but I get re-directed to the main Radio Shack site that has no support info on it.

Many thanks and have a nice day,
Stan...
 

pro92b

Member
Joined
Jun 27, 2002
Messages
1,665
The attached file was archived from the Radio Shack site and it contains all the info from the owners manual. You should try replacing the memory backup battery first. Pressing the clock key may clear up the display if nothing serious is wrong. As a last resort the part number for the service manual is in the attached file and you might still be able to order it.
 
Last edited:

seocom

Member
Joined
Aug 28, 2006
Messages
2
pro92b said:
The attached file was archived from the Radio Shack site and it contains all the info from the owners manual. You should try replacing the memory backup battery first. Pressing the clock key may clear up the display if nothing serious is wrong. As a last resort the part number for the service manual is in the attached file and you might still be able to order it.
Hi pro92b,

Thanks for the quick reply and the attached info. Had pulled the memory battery and tried replacing with new one, but that doesn't help. Pressing the clock key (or any other key) doesn't change the display at all either. I was hoping that there was combination of keys that did a re-set, or someone had had the same problem and knew what resister or whatever to replace...I guess I will have to look into getting a service manual afterall, or decide if it's worth the cost. It's been sitting around for so many years, and just thought I'd put it back to use on some of the local low and high band stuff that's still around (plus the local airport).

Thanks again,
Stan...
 
Status
Not open for further replies.
Top