Pro- 2096 Issue

Status
Not open for further replies.

KC8FAS

Member
Joined
Sep 26, 2003
Messages
87
Location
Moran, Michigan
Hello everyone I been having an issue with my pro-2096. I own two of them and have them located in different rooms. I can hear both at the same time. One of them isn't picking up digital. I noticed on the display when the scanner is receiving a digital signal it doesn't want to lock on. I can see the talk-group and frequencies but it kinda flashes like its trying to decode the signal but just cant. Sometimes it will work but is getting worse,Does anyone know what the issue is and would it be worth sending in for repair.
 

troymail

Silent Key
Joined
Dec 19, 2002
Messages
9,977
Location
Supply (Lockwood Inlet area), NC
Hello everyone I been having an issue with my pro-2096. I own two of them and have them located in different rooms. I can hear both at the same time. One of them isn't picking up digital. I noticed on the display when the scanner is receiving a digital signal it doesn't want to lock on. I can see the talk-group and frequencies but it kinda flashes like its trying to decode the signal but just cant. Sometimes it will work but is getting worse,Does anyone know what the issue is and would it be worth sending in for repair.
I've seen this kind of thing on more recent radios from GRE. On these radios, I've found that reflashing the firmware and/or reprogramming (wipe/replace SD card, etc.) solves it.

Not sure what similar options you have with that model...
 

kb8rvp

Member
Joined
Jul 4, 2003
Messages
551
Location
Michigan
Could be lots of things. All of the 800MHz towers in Michigan are being rebanded so make sure both scanners have the new freq updates in them. Like the last person said you may need to update the firmware. I have seen Pro-2096 scanners that seem to have an issue and after updating the firmware it works just fine. Check the antenna connection is all the way on and that the antenna jack is not loose or damaged. Location makes a lot of difference so try moving it a foot in any direction or maybe even put the one that's not working next to the one that is and see if it works in that location or even swap the location of the two.


Good Luck,
Mike
 
Last edited:

tac7

Member
Joined
Dec 2, 2003
Messages
56
Location
Hamilton, ON
One of them isn't picking up digital...
There may well be a problem with that unit, but before tinkering with the "faulty" one, exchange both scanners by putting them in the same location as the other one.

I had the same thing happen with one of my two Pro-96s, and it turned out that one location somehow blocked the reception enough (lots of steel beams in the building) to degrade digital reception in that spot. Moving it over a bit solved the problem.

Originally though, when I first got the Pro-96s, both needed the VR2 and VR4 pots adjusted to improve UHF digital reception, the electronic "guts" being the same as in the Pro-2096.
 
Last edited:
Status
Not open for further replies.
Top