Pro 2096

Status
Not open for further replies.

ARCA-Dave

Member
Feed Provider
Joined
Apr 26, 2008
Messages
65
Location
Summerville, South Carolina
Hello everyone, Dave here. I just got the "new to me" used Radio Shack Pro 2096 today. I did the reset thing and it erased all of the previously programed frequencies in there, as I wanted to. I tried to program my local frequencies from my old Pro 2020 scanner and I think I got one in on bank 0 channel 0 or 01 not sure. Anyway it went in OK and then I finally got the Alpha tag figured out from the manual. I went to the next channel and it gave me the "Invalid Channel" message. I could not put it into any channel on bank 0 or bank 1. I may have to break down and get the cable and Win96 program, but for now at least want to program it with my old frequencies for here in Summerville South Carolina.....any suggestions would be greatly appreciated...Dave
 

ARCA-Dave

Member
Feed Provider
Joined
Apr 26, 2008
Messages
65
Location
Summerville, South Carolina
Figured it out..

Well since I had a case of the dumb a$$ I finally figured out what I was doing wrong. Evidently I was punching in the frequency and hitting the program button rather than the enter button....duhhhhh
 

Stick0413

Member
Premium Subscriber
Joined
May 16, 2005
Messages
1,118
Location
Hopewell, VA
With the 2096 I would seriously consider getting the programing cable and at least trying Win96. It will make things 10X easier.
 

ARCA-Dave

Member
Feed Provider
Joined
Apr 26, 2008
Messages
65
Location
Summerville, South Carolina
Thanks for the heads up. My neihbor has the Pro 96 and he just brought mine back after cloning his to mine. Hopefully this will work out for me. I noticed that on the trunk systems sometimes the modulation sounds kinda tinny. Not sure how to desribe it but just hight pitched like your talking into a tin can. I also hear several agencies on the same bank and channel. I would assume that there are numerous agencies on this talk group and I also notice that the frequency changes most everytime it stops on, say bank 1 channel 01 where ever he put it. I would guess this is normal. Also I would guess there is a way to eliminate one agency and still listen to the others? I will have to get with Keith and see I guess. Thanks for yalls advice...Dave
 

ARCA-Dave

Member
Feed Provider
Joined
Apr 26, 2008
Messages
65
Location
Summerville, South Carolina
On initial powerup, it shows DSP 1.0 so I am thinking I have the version 1.0 and I see that the latest version is 1.4. I have a friend that has the cable and stuff so I guess I should have him come over and download it from my computer to the scanner? Does anyone know what this upgrade does and what makes it better than the older one? Thanks for the help,Dave


I stand corrected.....I found somewhere that if you press the #3 during the powerup welcome screen, it will tell you the DSP verson, and on my second line as it told me, I have the version 1.4. Thanks for everyone's help...Dave
 
Last edited:
Status
Not open for further replies.
Top