Pro 688 Scanning Issue

Status
Not open for further replies.

rknight

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
7
I have a PRO 668. At one point it worked fine.

Took it out today and it scans, but does not stop on stations that are transmitting.I know this since scanner in other room is stopping on them. I have done the following so far:

Checked Volume
Checked Squelch
Checked Playlists. Frequencies are listed and not locked out
Took out Data Card and reinserted
Took out batteries and held power button for 30 seconds plus
Re-programed radio
Switched Antennas
Changed Batteries
Said a Prayer

Any one see this before. If so what was the cause and resolution.
Any assistance is appreciated.

Thanks and 73's

Ron KB1UXT
 

Wackyracer

Member
Premium Subscriber
Joined
Feb 18, 2016
Messages
1,477
press the weather button if you still have nothing not even white noise. then do a power reset as many times needed until it works.

If it won't even stop on any freq then try wiggling the antenna connection...could be a broken solder joint inside the radio,
 

rknight

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
7
Tried It

So I did recycle power. The WX worked. When I went to menu to scan the playlists they load and then I hear nothing. They scan. Now when I go back and check the WX to see if that is working I hear nothing not even any squelch noise.

Ron
 

Wackyracer

Member
Premium Subscriber
Joined
Feb 18, 2016
Messages
1,477
POWER RESET FIX for: Scanner powers on, loads, has display appears to scan, beeps, has no signal meter, no audio, not even on weather and possibly other problems.

This has happened to my pro-668 twice now. The fix for me was. with the scanner on, good batteries in and disconnected from any USB power do the following....

1) Pull the batteries and hold the power button for at least 60 seconds while pressing other buttons. I just press them all one at a time for a couple seconds.

2) Reinstall the batteries and power on, connect usb, test with the weather eye button to see if you now can hear audio and see a signal meter.

Repeat until you get audio on weather and squelch (white noise)
 

Wackyracer

Member
Premium Subscriber
Joined
Feb 18, 2016
Messages
1,477
If the above doesn't fix it after many attempts, try reseating the memory card, try formatting the sdcard and reinstalling your settings from iscan/ezscan, try reinstalling the cpu and dsp firmware,
 

rknight

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
7
I ended up getting help in the FB 688 group. I had to reinstall both the CPU and the Firmware and after the 2nd time it worked. Thanks for your help
 
Status
Not open for further replies.
Top