Protecter message on sony STR-DE985 Receiver

Status
Not open for further replies.

cjrjr507

Member
Joined
Feb 27, 2007
Messages
676
Location
Libby, Montana
Protector message on sony STR-DE985 Receiver

Hi

I have an Sony STR-DE985; about 10 years old and the protector message is flashing and shutting down the receiver sometimes. I took out all the speaker wires and cables on the back of the receiver and checked them and speaker wires look okay. Checked the component connection cables and the last cable I checked had an bad S-video connector; one of the pins was bent and touching the outer ground. Would that cause the protector message to come on the receiver ? I'm assuming it would but since that is not audio but video, I'm not sure. Been having strange popping noises coming from the speakers sometimes and the the protector message comes on. So that means there is a short somewhere. I hoping it's the bad s-video cable.
I'm upgrading the speaker cables with banana plugs so there is no stray wires floating around and changing the 3 back surround speaker cables to 16 gauge wires. If the receiver is still screwing up after all this, it's off to the shop to have it checked out. I did blow out the dust in it, ha. And the CAT hair that was in it. CATS!
 
Last edited:

com501

Member
Premium Subscriber
Joined
Sep 28, 2003
Messages
1,498
Location
127.0.0.1
Something in the speaker chain is not happy. Either a bad speaker, bad crossover or actually something internal to the amp, possibly a bad capacitor.

Try switching your speakers to some other set of speakers you may have around, and see if the problem goes away. If it does not, time for service on the amp. Most amp problems are pretty easy, and the description you give points to something near the amp output to the speakers or the speakers themselves.
 
Status
Not open for further replies.
Top