PSR-310 Will Not Scan or Receive - Intermittently

Status
Not open for further replies.

ScannerHam

Member
Joined
Aug 19, 2003
Messages
8
Location
Northboro
I have owned a PSR-310 for a few years and have been very happy with it. Recently it has started to act up. When I turn the scanner on, rather than scanning, it sits on one channel and will not scan or receive any audio. If I hit the scan button, it goes to the next channel and stays there. After turning the scanner on and off numerous times, sometimes it starts to scan, other times it does not scan at all. There are also times when I turn the scanner on the first time and it scans OK.

I have used the scanner with the battery pack, a DC power cord (set to 9V with the center tip +), and the supplied AC adapter, but it makes no difference. The squelch control is set correctly (no white noise). Has anyone had this problem and if so is there a fix?
 

gmclam

Member
Premium Subscriber
Joined
Sep 15, 2006
Messages
5,750
Location
Fair Oaks, CA
PSR-310

Keep in mind that there are several things that will squelch the audio apart from the squelch knob. If you have CT or DC codes programmed on a channel, that will keep the speaker quiet, but the scanner will still 'see' a signal. What happens when you turn the squelch knob fully clockwise and/or disconnect the antenna? Unless a major CPU malfunction, the only thing that keeps it from scanning when in SCAN mode is it thinks a signal is present.
 
Status
Not open for further replies.
Top