PSR-410 Milair fuzz?

Status
Not open for further replies.

737mech

Member
Premium Subscriber
Joined
Aug 14, 2006
Messages
1,962
Location
Clark County, NV.
I have many scanners, all fed from my EDA-2800 8 port amp. My BCt-15X's are clear and no noise, my PSR-410 however always has squelch fuzz with the voice whenever a milair comm comes in? It's fine for other conventional freqs like 154-174 but Milair 220-400 always has fuzz? Anyone else have this problem or a fix for it? Maybe I'll try external speaker?
 

ka3jjz

Wiki Admin Emeritus
Joined
Jul 22, 2002
Messages
23,257
Location
Bowie, Md.
Dumb question - what is 'squelch fuzz'? Are you talking along the lines of excessive hiss, noise, etc.?

If it's internally generated noise, like, say from an oscillator in the radio, the external speaker will only make it worse.

Mike
 

737mech

Member
Premium Subscriber
Joined
Aug 14, 2006
Messages
1,962
Location
Clark County, NV.
Trying a few things

It's noise along with voice. You are correct no joy with external speaker. I went ahead and heated up the bnc center to board wire, maybe that was the issue? Seems a little better now. Also bent the bnc contacts closer to the center. Still a little noise but better so I guess that's all I can do? Maybe try a new feeder coax tomorrow? It has a shield box over the board near the bnc connection, I might add some shielding there to see if that helps? I also thought to add a ferrite choke on the power cord.
 
Last edited:

ilgrant

Member
Joined
Nov 13, 2002
Messages
410
Location
Chicago, IL
AM is selected, right? Not sure if FM can be programmed on that one but I do remember awhile back that one of the older scanners had FM selected for the MilAir band instead of the required AM.
 
Status
Not open for further replies.
Top