PSR-800: PSR-800 EZ Scan

TexScan780D

Member
Premium Subscriber
Joined
Feb 20, 2003
Messages
868
I got the PSR-800 EZ Scan version 1.08. I tried the Check for Liberary Update, but give me an Update Check Error There was an error getting the current
version informaiton from the update site. The error message received was: HTTP/1.1 301 Moved Permanently. Any work around for this?
 

kruser

Active Member
Premium Subscriber
Joined
Nov 25, 2007
Messages
4,005
Location
West St Louis Cnty, MO
I got the PSR-800 EZ Scan version 1.08. I tried the Check for Liberary Update, but give me an Update Check Error There was an error getting the current
version informaiton from the update site. The error message received was: HTTP/1.1 301 Moved Permanently. Any work around for this?
There's a newer 1.09 version for the PSR800 but my copy is also throwing a similar error as what you see so I don't think that's why your older version has stopped working.
I'd checked it earlier today after seeing the certificate error problem with the Whistler EZ-Scan versions and the GRE PSR800 version was working correctly. At that time, the Whistler versions were still broke. Now the Whistler issue has been fixed but we see this new error for the GRE version.
Seems odd but I'm not sure it they may be related. I don't know who maintains the GRE version and if Whistler is doing it or someone else.
I know Don Starr was doing the database updates for quite a while after GRE went under but I don't think he's involved in the GRE version for the PSR800 any longer.

Hopefully it will be corrected.
 

JANFINE

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
213
Location
MIRAMAR, FL
GRE no longer supports the scanner. So if you are trying to use the GRE software you will have no luck.
If you use the TRX-1 software you can download and copy the software to the 800. Just don't do any firmware updates or DSP updates.
 

tvengr

Active Member
Joined
Feb 10, 2019
Messages
3,045
Location
Baltimore County, MD
I got the PSR-800 EZ Scan version 1.08. I tried the Check for Liberary Update, but give me an Update Check Error There was an error getting the current
version informaiton from the update site. The error message received was: HTTP/1.1 301 Moved Permanently. Any work around for this?
The workaround is to send your PSR-800 to Whistler for the Legacy Upgrade. It will be converted to a Whistler WS1080. You will be able to use the WS1080 EZ Scan software for firmware and library updates. Others who have had the upgrade done have reported a significant improvement in the performance of the scanner. The upgrade also adds DMR. https://whistlergroup.com/products/upgrade
 
Last edited:

kruser

Active Member
Premium Subscriber
Joined
Nov 25, 2007
Messages
4,005
Location
West St Louis Cnty, MO
GRE no longer supports the scanner. So if you are trying to use the GRE software you will have no luck.
If you use the TRX-1 software you can download and copy the software to the 800. Just don't do any firmware updates or DSP updates.
The GRE version for the PSR800 has received weekly database updates each week on the exact same schedule as Whistler's versions.
That changed sometime yesterday as it did work yesterday morning but now throws an error.

I myself no longer need the PSR800 version as I finally sent mine in for the WS1080 upgrade.
I just wanted to point out to the OP and others reading this thread that the PSR800 was indeed receiving weekly database updates thru yesterday morning but that broke about the same time that Whistler fixed their certificate error that surfaced the day before for their newer versions of Ez-Scan.
 

TexScan780D

Member
Premium Subscriber
Joined
Feb 20, 2003
Messages
868
The workaround is to send your PSR-800 to Whistler for the Legacy Upgrade. It will be converted to a Whistler WS1080. You will be able to use the WS1080 EZ Scan software for firmware and library updates. Others who have had the upgrade done have reported a significant improvement in the performance of the scanner. The upgrade also adds DMR. https://whistlergroup.com/products/upgrade
 

TexScan780D

Member
Premium Subscriber
Joined
Feb 20, 2003
Messages
868
The GRE version for the PSR800 has received weekly database updates each week on the exact same schedule as Whistler's versions.
That changed sometime yesterday as it did work yesterday morning but now throws an error.

I myself no longer need the PSR800 version as I finally sent mine in for the WS1080 upgrade.
I just wanted to point out to the OP and others reading this thread that the PSR800 was indeed receiving weekly database updates thru yesterday morning but that broke about the same time that Whistler fixed their certificate error that surfaced the day before for their newer versions of Ez-Scan.
I have bgeen think of doing this, so I better do it soon.
 

DJ11DLN

Member
Premium Subscriber
Joined
Mar 23, 2013
Messages
2,097
Location
Mudhole, IN
I have bgeen think of doing this, so I better do it soon.
I can't speak for the PSR-800 but I had a Pro-18 and a Pro-668 done and it was a pretty substantial improvement for both, especially the 668. I bought that one during the bankruptcy close-out so I couldn't return it and I thought it was defective. It was the next thing to deaf. The upgrade really brought it to life.
 

Whistler_Support

Whistler Representative
Whistler Representative
Joined
May 7, 2020
Messages
47
Location
Bentonville, Arkansas
Seems their may be an issue between the old pc apps and the server.
The GRE and RadioShack apps are not supported however you can obtain an updated library using the Whistler Handheld PC app then transfer the DB files to your non supported pc app.

From the Whistler WS1080 PC App, run a library update.
Then go to your My Document > Whistler 1080 Digital > DB and copy the contents of this folder.
Replace the files in your GRE or Pro668 Digital DB folder with the files copied from the Whistler 1080 digital DB folder. Launch your GRE or RadioShack pc app and you will have the latest Library.

Keep in mind that the WS1080 library contains DMR systems however your GRE or RadioShack models do not support these objects. Details for an official DMR Upgrade program is available at whistlergroup.com/products/upgrade
 

jkahn

Very good looking Member
Premium Subscriber
Joined
Aug 7, 2003
Messages
363
Location
Silver Spring MD
Does anybody have the old PSR800 firmware file that was replaced using the unauthorized program to make the radio think it was a Whistler? I know several people who have the rigged radios that are functioning correctly, but would like to send them to Whistler for the legal upgrade without paying the extra fee for rigging their radio. They are not too tech savvy and asked me to fix them. I have the program, but do not have the firmware file and don't want to play with my radio, just in case.
 

MichaelBhere

Member
Joined
Mar 6, 2015
Messages
151
Change the file extension from .zip to .exe and this should work as it was an official GRE CPUUpdater for the PSR-800

Note, the file has not been Zip compressed, only the extension name was edited to allow attachment.
DO not attempt to unzip, just edit the file extension from .zip back to .exe
 

Attachments

N1GAW

Member
Premium Subscriber
Joined
Jul 15, 2014
Messages
3,763
Location
Raleigh, NC
@CycleSycho the fix is a simple work around, @Whistler_Support has gone above and beyond to provide that for you. There is no requirement to fix something that they are technically not responsible for. They could have said if you want updates buy the Legacy Upgrade, but they didn't they said here is how you can all use our product for free.
 

CycleSycho

Member
Joined
Jul 26, 2016
Messages
385
Location
Central South Carolina
@CycleSycho the fix is a simple work around, @Whistler_Support has gone above and beyond to provide that for you. There is no requirement to fix something that they are technically not responsible for. They could have said if you want updates buy the Legacy Upgrade, but they didn't they said here is how you can all use our product for free.


:rolleyes: N1GAW, thank you for your most direct criticism. I am guessing this issue doesn't affect you, does it. :rolleyes:

:) It went from copying a file from a folder on a PC, to transporting it to another computer on a flash drive, then downloading it to the second computer to paste into the iScan program. To now it is listed on the Whistler website downloads page. It IS an improvement for my situation. It also now is an additional 'fix' for everyone else who has the older programs, that can just go to the download page instead of copying/pasting folders on differing machines and programs. Do YOU want to install a program on a machine just to grab a file and copy it to another program every week? My situation may not even be an issue for you, is it? No need to reply, thank you. :)

:) Remember, this ONLY applies to those of us who have the inability to update library files! I cannot ask/tell/make someone else to 'legacy upgrade' their scanners, it isn't my place to (get it?). Thank you. :)


.
 

kd2pm

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
214
Location
East Windsor NJ
I bit the bullet today and signed up for the upgrade. Just waiting on the email to let me know where to send it to. But the PSR800/TRX1 programming software works fine. So will be nice to see an improvement on the PSR when it comes back.
 

Whistler_Support

Whistler Representative
Whistler Representative
Joined
May 7, 2020
Messages
47
Location
Bentonville, Arkansas
For those experiencing Library update issues with the GRE and RadioShack pc apps, you can download the WS1080 EZ Scan pc app and update the library then copy the contents of the DB folder to the the DB folder for your GRE or Radio Shack pc app. This takes about 1 minute.

For those that do not want to install the WS1080 EZ Scan pc app, you can go to the download page at https://whistlergroup.com/pages/downloads and select the WS1080, there you will find a Library_dbfiles_###.zip file that can be downloaded. Once downloaded you will need to unzip the file then copy the contents into the DB folder of your pc app. Updated Library versions will be posted weekly.
 

stircrazy

Member
Joined
Oct 30, 2008
Messages
101
Location
London Ontario
Seems their may be an issue between the old pc apps and the server.
The GRE and RadioShack apps are not supported however you can obtain an updated library using the Whistler Handheld PC app then transfer the DB files to your non supported pc app.

From the Whistler WS1080 PC App, run a library update.
Then go to your My Document > Whistler 1080 Digital > DB and copy the contents of this folder.
Replace the files in your GRE or Pro668 Digital DB folder with the files copied from the Whistler 1080 digital DB folder. Launch your GRE or RadioShack pc app and you will have the latest Library.

Keep in mind that the WS1080 library contains DMR systems however your GRE or RadioShack models do not support these objects. Details for an official DMR Upgrade program is available at whistlergroup.com/products/upgrade
I filled this step by step and now my radio does not decrypt p25 transmissions. Before I did this update my radio worked fine. I formatted my radios sd card. Tried a fresh version of ezscan and importing the new library. Still doesn't work. It will receive non digital signals. But not digital. Are you guys forcing everyone to upgrade by this work around? I can't find an ezscan version with a library installed. What's the best way to revert my scanner back to a working scanner?
 

Swipesy

Member
Joined
Jan 27, 2003
Messages
1,730
Location
Northern Ohio
You have not! I started to help you and I am 90% sure I know what your issue is. But you ignored my post and started this one. Good luck.
 
Top