PSR-800 TO WS 1080, Loss of earphone jack audio.

Status
Not open for further replies.

colbrz1319

Member
Premium Subscriber
Joined
Jan 1, 2015
Messages
133
Location
Washington, New Jersey
Howdy folks, 3 days ago my undamaged, undropped PSR-800 simply quit providing audio thru my stereo earbud/earphone/usb speaker jack. I tested multiple earbuds and usb amplified speaker sets, with the same, "no audio" results. Its internal speaker works fine, while the earphone jack appears dead.
 

IAmSixNine

Member
Feed Provider
Joined
Dec 19, 2002
Messages
2,038
Location
Dallas, TX
IF you frequently plug and unplug often from this port its possible its simply worn out.
Do you use the port often?
 

colbrz1319

Member
Premium Subscriber
Joined
Jan 1, 2015
Messages
133
Location
Washington, New Jersey
This model was purchased right after its release to the public, when GRE China was absorbed by Whistler Group 6 or so, years ago. The jack was used occasionally, but never left a desktop, and has no dings or scratches. Normally, you can spot jack failure, by slightly rattling the plug within the jack "entry pipe" and somewhere in that process, hit the "sweet spot" and restore intermittent reception, even if for only a moment or two. "Jockeying" the earphone/earbud/usb speaker plug around did nothing, so short of opening the radio up, I;m stumped.
 

scannerjunkie

Member
Joined
Feb 18, 2006
Messages
191
Location
South Side Of Chicago
If I'm not mistaken and correct me if I'm wrong but the psr 800 1080 668 all have a volume control you Can access via ezscan for the headphone jack. Check the volume level. It may be turned all the way down.
 
Status
Not open for further replies.
Top