PSR500> Everything seems to work but radio is deaf..

Status
Not open for further replies.

whooey

Member
Joined
Feb 2, 2005
Messages
846
Location
Gainesville, FL
Hi RR, hope all is well with you... :)

I haveent been using my PSR-500 for awhile, it has been on my shelf. I have been using my PSR600 around the house.

Yesterday I turned on my PSR500 and I noticed it wasnt picking up the local control channel. So I tried the weather channels, nothing. Turned the squelch down, speaker works fine.

Hooked it up to the CPU to releoad my Win500 file, still nothing.

This scanner hasnt been dropped or anyhting, any ideas?

Thanks!
 

wbigcount

Member
Premium Subscriber
Joined
May 15, 2003
Messages
752
Location
Kansas City
Hey Whooey here is another post in that same thread, you might check if its your problem before u send it in to GRE.


bubbaearle
also had an issue where my radio went deaf......it was right after I got it back from GRE when my display went dead.......

I unpacked the radio, popped in the battery pack and it would not pick up anything....no WX - no nuthin'!

I cracked it open and noticed the white rectangular connector that mates up when you put the 2 PCB's together was not seated properly......the top board was ****ed a bit......I reseated the board and radio was OK.

I had thought about putting a small square piece of foam on the inside of the back case to keep a small bit of pressure on the board to keep the board seated properly.
 

whooey

Member
Joined
Feb 2, 2005
Messages
846
Location
Gainesville, FL
Hey Whooey here is another post in that same thread, you might check if its your problem before u send it in to GRE.


bubbaearle
also had an issue where my radio went deaf......it was right after I got it back from GRE when my display went dead.......

I unpacked the radio, popped in the battery pack and it would not pick up anything....no WX - no nuthin'!

I cracked it open and noticed the white rectangular connector that mates up when you put the 2 PCB's together was not seated properly......the top board was ****ed a bit......I reseated the board and radio was OK.

I had thought about putting a small square piece of foam on the inside of the back case to keep a small bit of pressure on the board to keep the board seated properly.
Thanks Big C, I saw that when researching the thread, no such luck. :(

I have sent GRE a EM, so I guess i will have to send it in.

Bummer.
 
Status
Not open for further replies.
Top