RS HTX-245 dual band ht, tx discrepancy

Status
Not open for further replies.

MeddleMan

Member
Joined
Feb 22, 2009
Messages
246
Location
Mokane, MO
I have had this radio for years. It looks like it has been dunked into some sweet drink. My cousin cleaned it. For the most part, it works. But it's about 15 or 150khz off. It will key a repeater, but must deliberately be tuned off frequency to operate said repeater. 0.600 is set offset. I can't find any other user serviceable setting. Still a good spare radio. Repeater pairs are 147.225 and 147.825. I've set it to display on vfo at 147.240 and 147.840. Toned at 123.0 hz. That's how it works. Any ideas will be very much appreciated. Thanks in advance, David.
 

Attachments

Last edited:

krokus

Member
Premium Subscriber
Joined
Jun 9, 2006
Messages
4,534
Location
Southeastern Michigan
It might need more cleaning, in internal parts.

There is a chance some adjustable parts have been bumped, during the cleaning.

Sent via Tapatalk
 

MeddleMan

Member
Joined
Feb 22, 2009
Messages
246
Location
Mokane, MO
got it

We'll look into it a little later, thanks. I also have the mono band radio. Same dunking, but does everything but pass audio through built-in speaker or ext speaker.
 

Attachments

Last edited:

MeddleMan

Member
Joined
Feb 22, 2009
Messages
246
Location
Mokane, MO
broken solder joint

On the mono band radio, a grounding strap had come loose from a pot. Not sure if this is the solution to my audio problem. I tried to get some help. Couldn't find any. Or my soldering iron.
 
Status
Not open for further replies.
Top