RTL SDR using two dongles of exact make in Unitrunker

Status
Not open for further replies.

NRGST

Member
Premium Subscriber
Joined
Mar 4, 2014
Messages
6
Hey all, was searching for an answer to my problem and finally solved it and wanted to share here for others having the same issue. (I've seen a few posts having the same issue but are very old, hopefully this helps someone out that has the same issue. )

I have 2 version 3 dongles from rtl-sdr.com and was trying to get unitrunker working with both. They each indivdually worked when tested in SDR# and unitrunker so I knew they were both working fine, but whenever I plugged both into unitrunker one would not work.

Many posts online said that it's likely a USB Hub issue or a built-in Hub in your laptop. Not wanting to give up, I continued searching and found out that they have the same serial number, so I used rtl_eeprom (Instructions here: Ubuntu Manpage: rtl-eeprom - EEPROM programming tool for RTL2832 based DVB-T receivers) to reprogram the serial number from 00000001 to 00000002 on one of my devices, and now they both work wonderfully in unitrunker.

Although, in my quest to get it working, I descovered SDRTrunk, and I love that way better than the harder to manage unitrunker, and I believe the SDRTrunk does a better job decoding P25 than DSD+, and the alias funtion, onced programmed is brilliant for seeing who is speaking and blocking out unwanted talkgroups (I'm sure there are ways to do this in unitrunker but it seems much harder, plus watching the waterfall and spectrum live is nice to see as well), so it's my go-to now.

Hopefully this helps someone having a similar issue. Have a great one!
 

a417

!#
Joined
Mar 14, 2004
Messages
2,850
Congrats, reprogramming the serial #s is a great beginner step for multiple device installations. You can even get quite fancy with how it further makes your life easier in linux, like passing individual commands specific to the devices at the hardware level.

It's nice when people RTFM. (y)

+1 internets to you sir!
 

NRGST

Member
Premium Subscriber
Joined
Mar 4, 2014
Messages
6
Congrats, reprogramming the serial #s is a great beginner step for multiple device installations. You can even get quite fancy with how it further makes your life easier in linux, like passing individual commands specific to the devices at the hardware level.

It's nice when people RTFM. (y)

+1 internets to you sir!
I'm generally a figure stuff out myself kind of guy and always find stuff for myself (hence why I've been a member for so long and don't post often, just paid for premium to support this great site!), but it's nice when answers are easy to find. Hopefully this saves someone a few days of searching! Now to bundle this all together with my raspberry pi and make it semi-permanent.
 

KD0TAZ

Member
Feed Provider
Joined
Dec 26, 2010
Messages
332
Location
Kansas
I will also add this just in case someone else runs into the same issue I did. Some dongles (in my case it was Nooelec SmarTees) will show up as two separate devices - both in Zadig and in rtl_test/rtl_eeprom. Device 0 is the built in (but unused for our purposes) IR receiver. Device 1 is the actual radio. In Zadig it will show as Bulk Input Device #0 and #1. If you try to run rtl_test or rtl_eeprom, it defaults to Device 0 and will return an error because it can't talk to the radio. The fix for this is to use the command "rtl_eeprom -d 1 -i 0 -s 0001####". This selects Device 1, disables the internal IR device, and sets the serial number. If you run rtl_test, it will now only show one device, and will no longer need the -d 1 switch as the radio then becomes Device 0. After you do this, run Zadig again and reinstall the driver (ONLY the radio should show up now, not the IR).
 

foxtail

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
296
Location
Niagara Region Canada
kd0taz, i tried your method of changing ser. and ir disable. Some reason would not change, something about could not open. Anyways I was able to do it with two commands from eeprom tool which was,,,,: rtl_eeprom -s 00000101, and rtl_eeprom -i 0.....both ask to unplug and re plug dongle back in to confirm. P.S. this was with ubuntu 18.04
 

KD0TAZ

Member
Feed Provider
Joined
Dec 26, 2010
Messages
332
Location
Kansas
Windows.

Debian-derivative Linux.


Different operating systems. I have never run rtl_eeprom/test on a windows machine, but maybe it handles the flags differently.
That's entirely possible. My experience with Linux is very limited, I know just enough basic commands and can google errors to (usually) get myself out of trouble but that's about it lol.
 
Status
Not open for further replies.
Top