SDR# causes mouse freezes

Status
Not open for further replies.

Jim_Shaffer

Member
Premium Subscriber
Joined
Mar 31, 2013
Messages
47
I'm using the current version of SDR#, but this problem started several versions ago (I'm not sure exactly when, because I hadn't upgraded for a very long time but wanted to try out the recent version with a bandplan display.) Every so often, my mouse will freeze for a brief time. I don't need to be accessing my RTL stick for this to happen, all that needs to happen is that SDR# is open, receiving anything or not. Using the RTL stick in HDSDR doesn't cause this problem. Has anyone else seen anything like this?
 

princessthelus

Member
Premium Subscriber
Joined
Dec 16, 2016
Messages
62
Does it make the sound in Windows that hardware is being disconnected and what is your rigs processor and motherboard? I had the same thing happen with my desktop which is an AMD FX with an ASROCK Extreame 3 motherboard. The laptop i use now for SDR is an AMD Phenom II and it does not disconnect the mouse.
 

dlwtrunked

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
575
I'm using the current version of SDR#, but this problem started several versions ago (I'm not sure exactly when, because I hadn't upgraded for a very long time but wanted to try out the recent version with a bandplan display.) Every so often, my mouse will freeze for a brief time. I don't need to be accessing my RTL stick for this to happen, all that needs to happen is that SDR# is open, receiving anything or not. Using the RTL stick in HDSDR doesn't cause this problem. Has anyone else seen anything like this?
There is clearly a problem with all recent versions of SDR#. the problem I have is sometimes if I move the mouse, there will be a sudden increase in noise in the displayed spectrum. It will go away if I stop SDR# and restart it. This is another example showing that SDR# is somehow inappropriately interacting with the mouse.

That being said, I love SDR# and my AirSpy (more than my SDRPlay, HDSDR, and SDR Console).
 

Jim_Shaffer

Member
Premium Subscriber
Joined
Mar 31, 2013
Messages
47
Does it make the sound in Windows that hardware is being disconnected and what is your rigs processor and motherboard? I had the same thing happen with my desktop which is an AMD FX with an ASROCK Extreame 3 motherboard. The laptop i use now for SDR is an AMD Phenom II and it does not disconnect the mouse.
No, it does NOT make the disconnect noise.

CPU is Intel Core i5-3570K, motherboard is Asrock Z77 Extreme 4.
 

thewraith2008

Member
Joined
Nov 22, 2016
Messages
752
Did you install over the old SDR# installation with the new. Maybe some files did not overwrite old ones.
Maybe try a fresh install.

Have you added Frontends or Plug-ins to the SDR# installation. If so try removing them one at a time to see if they fix the mouse conflict.

Shutdown SDR# then remove applicable DLL from the SDR# folder and entry from 'FrontEnd.xml' or 'plugins.xml' file. Then restart SDR#.

Most of the plugins have not been updated since about 2014 while SDR# has continued development and changed the .NET framework.

Cheers
 
Status
Not open for further replies.
Top