SDRplay DUO not detected by Windows 10 x64 anymore

jazzboypro

Member
Premium Subscriber
Joined
Aug 7, 2019
Messages
72
Location
Laval
Hello all,

Last Friday i received my SDRplay duo. Prior to buying it, i checked with them to make sure that both the device and their software were fully compatible with Windows 10 x64. I installed their SDRuno software on a Dell Laptop running Windows 10 x64. It worked well the whole weekend.

As of yesterday, when i plug the device in my laptop, it is detected as an unknown device and 2-3 seconds later it is removed as if i had unplugged the device from the laptop. If i leave the device plugged in, Windows randomly tries to detect and configure the device but to no avail. I then installed their software on a second machine (Dell PC running Windows 10 x64) to my surprise, i got the same problem. I opened a case with SDRplay, they got back to me and they asked me to try another USB cable. I went to the store and bought 2 cables. I tried both cables on both machines but the problem remains. I've also tried to uninstall and reinstall the software on both machines and the problem is still there. I wrote back to SDRplay informing them of the tests i had done and they suggest that i return the unit to the vendor for testing.

Before doing that, i was wandering if any of you ran into this problem and if a solution was found.

Many thanks
 

morfis

Member
Joined
Jan 24, 2004
Messages
1,142
This won't necessarily help you but I have four windows10 64bit machines here, one of which is a Dell, and I have installed sdruno (v1.33 as I need the older API) onto each with no problems. Three installations are on machines where I use RSPduos but trying one of those in the other machine it worked fine. Each of my sdrplay receivers is used with the USB cable it was suppplied with originally
 

jazzboypro

Member
Premium Subscriber
Joined
Aug 7, 2019
Messages
72
Location
Laval
This won't necessarily help you but I have four windows10 64bit machines here, one of which is a Dell, and I have installed sdruno (v1.33 as I need the older API) onto each with no problems. Three installations are on machines where I use RSPduos but trying one of those in the other machine it worked fine. Each of my sdrplay receivers is used with the USB cable it was suppplied with originally
Installing the software is not a problem, it's just that the device is not being detected. I just tried on third Dell PC running Windows 10 x64 and i have the same problem. I don't think that all three computers have the same problem and since it work well from Friday evening to Sunday evening i don't think is a compatibility issue either.
 

N7DAN

Member
Premium Subscriber
Joined
Aug 19, 2008
Messages
20
Location
Phoenix,Arizona
Any help would be greatly appreciated,
I Also just a bought a RSPDX, does anyone know if this will run on a Microsoft Surface tablet running Windows 10pro
8GB RAM, 64-bit
When I start SDRuno it fails no rsp connected , check USB cable ? What I’m I doing wrong ?
thanks !
 

jazzboypro

Member
Premium Subscriber
Joined
Aug 7, 2019
Messages
72
Location
Laval
Last week a SDRplay technician connected to my laptop (TeamViewer) and he was able to see the problem i was having. The computer can enumerate the USB device (the SDR) but it sees it as an unrecognized device. After some troubleshooting he concluded that there is something wrong with the SDR's firmware. I sent the SDR to the vendor yesterday.
 

N7DAN

Member
Premium Subscriber
Joined
Aug 19, 2008
Messages
20
Location
Phoenix,Arizona
Thanks for the replies......
I have uninstalled and reinstalled the drivers, the soft2are. I can see the device in the Device properties.
NO LUCK......
i was able to connect with a third party software on my iMac.
is there Another software option to try on a surface tablet ?
thanks,

N7DAN
 

morfis

Member
Joined
Jan 24, 2004
Messages
1,142
Installing the software is not a problem, it's just that the device is not being detected. I just tried on third Dell PC running Windows 10 x64 and i have the same problem. I don't think that all three computers have the same problem and since it work well from Friday evening to Sunday evening i don't think is a compatibility issue either.
Which was my point, software installs fine on all and each device worked fine on any of the PCs so that suggests 'windows 10' and Dell were unlikley to be the problem.

Good to hear that sdrplay think they identified the problem and are swapping the unit. Hopefully you'll get a working device back quickly and be able to enjoy using it again.
 

jazzboypro

Member
Premium Subscriber
Joined
Aug 7, 2019
Messages
72
Location
Laval
Which was my point, software installs fine on all and each device worked fine on any of the PCs so that suggests 'windows 10' and Dell were unlikley to be the problem.

Good to hear that sdrplay think they identified the problem and are swapping the unit. Hopefully you'll get a working device back quickly and be able to enjoy using it again.
I will report when i get the new unit. It will probably take a while, postal service has been very slow since the beginning of the COVID crisis
 

jazzboypro

Member
Premium Subscriber
Joined
Aug 7, 2019
Messages
72
Location
Laval
Just got my replacement unit, i have not fully tested it yet but it does not exhibit the problem and i was receiving signals. I don't know exactly what the problem was. I hope it was just bad luck and that this problem won't come back.
 
Top