SDS 100 won't charge

Status
Not open for further replies.

KJ4ION

Newbie
Joined
Aug 16, 2019
Messages
4
Hopefully someone can point me in the right direction. Received my new Uniden SDS 100 scanner yesterday. The scanner will not charge. When I plug the scanner in the LED lights do not indicate that it is charging (neither red or green, the LEDs never illuminate). It doesn't make a difference if the scanner is on (set charge while on is enabled) or not. If it is not turned on when I plug it in it does absolutely nothing. No LEDs, nothing on the screen at all. Additionally, the battery is now depleted and the scanner will not even turn on unless it is plugged in. Am I missing something or is my unit defective? I saw other threads where the scanner was having issues not charging when it was powered on, but I didn't see anything that fit my situation. The unit won't charge at all, period. Any ideas? Anything I should try? Any suggestions or help is appreciated. On a side note, other than this issue, I love the scanner. Reception is much better and it is an awesome upgrade from my BCD436HP.
 

trentbob

Member
Premium Subscriber
Joined
Feb 22, 2007
Messages
2,312
Location
Bristol, Pa.
Keeping in mind that you can always return it to the vendor for a refund or exchange, you can try a different charger in case your wall wart is defective. A phone charger can work, it should be a 2A...

You can also plug it into your computer and see if that helps.

If a different or new charger doesn't work then remove the battery and examine it. There have been issues with batteries bulging. Check the seams of the battery and the shape and see if it looks abnormal.

It seems like you are trying everything.

You may just end up returning it to the vendor for an exchange.
 

trentbob

Member
Premium Subscriber
Joined
Feb 22, 2007
Messages
2,312
Location
Bristol, Pa.
Mr. Gentry, are you going to charge the O P money? That I think would be a problem using RR to solicit your business but I might be wrong on that. If you're giving this fix for free then just do it... Now.

Can't imagine what this fix would be? Especially if it was simple. Other people have had this issue. Tread carefully o p... If those suggestions made above don't work just exchange the radio for a brand new one.
 

budevans

Member
Premium Subscriber
Joined
Feb 2, 2009
Messages
2,166
Location
Cleveland, Ohio
Hopefully someone can point me in the right direction. Received my new Uniden SDS 100 scanner yesterday. The scanner will not charge. When I plug the scanner in the LED lights do not indicate that it is charging (neither red or green, the LEDs never illuminate). It doesn't make a difference if the scanner is on (set charge while on is enabled) or not. If it is not turned on when I plug it in it does absolutely nothing. No LEDs, nothing on the screen at all. Additionally, the battery is now depleted and the scanner will not even turn on unless it is plugged in. Am I missing something or is my unit defective? I saw other threads where the scanner was having issues not charging when it was powered on, but I didn't see anything that fit my situation. The unit won't charge at all, period. Any ideas? Anything I should try? Any suggestions or help is appreciated. On a side note, other than this issue, I love the scanner. Reception is much better and it is an awesome upgrade from my BCD436HP.
KJ4ION,
In your post you did not mention which USB port you plugged into. The top port can be used to power the scanner only. The top port will not charge the battery.

The bottom USB port can be used to power and or charge the battery. If you have it connected to a 2.1 amp USB power source. Such as the included Uniden power adapter.

FYI, the battery will charge faster if the scanner is turned off.
 

KK4JUG

Member
Premium Subscriber
Joined
Dec 13, 2014
Messages
3,275
Location
GA
KJ4ION,
In your post you did not mention which USB port you plugged into. The top port can be used to power the scanner only. The top port will not charge the battery.

The bottom USB port can be used to power and or charge the battery. If you have it connected to a 2.1 amp USB power source. Such as the included Uniden power adapter.

FYI, the battery will charge faster if the scanner is turned off.
You make a great point. Old timers may know about the two plugs but others might not.
 

trentbob

Member
Premium Subscriber
Joined
Feb 22, 2007
Messages
2,312
Location
Bristol, Pa.
So if he is using the cable supplied with the radio then it's only going to go into one port. He can unplug that cable and put it into another charger and see if that works in case his wall wart is defective.
 

KJ4ION

Newbie
Joined
Aug 16, 2019
Messages
4
KJ4ION,
In your post you did not mention which USB port you plugged into. The top port can be used to power the scanner only. The top port will not charge the battery.

The bottom USB port can be used to power and or charge the battery. If you have it connected to a 2.1 amp USB power source. Such as the included Uniden power adapter.

FYI, the battery will charge faster if the scanner is turned off.
Wanted to thank everyone for their responses. I have it plugged into the bottom port that is marked charge. I have connected it directly to a wall outlet using the supplied power adapter. It will not charge on or off. It will not even turn on unless it is plugged directly into the outlet. I reached out to the vendor I purchased the scanner from. They seem to think the battery is bad and is shipping me a new one. I am going to try that and if it doesn't work, send the radio back for an exchange. I just wanted to make sure i wasn't missing something obvious since I just got this radio and don't have much experience with it.
 

KJ4ION

Newbie
Joined
Aug 16, 2019
Messages
4
Wanted to provide a quick update. I received my replacement battery today. The scanner now charges as it should. So in my case it was in fact a defective battery. All is well. Thanks again.
 

tkenny53

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
153
Location
socal
I had the same problem with my first 100, a replacement was sent and it worked fine
 
Status
Not open for further replies.
Top