SpectrumForce Wideband mag mount antenna

Status
Not open for further replies.
Joined
May 22, 2005
Messages
383
Location
Gig Harbor, WA


Has anyone had experience with this antenna? Just wondering how it performs with 700 and 800 mhz radio systems? I'm planning on hooking it up to my 436hp to monitor King and Pierce Counties from my car.

Sent from my SM-G930V using Tapatalk
 

sjgostovich

Member
Premium Subscriber
Joined
Jan 15, 2010
Messages
302
Location
Hudson, WI
Mine lasted about 4 years on top of my Ford Expidtion parked outside in the elements. The whip rusted out a little and the coax is kind of cheap. It picked up my local 800 fine. I feel its more or less a disposable antenna, but i'd buy another one if the need arose.
 

DJ11DLN

Member
Premium Subscriber
Joined
Mar 23, 2013
Messages
2,117
Location
Mudhole, IN
Mine lasted about 4 years on top of my Ford Expidtion parked outside in the elements. The whip rusted out a little and the coax is kind of cheap. It picked up my local 800 fine. I feel its more or less a disposable antenna, but i'd buy another one if the need arose.
+1, they're not bad antennas. I've got one put up in my garage somewhere, ran it on the old pickup for awhile, then switched to an NMO. Decent for the price, but overall you get what you pay for.
 

AtlasFBG2

Member
Joined
Mar 10, 2015
Messages
349
Location
Fremont,Ohio
I have one I use occasionally. Works ok on the 700 MHz and 450mhz.

It holds on at 80 mph. I was kind of surprised it was still on the roof with the size of the magnet.
 
Status
Not open for further replies.
Top